]> git.pld-linux.org Git - packages/ocaml.git/blame - ocaml.spec
outdated
[packages/ocaml.git] / ocaml.spec
CommitLineData
3105856a
JB
1#
2# Conditional build:
b552f088
JB
3%bcond_without emacs # without emacs subpackage
4%bcond_without x # without X11 support
5%bcond_without tk # without Tcl/Tk support
ed19172f 6#
f4710e3c 7# --without x11 implies --without tk
1b2eae14 8%{!?with_x:%undefine with_tk}
4797676b 9
6e71517f 10%define p4ver 3.06
7ff0f82f 11%define sver 3.10
db184753 12
65fbc6c7 13Summary: The Objective Caml compiler and programming environment
6e95eae7 14Summary(pl.UTF-8): Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
65fbc6c7 15Name: ocaml
d84057ce 16Version: 3.10.2
7d1b8310 17Release: 1
4694cc06 18Epoch: 1
a13fc47d 19License: distributable
65fbc6c7 20Group: Development/Languages
7845a5c9 21Source0: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.bz2
d84057ce 22# Source0-md5: d86f8f8aa4574fa60dd6f89044580307
307e1de8 23Source1: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
7ff0f82f 24# Source1-md5: 663b31c8ea364a531aa325a5b06a2763
307e1de8 25Source2: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
7ff0f82f 26# Source2-md5: 69c7acc08ee182c97089fe0736c04e37
db184753 27Source3: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
79b42dbe 28# Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
db184753 29Source4: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
79b42dbe 30# Source4-md5: 035915d1a530aa7ec9b194d9a7d258eb
db184753 31Source5: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.html.tar.gz
79b42dbe 32# Source5-md5: 96d8eb4ca5abd58c9a280ba59f73b192
db184753 33Source6: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
79b42dbe 34# Source6-md5: fcd87c235109364242a0c9ccf176dff8
3a1adca1
JB
35Source7: http://www.ocaml.info/ocaml_sources/pure-fun-1.0.6.tar.bz2
36# Source7-md5: 94eac3fa1ac51b8ada344b04839cb43c
7db52553 37Source8: http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
79b42dbe 38# Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
69735a4b 39Source9: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
7ff0f82f 40# Source9-md5: f80b52b8bc4b10ed557808fc899acf3a
56260732 41Patch0: %{name}-build.patch
4c1e0f62
MM
42Patch1: %{name}-db3.patch
43Patch2: %{name}-objinfo.patch
3a1adca1
JB
44Patch3: %{name}-tk85support.patch
45Patch4: %{name}-CFLAGS.patch
46Patch5: %{name}-as_needed.patch
8b0de54e 47URL: http://caml.inria.fr/
3a1adca1 48BuildRequires: db-devel >= 4.1
6e71517f 49%{?with_tk:BuildRequires: tk-devel}
3232e3f5 50%{?with_x:BuildRequires: xorg-lib-libX11-devel}
f4710e3c 51%if %{with emacs}
69735a4b 52BuildRequires: sed >= 4.0
f4710e3c
MM
53BuildRequires: xemacs
54BuildRequires: xemacs-common
55BuildRequires: xemacs-fsf-compat-pkg
56%endif
4e386054 57Requires: %{name}-runtime = %{epoch}:%{version}-%{release}
5a1e52bf
PG
58Provides: ocaml-ocamldoc
59Obsoletes: ocaml-ocamldoc
151fbae6 60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65fbc6c7 61
0053154a
PS
62%define specflags -fno-strict-aliasing
63
65fbc6c7
AM
64%description
65Objective Caml is a high-level, strongly-typed, functional and
66object-oriented programming language from the ML family of languages.
67
68This package comprises two batch compilers (a fast bytecode compiler
5ca6b9fb
MP
69and an optimizing native-code compiler), an interactive toplevel
70system, Lex&Yacc tools, a replay debugger, and a comprehensive
71library.
65fbc6c7 72
3f556f71
JR
73%description -l pl.UTF-8
74OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym językiem
75wysokiego poziomu z silnym typowaniem. Należy do rodziny języków ML.
65fbc6c7 76
8151bf1e 77Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu
3f556f71
JR
78oraz optymalizujący kompilator do kodu natywnego), interaktywne środowisko
79pracy, narzędzia do tworzenia analizatorów leksykalnych oraz składniowych
8151bf1e 80(ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i biblioteki.
65fbc6c7 81
79502218
JB
82%package runtime
83Summary: Runtime system for OCaml
6e95eae7 84Summary(pl.UTF-8): Środowisko uruchomieniowe dla OCamla
79502218
JB
85Group: Libraries
86
87%description runtime
88This package contains binaries needed to run bytecode OCaml programs:
89ocamlrun bytecode interpreter, and basic dynamic link libraries.
90
3f556f71
JR
91%description runtime -l pl.UTF-8
92Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
79502218
JB
93OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
94podstawowe biblioteki linkowane dynamicznie.
95
96%package lib-source
97Summary: Sources of OCaml standard library
6e95eae7 98Summary(pl.UTF-8): Źródła biblioteki standardowej OCamla
79502218
JB
99Group: Development/Languages
100Requires: %{name} = %{epoch}:%{version}-%{release}
101
102%description lib-source
103This sources come helpful during debugging of user programs with ocamldebug.
104
3f556f71
JR
105%description lib-source -l pl.UTF-8
106Źródła te są przydatne przy odpluskwianiu programów użytkownika
107z użyciem ocamldebug.
79502218 108
69735a4b 109%package doc-html
110Summary: HTML documentation for OCaml
6e95eae7 111Summary(pl.UTF-8): Dokumentacja dla OCamla w formacie HTML
69735a4b 112Group: Development/Tools
113
114%description doc-html
115HTML documentation for OCaml.
116
3f556f71 117%description doc-html -l pl.UTF-8
69735a4b 118Dokumentacja dla OCamla w formacie HTML.
119
13b509d1 120%package doc-ps
4797676b 121Summary: PostScript documentation for OCaml
6e95eae7 122Summary(pl.UTF-8): Dokumentacja dla OCamla w formacie PostScript
4797676b 123Group: Development/Tools
4797676b 124
13b509d1 125%description doc-ps
69735a4b 126PostScript documentation for OCaml.
4797676b 127
3f556f71 128%description doc-ps -l pl.UTF-8
69735a4b 129Dokumentacja dla OCamla w formacie PostScript.
130
131%package doc-info
132Summary: Info documentation for OCaml
6e95eae7 133Summary(pl.UTF-8): Dokumentacja info dla OCamla
69735a4b 134Group: Development/Tools
135
136%description doc-info
137Info documentation for OCaml.
138
3f556f71 139%description doc-info -l pl.UTF-8
69735a4b 140Dokumentacja info dla OCamla.
4797676b 141
65fbc6c7 142%package emacs
c4a5fbda 143Summary: Emacs mode for OCaml
6e95eae7 144Summary(pl.UTF-8): Tryb OCamla dla Emacsa
65fbc6c7 145Group: Development/Tools
4694cc06 146Requires: %{name} = %{epoch}:%{version}-%{release}
65fbc6c7
AM
147
148%description emacs
981ff793 149Emacs mode files for Objective Caml language.
65fbc6c7 150
3f556f71 151%description emacs -l pl.UTF-8
8151bf1e 152Pliki trybu OCamla dla Emacsa.
56260732 153
79502218
JB
154%package labltk
155Summary: Runtime for LablTk library
6e95eae7 156Summary(pl.UTF-8): Środowisko uruchomieniowe dla biblioteki LablTk
981ff793 157Group: Libraries
79502218 158Requires: %{name} = %{epoch}:%{version}-%{release}
981ff793 159
79502218
JB
160%description labltk
161LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
162contains files needed to run bytecode OCaml programs using LablTk.
981ff793 163
3f556f71
JR
164%description labltk -l pl.UTF-8
165Biblioteka LablTk daje programom napisanym w OCamlu dostęp do widgetów
166Tcl/Tk. Pakiet ten zawiera binaria potrzebne do uruchamiania programów
167używających LablTk.
981ff793
MM
168
169%package labltk-devel
8151bf1e 170Summary: LablTk library for OCaml
6e95eae7 171Summary(pl.UTF-8): Biblioteka LablTk dla OCamla
56260732 172Group: Development/Libraries
4694cc06 173Requires: %{name}-labltk = %{epoch}:%{version}-%{release}
981ff793
MM
174
175%description labltk-devel
176LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
177contains files needed to develop OCaml programs using LablTk.
178
3f556f71
JR
179%description labltk-devel -l pl.UTF-8
180Biblioteka LablTk daje programom napisanym w OCamlu dostęp do widgetów
181Tcl/Tk. Pakiet ten zawiera pliki niezbędne do tworzenia programów
182używających LablTk.
981ff793 183
79502218
JB
184%package x11graphics
185Summary: X11 graphic output for OCaml
6e95eae7 186Summary(pl.UTF-8): Dostęp do X11 dla OCamla
79502218 187Group: Development/Libraries
4694cc06 188Requires: %{name} = %{epoch}:%{version}-%{release}
56260732 189
79502218
JB
190%description x11graphics
191x11graphics module gives OCaml program access to drawing in X11
192windows. This package contains files needed to run bytecode OCaml
193programs using x11graphics.
56260732 194
3f556f71
JR
195%description x11graphics -l pl.UTF-8
196Moduł x11graphics daje programom napisanym w OCamlu możliwość
79502218 197korzystania z interfejsu graficznego X11. Pakiet ten zawiera binaria
3f556f71 198potrzebne do uruchamiania programów używających x11graphics.
981ff793
MM
199
200%package x11graphics-devel
201Summary: X11 graphic output for OCaml
6e95eae7 202Summary(pl.UTF-8): Dostęp do X11 dla OCamla
981ff793 203Group: Development/Libraries
4694cc06 204Requires: %{name}-x11graphics = %{epoch}:%{version}-%{release}
981ff793
MM
205
206%description x11graphics-devel
207x11graphics module gives OCaml program access to drawing in X11
208windows. This package contains files needed to develop OCaml programs
209using x11graphics.
210
3f556f71
JR
211%description x11graphics-devel -l pl.UTF-8
212Moduł x11graphics daje programom napisanym w OCamlu możliwość
8151bf1e 213korzystania z interfejsu graficznego X11. Pakiet ten zawiera pliki
3f556f71 214niezbędne do tworzenia programów używających x11graphics.
56260732 215
56260732
MM
216%package camlp4
217Summary: Objective Caml Preprocessor
6e95eae7 218Summary(pl.UTF-8): Preprocesor OCamla
56260732 219Group: Development/Languages
4694cc06 220Requires: %{name} = %{epoch}:%{version}-%{release}
221Provides: camlp4 = %{epoch}:%{version}-%{release}
56260732
MM
222Obsoletes: camlp4
223
224%description camlp4
225Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
226tools for syntax (grammars) and the ability to modify the concrete
227syntax of the language (quotations, syntax extensions).
228
229Camlp4 can parse normal Ocaml concrete syntax or any other
230user-definable syntax. As an example, an alternative syntax is
231provided, named revised, because it tries to fix some small problems
232of the normal syntax.
233
234Camlp4 can pretty print the normal Ocaml concrete syntax or the
235revised one. It is therefore always possible to have a version of your
8151bf1e 236sources compilable by the Objective Caml compiler without
56260732
MM
237preprocessing.
238
3f556f71
JR
239%description camlp4 -l pl.UTF-8
240Camlp4 jest preprocesorem OCamla. Oferuje narzędzia do manipulowania
241składnią (gramatyki) oraz możliwość modyfikowania oryginalnej składni
242języka (cytowania, rozszerzenia).
56260732 243
3f556f71
JR
244Camlp4 może sparsować oryginalną składnię Ocamla lub dowolną inną
245definiowalną przez użytkownika. Jako przykład podana jest alternatywna
246składnia (revised syntax), która próbuje poprawić drobne problemy
247występujące w składni oryginalnej.
56260732 248
3f556f71
JR
249Camlp4 umie ładnie formatować źródła zarówno w oryginalnej jak i
250poprawionej składni OCamla. Potrafi także tłumaczyć programy z jednej
251składni na drugą.
65fbc6c7 252
69735a4b 253%package camlp4-doc-html
254Summary: Objective Caml Preprocessor - HTML documentation
6e95eae7 255Summary(pl.UTF-8): Preprocesor OCamla - dokumentacja HTML
69735a4b 256Group: Development/Languages
257
258%description camlp4-doc-html
259Objective Caml Preprocessor - HTML documentation.
260
3f556f71 261%description camlp4-doc-html -l pl.UTF-8
69735a4b 262Preprocesor OCamla - dokumentacja HTML.
263
6dfc0e1a 264%package compiler-objects
981ff793 265Summary: Compiled parts of OCaml compiler
6e95eae7 266Summary(pl.UTF-8): Skompilowane części kompilatora OCamla
981ff793 267Group: Development/Languages
4694cc06 268Requires: %{name} = %{epoch}:%{version}-%{release}
68076664 269Obsoletes: ocaml-devel
6adc6dd7 270Provides: ocaml-devel
981ff793 271
6dfc0e1a 272%description compiler-objects
981ff793
MM
273This package contains *.cmi and *.cmo files being parts of OCaml
274compiler. They are needed to compile some programs.
275
3f556f71
JR
276%description compiler-objects -l pl.UTF-8
277Pakiet ten zawiera pliki *.cmi oraz *.cmo będące częściami kompilatora
278OCamla. Są one wymagane do kompilacji niektórych programów.
981ff793 279
13b509d1
MM
280%package ocamldoc-devel
281Summary: Files needed to develop programs using ocamldoc
6e95eae7 282Summary(pl.UTF-8): Pliki potrzebne do tworzenia programów używających ocamldoc
13b509d1 283Group: Development/Languages
4694cc06 284Requires: %{name} = %{epoch}:%{version}-%{release}
13b509d1
MM
285
286%description ocamldoc-devel
287You need this package if you are going to write ocamldoc front end or
288something like that.
289
3f556f71
JR
290%description ocamldoc-devel -l pl.UTF-8
291Będziesz potrzebować tego pakietu, jeśli zamierzasz pisać front end
292dla ocamldoc lub coś podobnego.
13b509d1 293
53fbd845
MM
294# maybe we'll want to add some more stuff here?
295%package examples
296Summary: Example source code for OCaml
6e95eae7 297Summary(pl.UTF-8): Przykładowe kody źródłowe w OCamlu
53fbd845 298Group: Development/Languages
4694cc06 299Requires: %{name} = %{epoch}:%{version}-%{release}
53fbd845
MM
300
301%description examples
63004413 302This packages contains sources for Okasaki's Purely Functional
53fbd845
MM
303Datastructures in OCaml, along with some contributions.
304
3f556f71
JR
305%description examples -l pl.UTF-8
306Pakiet ten zawiera źródła Czysto Funkcyjnych Struktur Danych
8151bf1e 307autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
53fbd845 308
65fbc6c7 309%prep
307e1de8 310%setup -q -a1 -a3 -a5
19e77905
JB
311mkdir examples
312tar xjf %{SOURCE7} -C examples
313tar xzf %{SOURCE8} -C examples
69735a4b 314tar xzf %{SOURCE9}
56260732 315# order mess with docs somewhat
69735a4b 316mkdir -p docs/html
56260732 317mv htmlman docs/html/ocaml
fa4b2219 318cp %{SOURCE2} docs/ocaml.ps.gz
db184753 319mv camlp4-%{p4ver}-manual.html docs/html/camlp4
fa4b2219 320cp %{SOURCE4} docs/camlp4.ps.gz
db184753 321mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
fa4b2219 322cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
56260732 323%patch0 -p1
4c1e0f62 324%patch1 -p1
56260732 325%patch2 -p1
3a1adca1 326%patch3 -p1
f2f21d95 327%patch4 -p1
04508f14 328%patch5 -p1
69735a4b 329
330%build
ed19172f 331cp -f /usr/share/automake/config.sub config/gnu
65fbc6c7 332./configure \
69735a4b 333 -cc "%{__cc}" \
65fbc6c7
AM
334 -bindir %{_bindir} \
335 -libdir %{_libdir}/%{name} \
336 -mandir %{_mandir}/man1 \
530dec71 337 -host %{_host} \
f4710e3c 338 %{!?with_tk:-no-tk} \
2e6ceb74 339 -with-pthread \
0053154a 340 -x11lib %{_libdir}
65fbc6c7 341
bf9b6da9 342%{__make} -j1 world bootstrap opt.opt CFLAGS="%{rpmcflags} -Wall"
7ae05805 343%{__make} -C tools objinfo CFLAGS="%{rpmcflags} -Wall" -j1
65fbc6c7 344
e1542d3b
JB
345# broken build system
346sed -e 's,LIBDIR,%{_libdir},' camlp4/man/camlp4.1.tpl > camlp4/man/camlp4.1
347
65fbc6c7 348%install
5ca6b9fb 349rm -rf $RPM_BUILD_ROOT
69735a4b 350install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
7ff0f82f 351install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/site-lib
e42e1457 352
7ae05805 353%{__make} install \
13b509d1
MM
354 BINDIR=$RPM_BUILD_ROOT%{_bindir} \
355 LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} \
356 MANDIR=$RPM_BUILD_ROOT%{_mandir}
357
358cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
359%{_libdir}/%{name}/stublibs
360%{_libdir}/%{name}
361EOF
4797676b 362
f4710e3c 363%if %{with emacs}
7ae05805 364%{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
65fbc6c7
AM
365 EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
366 else echo xemacs; fi`" \
8151bf1e 367 EMACSDIR="$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp"
56260732
MM
368%endif
369
981ff793 370# symlink .opt versions of compilers (if present)
13b509d1
MM
371# warning: don't do that with camlp4 (can't load extensions then)
372for f in ocamlc ocamlopt ocamldoc ocamllex; do
067af37d
MM
373 if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
374 mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
375 $RPM_BUILD_ROOT%{_bindir}/$f.byte
376 ln -sf %{_bindir}/$f.opt $RPM_BUILD_ROOT%{_bindir}/$f
377 fi
1511bcd5 378done
65fbc6c7 379
981ff793 380# move includes to the proper place
ba35c88b 381mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
981ff793 382# but leave compatibility symlink
379cf672 383ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
981ff793 384
360c386d
MM
385# compiled sources of compiler, needed by some programs
386for f in {asm,byte}comp parsing typing utils ; do
387 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
388 cp $f/*.{cmi,cmo,cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
389done
981ff793
MM
390
391# this isn't installed by default, but is useful
392install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
53fbd845 393cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
13b509d1 394cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
56260732
MM
395ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
396
13b509d1 397# shutup checkfiles
f442d039 398rm -rf $RPM_BUILD_ROOT%{_mandir}/man3
13b509d1
MM
399rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
400
69735a4b 401# install info pages
402cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
403
e1542d3b
JB
404# broken build system
405install camlp4/man/camlp4.1 $RPM_BUILD_ROOT%{_mandir}/man1
406for f in camlp4o.1 camlp4r.1 mkcamlp4.1 camlp4o.opt.1 camlp4r.opt.1 ; do
407 echo '.so camlp4.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
408done
409
65fbc6c7
AM
410%clean
411rm -rf $RPM_BUILD_ROOT
412
4a452533
ER
413%post doc-info -p /sbin/postshell
414-/usr/sbin/fix-info-dir -c %{_infodir}
69735a4b 415
4a452533
ER
416%postun doc-info -p /sbin/postshell
417-/usr/sbin/fix-info-dir -c %{_infodir}
69735a4b 418
65fbc6c7
AM
419%files
420%defattr(644,root,root,755)
f1920819 421%doc LICENSE Changes README Upgrading
13b509d1 422%attr(755,root,root) %{_bindir}/ocaml*
dd90c8d9 423%{?with_tk:%exclude %{_bindir}/ocamlbrowser}
13b509d1 424%exclude %{_bindir}/ocamlrun
73a93122 425%attr(755,root,root) %{_bindir}/*labels
ba35c88b 426%{_includedir}/caml
530dec71 427%{_libdir}/%{name}/caml
530dec71 428%{_libdir}/%{name}/threads
4c1e0f62
MM
429%dir %{_libdir}/%{name}/vmthreads
430%dir %{_libdir}/%{name}/vmthreads/*.cm*
431%dir %{_libdir}/%{name}/vmthreads/*.a
13b509d1
MM
432%{_libdir}/%{name}/*.a
433%{_libdir}/%{name}/*.o
434%{_libdir}/%{name}/*.cm*
435%exclude %{_libdir}/%{name}/*graphics*
dd90c8d9 436%{_libdir}/%{name}/Makefile.config
4251bfb1 437%{_libdir}/%{name}/ld.conf
56260732
MM
438%{_libdir}/%{name}/camlheader
439%{_libdir}/%{name}/camlheader_ur
7ff0f82f 440%{_libdir}/%{name}/ocamlbuild
13b509d1 441%dir %{_libdir}/%{name}/ocamldoc
13b509d1
MM
442%{_libdir}/%{name}/ocamldoc/*.hva
443%attr(755,root,root) %{_libdir}/%{name}/expunge
444%attr(755,root,root) %{_libdir}/%{name}/extract_crc
56260732 445%attr(755,root,root) %{_libdir}/%{name}/*labels
13b509d1
MM
446%{_mandir}/man1/*ocaml*
447
79502218
JB
448%files runtime
449%defattr(644,root,root,755)
450%attr(755,root,root) %{_bindir}/ocamlrun
451%dir %{_libdir}/%{name}
7ff0f82f 452%dir %{_libdir}/%{name}/site-lib
79502218
JB
453%dir %{_libdir}/%{name}/stublibs
454%attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
455%exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
456%if %{with tk}
457%exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
458%exclude %{_libdir}/%{name}/stublibs/dlltkanim.so
459%endif
460
13b509d1
MM
461%files lib-source
462%defattr(644,root,root,755)
463%{_libdir}/%{name}/*.ml
8151bf1e 464%{_libdir}/%{name}/*.mli
4c1e0f62 465%{_libdir}/%{name}/*/*.mli
13b509d1 466
79502218 467%files doc-html
763b9075 468%defattr(644,root,root,755)
79502218
JB
469%doc docs/html/ocaml/*
470
471%files doc-ps
472%defattr(644,root,root,755)
473%doc docs/*.ps.gz
474
475%files doc-info
476%defattr(644,root,root,755)
477%{_infodir}/ocaml.info*
53fbd845 478
13b509d1
MM
479# they are poor, html is much better
480#%files manpages
e68873d9 481#%%{_mandir}/man3/*
65fbc6c7 482
79502218
JB
483%if %{with emacs}
484%files emacs
56260732 485%defattr(644,root,root,755)
79502218
JB
486%{_datadir}/emacs/site-lisp/*.el*
487%endif
56260732 488
79502218
JB
489%if %{with tk}
490%files labltk
69735a4b 491%defattr(644,root,root,755)
79502218
JB
492%attr(755,root,root) %{_libdir}/%{name}/stublibs/dlllabltk.so
493%attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
69735a4b 494
981ff793 495%files labltk-devel
56260732 496%defattr(644,root,root,755)
73a93122 497%attr(755,root,root) %{_bindir}/labltk
498%attr(755,root,root) %{_bindir}/ocamlbrowser
56260732
MM
499%dir %{_libdir}/%{name}/labltk
500%{_libdir}/%{name}/labltk/*.cm*
501%{_libdir}/%{name}/labltk/*.a
73a93122 502%attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
ba35c88b 503%{_examplesdir}/%{name}-labltk-%{version}
56260732
MM
504%endif
505
b552f088 506%if %{with x}
79502218
JB
507%files x11graphics
508%defattr(644,root,root,755)
509%attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
510
981ff793 511%files x11graphics-devel
56260732 512%defattr(644,root,root,755)
13b509d1 513%{_libdir}/%{name}/graphics*.cm*
f442d039 514%{_libdir}/%{name}/graphics.a
56260732 515%{_libdir}/%{name}/libgraphics.a
56260732
MM
516%endif
517
79502218 518%files camlp4
65fbc6c7 519%defattr(644,root,root,755)
e1542d3b
JB
520%attr(755,root,root) %{_bindir}/camlp4*
521%attr(755,root,root) %{_bindir}/mkcamlp4
79502218 522%{_libdir}/%{name}/camlp4
e1542d3b
JB
523%{_mandir}/man1/camlp4*.1*
524%{_mandir}/man1/mkcamlp4.1*
4797676b 525
79502218 526%files camlp4-doc-html
13b509d1 527%defattr(644,root,root,755)
79502218 528%doc docs/html/camlp4*
13b509d1 529
79502218 530%files compiler-objects
69735a4b 531%defattr(644,root,root,755)
79502218 532%{_libdir}/%{name}/compiler
69735a4b 533
79502218 534%files ocamldoc-devel
73a93122 535%defattr(644,root,root,755)
79502218
JB
536%{_libdir}/%{name}/ocamldoc/*.cm*
537%{_libdir}/%{name}/ocamldoc/*.a
69735a4b 538
79502218 539%files examples
69735a4b 540%defattr(644,root,root,755)
79502218 541%{_examplesdir}/%{name}-%{version}
This page took 0.129891 seconds and 4 git commands to generate.