]> git.pld-linux.org Git - packages/ocaml.git/blame - ocaml.spec
- rel 21; fix build with tcl/tk 8.6
[packages/ocaml.git] / ocaml.spec
CommitLineData
3105856a
JB
1#
2# Conditional build:
b552f088
JB
3%bcond_without emacs # without emacs subpackage
4%bcond_without x # without X11 support
5%bcond_without tk # without Tcl/Tk support
ed19172f 6#
f4710e3c 7# --without x11 implies --without tk
1b2eae14 8%{!?with_x:%undefine with_tk}
4797676b 9
6e71517f 10%define p4ver 3.06
9de25172 11%define sver 3.12
db184753 12
65fbc6c7 13Summary: The Objective Caml compiler and programming environment
6e95eae7 14Summary(pl.UTF-8): Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
65fbc6c7 15Name: ocaml
356fa1c2 16Version: 3.12.1
0d424b76 17Release: 21
4694cc06 18Epoch: 1
a13fc47d 19License: distributable
65fbc6c7 20Group: Development/Languages
7845a5c9 21Source0: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.bz2
356fa1c2 22# Source0-md5: 227a3daaedb150bf5037a3db01f5bf42
307e1de8 23Source1: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
9de25172 24# Source1-md5: 93cd91f525441eb7e94cc49b9b64bab0
307e1de8 25Source2: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
9de25172
JB
26# Source2-md5: a9c17db6ffd400c5ea00c6d51cbf56bf
27Source3: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
28# Source3-md5: 8cf24c4f69c6f9c9f9cc1edb9b18f6cb
29Source4: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
30# Source4-md5: 21370bae4e7f6435b38aeb21db7ce8bb
31Source5: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
32# Source5-md5: 035915d1a530aa7ec9b194d9a7d258eb
33Source6: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.html.tar.gz
34# Source6-md5: 96d8eb4ca5abd58c9a280ba59f73b192
35Source7: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
36# Source7-md5: fcd87c235109364242a0c9ccf176dff8
37Source8: http://www.ocaml.info/ocaml_sources/pure-fun-1.0.6.tar.bz2
38# Source8-md5: 94eac3fa1ac51b8ada344b04839cb43c
39Source9: http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
40# Source9-md5: 77fa1da7375dea1393cc0b6cd802d7e1
42946d4f 41Patch0: %{name}-db3.patch
9de25172
JB
42Patch1: %{name}-CFLAGS.patch
43Patch2: %{name}-as_needed.patch
44Patch3: %{name}-gas.patch
0d424b76 45Patch4: %{name}-tcl86.patch
8b0de54e 46URL: http://caml.inria.fr/
3a1adca1 47BuildRequires: db-devel >= 4.1
6e71517f 48%{?with_tk:BuildRequires: tk-devel}
3232e3f5 49%{?with_x:BuildRequires: xorg-lib-libX11-devel}
f4710e3c 50%if %{with emacs}
69735a4b 51BuildRequires: sed >= 4.0
3889f6d2
JR
52BuildRequires: emacs
53BuildRequires: emacs-common
f4710e3c 54%endif
4e386054 55Requires: %{name}-runtime = %{epoch}:%{version}-%{release}
5a1e52bf
PG
56Provides: ocaml-ocamldoc
57Obsoletes: ocaml-ocamldoc
151fbae6 58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65fbc6c7 59
0053154a
PS
60%define specflags -fno-strict-aliasing
61
65fbc6c7
AM
62%description
63Objective Caml is a high-level, strongly-typed, functional and
64object-oriented programming language from the ML family of languages.
65
66This package comprises two batch compilers (a fast bytecode compiler
5ca6b9fb
MP
67and an optimizing native-code compiler), an interactive toplevel
68system, Lex&Yacc tools, a replay debugger, and a comprehensive
69library.
65fbc6c7 70
3f556f71
JR
71%description -l pl.UTF-8
72OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym językiem
73wysokiego poziomu z silnym typowaniem. Należy do rodziny języków ML.
65fbc6c7 74
8151bf1e 75Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu
3f556f71
JR
76oraz optymalizujący kompilator do kodu natywnego), interaktywne środowisko
77pracy, narzędzia do tworzenia analizatorów leksykalnych oraz składniowych
8151bf1e 78(ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i biblioteki.
65fbc6c7 79
79502218
JB
80%package runtime
81Summary: Runtime system for OCaml
6e95eae7 82Summary(pl.UTF-8): Środowisko uruchomieniowe dla OCamla
79502218
JB
83Group: Libraries
84
85%description runtime
86This package contains binaries needed to run bytecode OCaml programs:
87ocamlrun bytecode interpreter, and basic dynamic link libraries.
88
3f556f71
JR
89%description runtime -l pl.UTF-8
90Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
79502218
JB
91OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
92podstawowe biblioteki linkowane dynamicznie.
93
94%package lib-source
95Summary: Sources of OCaml standard library
6e95eae7 96Summary(pl.UTF-8): Źródła biblioteki standardowej OCamla
79502218
JB
97Group: Development/Languages
98Requires: %{name} = %{epoch}:%{version}-%{release}
99
100%description lib-source
101This sources come helpful during debugging of user programs with ocamldebug.
102
3f556f71
JR
103%description lib-source -l pl.UTF-8
104Źródła te są przydatne przy odpluskwianiu programów użytkownika
105z użyciem ocamldebug.
79502218 106
69735a4b 107%package doc-html
108Summary: HTML documentation for OCaml
6e95eae7 109Summary(pl.UTF-8): Dokumentacja dla OCamla w formacie HTML
69735a4b 110Group: Development/Tools
111
112%description doc-html
113HTML documentation for OCaml.
114
3f556f71 115%description doc-html -l pl.UTF-8
69735a4b 116Dokumentacja dla OCamla w formacie HTML.
117
13b509d1 118%package doc-ps
4797676b 119Summary: PostScript documentation for OCaml
6e95eae7 120Summary(pl.UTF-8): Dokumentacja dla OCamla w formacie PostScript
4797676b 121Group: Development/Tools
4797676b 122
13b509d1 123%description doc-ps
69735a4b 124PostScript documentation for OCaml.
4797676b 125
3f556f71 126%description doc-ps -l pl.UTF-8
69735a4b 127Dokumentacja dla OCamla w formacie PostScript.
128
129%package doc-info
130Summary: Info documentation for OCaml
6e95eae7 131Summary(pl.UTF-8): Dokumentacja info dla OCamla
69735a4b 132Group: Development/Tools
133
134%description doc-info
135Info documentation for OCaml.
136
3f556f71 137%description doc-info -l pl.UTF-8
69735a4b 138Dokumentacja info dla OCamla.
4797676b 139
65fbc6c7 140%package emacs
c4a5fbda 141Summary: Emacs mode for OCaml
6e95eae7 142Summary(pl.UTF-8): Tryb OCamla dla Emacsa
65fbc6c7 143Group: Development/Tools
4694cc06 144Requires: %{name} = %{epoch}:%{version}-%{release}
65fbc6c7
AM
145
146%description emacs
981ff793 147Emacs mode files for Objective Caml language.
65fbc6c7 148
3f556f71 149%description emacs -l pl.UTF-8
8151bf1e 150Pliki trybu OCamla dla Emacsa.
56260732 151
79502218
JB
152%package labltk
153Summary: Runtime for LablTk library
6e95eae7 154Summary(pl.UTF-8): Środowisko uruchomieniowe dla biblioteki LablTk
981ff793 155Group: Libraries
79502218 156Requires: %{name} = %{epoch}:%{version}-%{release}
981ff793 157
79502218
JB
158%description labltk
159LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
160contains files needed to run bytecode OCaml programs using LablTk.
981ff793 161
3f556f71
JR
162%description labltk -l pl.UTF-8
163Biblioteka LablTk daje programom napisanym w OCamlu dostęp do widgetów
164Tcl/Tk. Pakiet ten zawiera binaria potrzebne do uruchamiania programów
165używających LablTk.
981ff793
MM
166
167%package labltk-devel
8151bf1e 168Summary: LablTk library for OCaml
6e95eae7 169Summary(pl.UTF-8): Biblioteka LablTk dla OCamla
56260732 170Group: Development/Libraries
4694cc06 171Requires: %{name}-labltk = %{epoch}:%{version}-%{release}
981ff793
MM
172
173%description labltk-devel
174LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
175contains files needed to develop OCaml programs using LablTk.
176
3f556f71
JR
177%description labltk-devel -l pl.UTF-8
178Biblioteka LablTk daje programom napisanym w OCamlu dostęp do widgetów
179Tcl/Tk. Pakiet ten zawiera pliki niezbędne do tworzenia programów
180używających LablTk.
981ff793 181
79502218
JB
182%package x11graphics
183Summary: X11 graphic output for OCaml
6e95eae7 184Summary(pl.UTF-8): Dostęp do X11 dla OCamla
79502218 185Group: Development/Libraries
4694cc06 186Requires: %{name} = %{epoch}:%{version}-%{release}
56260732 187
79502218
JB
188%description x11graphics
189x11graphics module gives OCaml program access to drawing in X11
190windows. This package contains files needed to run bytecode OCaml
191programs using x11graphics.
56260732 192
3f556f71
JR
193%description x11graphics -l pl.UTF-8
194Moduł x11graphics daje programom napisanym w OCamlu możliwość
79502218 195korzystania z interfejsu graficznego X11. Pakiet ten zawiera binaria
3f556f71 196potrzebne do uruchamiania programów używających x11graphics.
981ff793
MM
197
198%package x11graphics-devel
199Summary: X11 graphic output for OCaml
6e95eae7 200Summary(pl.UTF-8): Dostęp do X11 dla OCamla
981ff793 201Group: Development/Libraries
4694cc06 202Requires: %{name}-x11graphics = %{epoch}:%{version}-%{release}
981ff793
MM
203
204%description x11graphics-devel
205x11graphics module gives OCaml program access to drawing in X11
206windows. This package contains files needed to develop OCaml programs
207using x11graphics.
208
3f556f71
JR
209%description x11graphics-devel -l pl.UTF-8
210Moduł x11graphics daje programom napisanym w OCamlu możliwość
8151bf1e 211korzystania z interfejsu graficznego X11. Pakiet ten zawiera pliki
3f556f71 212niezbędne do tworzenia programów używających x11graphics.
56260732 213
56260732
MM
214%package camlp4
215Summary: Objective Caml Preprocessor
6e95eae7 216Summary(pl.UTF-8): Preprocesor OCamla
56260732 217Group: Development/Languages
4694cc06 218Requires: %{name} = %{epoch}:%{version}-%{release}
219Provides: camlp4 = %{epoch}:%{version}-%{release}
56260732
MM
220Obsoletes: camlp4
221
222%description camlp4
223Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
224tools for syntax (grammars) and the ability to modify the concrete
225syntax of the language (quotations, syntax extensions).
226
227Camlp4 can parse normal Ocaml concrete syntax or any other
228user-definable syntax. As an example, an alternative syntax is
229provided, named revised, because it tries to fix some small problems
230of the normal syntax.
231
232Camlp4 can pretty print the normal Ocaml concrete syntax or the
233revised one. It is therefore always possible to have a version of your
8151bf1e 234sources compilable by the Objective Caml compiler without
56260732
MM
235preprocessing.
236
3f556f71
JR
237%description camlp4 -l pl.UTF-8
238Camlp4 jest preprocesorem OCamla. Oferuje narzędzia do manipulowania
239składnią (gramatyki) oraz możliwość modyfikowania oryginalnej składni
240języka (cytowania, rozszerzenia).
56260732 241
3f556f71
JR
242Camlp4 może sparsować oryginalną składnię Ocamla lub dowolną inną
243definiowalną przez użytkownika. Jako przykład podana jest alternatywna
244składnia (revised syntax), która próbuje poprawić drobne problemy
245występujące w składni oryginalnej.
56260732 246
3f556f71
JR
247Camlp4 umie ładnie formatować źródła zarówno w oryginalnej jak i
248poprawionej składni OCamla. Potrafi także tłumaczyć programy z jednej
249składni na drugą.
65fbc6c7 250
69735a4b 251%package camlp4-doc-html
252Summary: Objective Caml Preprocessor - HTML documentation
6e95eae7 253Summary(pl.UTF-8): Preprocesor OCamla - dokumentacja HTML
69735a4b 254Group: Development/Languages
255
256%description camlp4-doc-html
257Objective Caml Preprocessor - HTML documentation.
258
3f556f71 259%description camlp4-doc-html -l pl.UTF-8
69735a4b 260Preprocesor OCamla - dokumentacja HTML.
261
6dfc0e1a 262%package compiler-objects
981ff793 263Summary: Compiled parts of OCaml compiler
6e95eae7 264Summary(pl.UTF-8): Skompilowane części kompilatora OCamla
981ff793 265Group: Development/Languages
4694cc06 266Requires: %{name} = %{epoch}:%{version}-%{release}
68076664 267Obsoletes: ocaml-devel
6adc6dd7 268Provides: ocaml-devel
981ff793 269
6dfc0e1a 270%description compiler-objects
981ff793
MM
271This package contains *.cmi and *.cmo files being parts of OCaml
272compiler. They are needed to compile some programs.
273
3f556f71
JR
274%description compiler-objects -l pl.UTF-8
275Pakiet ten zawiera pliki *.cmi oraz *.cmo będące częściami kompilatora
276OCamla. Są one wymagane do kompilacji niektórych programów.
981ff793 277
13b509d1
MM
278%package ocamldoc-devel
279Summary: Files needed to develop programs using ocamldoc
6e95eae7 280Summary(pl.UTF-8): Pliki potrzebne do tworzenia programów używających ocamldoc
13b509d1 281Group: Development/Languages
4694cc06 282Requires: %{name} = %{epoch}:%{version}-%{release}
13b509d1
MM
283
284%description ocamldoc-devel
285You need this package if you are going to write ocamldoc front end or
286something like that.
287
3f556f71
JR
288%description ocamldoc-devel -l pl.UTF-8
289Będziesz potrzebować tego pakietu, jeśli zamierzasz pisać front end
290dla ocamldoc lub coś podobnego.
13b509d1 291
53fbd845
MM
292# maybe we'll want to add some more stuff here?
293%package examples
294Summary: Example source code for OCaml
6e95eae7 295Summary(pl.UTF-8): Przykładowe kody źródłowe w OCamlu
53fbd845 296Group: Development/Languages
4694cc06 297Requires: %{name} = %{epoch}:%{version}-%{release}
53fbd845
MM
298
299%description examples
63004413 300This packages contains sources for Okasaki's Purely Functional
53fbd845
MM
301Datastructures in OCaml, along with some contributions.
302
3f556f71
JR
303%description examples -l pl.UTF-8
304Pakiet ten zawiera źródła Czysto Funkcyjnych Struktur Danych
8151bf1e 305autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
53fbd845 306
65fbc6c7 307%prep
9de25172 308%setup -q -a1 -a3 -a4 -a6
19e77905 309mkdir examples
9de25172
JB
310tar xjf %{SOURCE8} -C examples
311tar xzf %{SOURCE9} -C examples
56260732 312# order mess with docs somewhat
69735a4b 313mkdir -p docs/html
56260732 314mv htmlman docs/html/ocaml
fa4b2219 315cp %{SOURCE2} docs/ocaml.ps.gz
db184753 316mv camlp4-%{p4ver}-manual.html docs/html/camlp4
9de25172 317cp %{SOURCE5} docs/camlp4.ps.gz
db184753 318mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
9de25172 319cp %{SOURCE7} docs/camlp4-tutorial.ps.gz
56260732 320%patch0 -p1
4c1e0f62 321%patch1 -p1
56260732 322%patch2 -p1
3a1adca1 323%patch3 -p1
0d424b76 324%patch4 -p1
69735a4b 325
326%build
ed19172f 327cp -f /usr/share/automake/config.sub config/gnu
65fbc6c7 328./configure \
69735a4b 329 -cc "%{__cc}" \
65fbc6c7
AM
330 -bindir %{_bindir} \
331 -libdir %{_libdir}/%{name} \
332 -mandir %{_mandir}/man1 \
530dec71 333 -host %{_host} \
f4710e3c 334 %{!?with_tk:-no-tk} \
2e6ceb74 335 -with-pthread \
0053154a 336 -x11lib %{_libdir}
65fbc6c7 337
0d424b76
AM
338%{__make} -j1 world bootstrap opt.opt CFLAGS="%{rpmcflags} -Wall -DUSE_INTERP_RESULT"
339%{__make} -C tools objinfo CFLAGS="%{rpmcflags} -Wall -DUSE_INTERP_RESULT" -j1
65fbc6c7 340
e1542d3b
JB
341# broken build system
342sed -e 's,LIBDIR,%{_libdir},' camlp4/man/camlp4.1.tpl > camlp4/man/camlp4.1
343
65fbc6c7 344%install
5ca6b9fb 345rm -rf $RPM_BUILD_ROOT
69735a4b 346install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
7ff0f82f 347install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/site-lib
e42e1457 348
7ae05805 349%{__make} install \
13b509d1
MM
350 BINDIR=$RPM_BUILD_ROOT%{_bindir} \
351 LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} \
352 MANDIR=$RPM_BUILD_ROOT%{_mandir}
353
354cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
355%{_libdir}/%{name}/stublibs
356%{_libdir}/%{name}
357EOF
4797676b 358
f4710e3c 359%if %{with emacs}
3889f6d2
JR
360%{__make} -C emacs install \
361 DESTDIR=$RPM_BUILD_ROOT \
362 EMACSDIR="$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp" \
363 EMACS="emacs"
56260732
MM
364%endif
365
981ff793 366# symlink .opt versions of compilers (if present)
13b509d1
MM
367# warning: don't do that with camlp4 (can't load extensions then)
368for f in ocamlc ocamlopt ocamldoc ocamllex; do
067af37d
MM
369 if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
370 mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
371 $RPM_BUILD_ROOT%{_bindir}/$f.byte
372 ln -sf %{_bindir}/$f.opt $RPM_BUILD_ROOT%{_bindir}/$f
373 fi
1511bcd5 374done
65fbc6c7 375
981ff793 376# move includes to the proper place
ba35c88b 377mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
981ff793 378# but leave compatibility symlink
379cf672 379ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
981ff793 380
360c386d
MM
381# compiled sources of compiler, needed by some programs
382for f in {asm,byte}comp parsing typing utils ; do
383 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
384 cp $f/*.{cmi,cmo,cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
385done
981ff793
MM
386
387# this isn't installed by default, but is useful
388install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
53fbd845 389cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
13b509d1 390cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
56260732
MM
391ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
392
13b509d1 393# shutup checkfiles
9de25172
JB
394%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/man3
395%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
13b509d1 396
69735a4b 397# install info pages
398cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
399
e1542d3b
JB
400# broken build system
401install camlp4/man/camlp4.1 $RPM_BUILD_ROOT%{_mandir}/man1
402for f in camlp4o.1 camlp4r.1 mkcamlp4.1 camlp4o.opt.1 camlp4r.opt.1 ; do
403 echo '.so camlp4.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
404done
405
65fbc6c7
AM
406%clean
407rm -rf $RPM_BUILD_ROOT
408
9de25172 409%post doc-info -p /sbin/postshell
4a452533 410-/usr/sbin/fix-info-dir -c %{_infodir}
69735a4b 411
9de25172 412%postun doc-info -p /sbin/postshell
4a452533 413-/usr/sbin/fix-info-dir -c %{_infodir}
69735a4b 414
65fbc6c7
AM
415%files
416%defattr(644,root,root,755)
f1920819 417%doc LICENSE Changes README Upgrading
9de25172 418%attr(755,root,root) %{_bindir}/addlabels
13b509d1 419%attr(755,root,root) %{_bindir}/ocaml*
9de25172 420%attr(755,root,root) %{_bindir}/scrapelabels
dd90c8d9 421%{?with_tk:%exclude %{_bindir}/ocamlbrowser}
13b509d1 422%exclude %{_bindir}/ocamlrun
ba35c88b 423%{_includedir}/caml
530dec71 424%{_libdir}/%{name}/caml
530dec71 425%{_libdir}/%{name}/threads
4c1e0f62
MM
426%dir %{_libdir}/%{name}/vmthreads
427%dir %{_libdir}/%{name}/vmthreads/*.cm*
428%dir %{_libdir}/%{name}/vmthreads/*.a
13b509d1
MM
429%{_libdir}/%{name}/*.a
430%{_libdir}/%{name}/*.o
431%{_libdir}/%{name}/*.cm*
432%exclude %{_libdir}/%{name}/*graphics*
dd90c8d9 433%{_libdir}/%{name}/Makefile.config
4251bfb1 434%{_libdir}/%{name}/ld.conf
56260732
MM
435%{_libdir}/%{name}/camlheader
436%{_libdir}/%{name}/camlheader_ur
7ff0f82f 437%{_libdir}/%{name}/ocamlbuild
13b509d1 438%dir %{_libdir}/%{name}/ocamldoc
13b509d1
MM
439%{_libdir}/%{name}/ocamldoc/*.hva
440%attr(755,root,root) %{_libdir}/%{name}/expunge
441%attr(755,root,root) %{_libdir}/%{name}/extract_crc
9de25172
JB
442%attr(755,root,root) %{_libdir}/%{name}/objinfo_helper
443%{_mandir}/man1/ocaml*
444%exclude %{_mandir}/man1/ocamlrun.1*
13b509d1 445
79502218
JB
446%files runtime
447%defattr(644,root,root,755)
448%attr(755,root,root) %{_bindir}/ocamlrun
449%dir %{_libdir}/%{name}
7ff0f82f 450%dir %{_libdir}/%{name}/site-lib
79502218
JB
451%dir %{_libdir}/%{name}/stublibs
452%attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
453%exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
42946d4f 454%attr(755,root,root) %{_libdir}/%{name}/libcamlrun_shared.so
79502218
JB
455%if %{with tk}
456%exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
79502218 457%endif
9de25172 458%{_mandir}/man1/ocamlrun.1*
79502218 459
13b509d1
MM
460%files lib-source
461%defattr(644,root,root,755)
462%{_libdir}/%{name}/*.ml
8151bf1e 463%{_libdir}/%{name}/*.mli
4c1e0f62 464%{_libdir}/%{name}/*/*.mli
13b509d1 465
79502218 466%files doc-html
763b9075 467%defattr(644,root,root,755)
79502218
JB
468%doc docs/html/ocaml/*
469
470%files doc-ps
471%defattr(644,root,root,755)
472%doc docs/*.ps.gz
473
474%files doc-info
475%defattr(644,root,root,755)
476%{_infodir}/ocaml.info*
53fbd845 477
13b509d1
MM
478# they are poor, html is much better
479#%files manpages
e68873d9 480#%%{_mandir}/man3/*
65fbc6c7 481
79502218
JB
482%if %{with emacs}
483%files emacs
56260732 484%defattr(644,root,root,755)
79502218
JB
485%{_datadir}/emacs/site-lisp/*.el*
486%endif
56260732 487
79502218
JB
488%if %{with tk}
489%files labltk
69735a4b 490%defattr(644,root,root,755)
79502218 491%attr(755,root,root) %{_libdir}/%{name}/stublibs/dlllabltk.so
69735a4b 492
981ff793 493%files labltk-devel
56260732 494%defattr(644,root,root,755)
73a93122 495%attr(755,root,root) %{_bindir}/labltk
496%attr(755,root,root) %{_bindir}/ocamlbrowser
56260732
MM
497%dir %{_libdir}/%{name}/labltk
498%{_libdir}/%{name}/labltk/*.cm*
499%{_libdir}/%{name}/labltk/*.a
42946d4f 500%{_libdir}/%{name}/labltk/*.o
73a93122 501%attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
ba35c88b 502%{_examplesdir}/%{name}-labltk-%{version}
56260732
MM
503%endif
504
b552f088 505%if %{with x}
79502218
JB
506%files x11graphics
507%defattr(644,root,root,755)
508%attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
509
981ff793 510%files x11graphics-devel
56260732 511%defattr(644,root,root,755)
13b509d1 512%{_libdir}/%{name}/graphics*.cm*
f442d039 513%{_libdir}/%{name}/graphics.a
56260732 514%{_libdir}/%{name}/libgraphics.a
56260732
MM
515%endif
516
79502218 517%files camlp4
65fbc6c7 518%defattr(644,root,root,755)
e1542d3b
JB
519%attr(755,root,root) %{_bindir}/camlp4*
520%attr(755,root,root) %{_bindir}/mkcamlp4
79502218 521%{_libdir}/%{name}/camlp4
e1542d3b
JB
522%{_mandir}/man1/camlp4*.1*
523%{_mandir}/man1/mkcamlp4.1*
4797676b 524
79502218 525%files camlp4-doc-html
13b509d1 526%defattr(644,root,root,755)
79502218 527%doc docs/html/camlp4*
13b509d1 528
79502218 529%files compiler-objects
69735a4b 530%defattr(644,root,root,755)
79502218 531%{_libdir}/%{name}/compiler
69735a4b 532
79502218 533%files ocamldoc-devel
73a93122 534%defattr(644,root,root,755)
79502218
JB
535%{_libdir}/%{name}/ocamldoc/*.cm*
536%{_libdir}/%{name}/ocamldoc/*.a
69735a4b 537
79502218 538%files examples
69735a4b 539%defattr(644,root,root,755)
79502218 540%{_examplesdir}/%{name}-%{version}
This page took 0.18164 seconds and 4 git commands to generate.