]> git.pld-linux.org Git - packages/ocaml-zarith.git/blobdiff - ocaml-zarith.spec
rebuild with separate debuginfo build-ids
[packages/ocaml-zarith.git] / ocaml-zarith.spec
index 3fb8b45fdf61c0f7a022421aca8a5f0a100bfa51..b5f7c3580d79047e949e00bcb1a180d8055e202d 100644 (file)
@@ -1,27 +1,32 @@
 #
 # Conditional build:
 #
 # Conditional build:
-%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
+%bcond_without ocaml_opt       # native optimized binaries (bytecode is always built)
 
 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
 
 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
-%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
+%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
 %undefine      with_ocaml_opt
 %endif
 
 %define                module  zarith
 Summary:       Zarith: arbitrary-precision integers
 %undefine      with_ocaml_opt
 %endif
 
 %define                module  zarith
 Summary:       Zarith: arbitrary-precision integers
+Summary(pl.UTF-8):     Zarith - liczby całkowite dowolnej precyzji
 Name:          ocaml-zarith
 Name:          ocaml-zarith
-Version:       1.4.1
-Release:       1
-License:       GPL
+Version:       1.12
+Release:       5
+License:       LGPL v2 with linking exception
 Group:         Applications/Math
 Group:         Applications/Math
-Source0:       http://forge.ocamlcore.org/frs/download.php/1574/%{module}-%{version}.tgz
-# Source0-md5: 9ab2482d57f632c9cb3d10149138bc6e
-URL:           http://forge.ocamlcore.org/projects/zarith
+#Source0Download: https://github.com/ocaml/Zarith/releases
+Source0:       https://github.com/ocaml/Zarith/archive/release-%{version}/Zarith-%{version}.tar.gz
+# Source0-md5: bf368f3d9e20b6b446d54681afc05a04
+URL:           http://github.com/ocaml/Zarith
 BuildRequires: bash
 BuildRequires: gmp-devel
 BuildRequires: bash
 BuildRequires: gmp-devel
-BuildRequires: ocaml >= 3.09.0
-BuildRequires: camlp5 >= 5.01
+BuildRequires: ocaml >= 1:4.04
+BuildRequires: ocaml-findlib
+BuildRequires: perl-base
 %requires_eq   ocaml-runtime
 %requires_eq   ocaml-runtime
+# does not work on x32 because sizeof(intnat) != sizeof(mp_limb_t) (4 != 8)
+ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -30,26 +35,39 @@ arbitrary-precision integers. It uses GMP to efficiently implement
 arithmetic over big integers. Small integers are represented as Caml
 unboxed integers, for speed and space economy.
 
 arithmetic over big integers. Small integers are represented as Caml
 unboxed integers, for speed and space economy.
 
+%description -l pl.UTF-8
+Biblioteka Zarith implementuje operacje arytmetyczne i logiczne na
+liczbach całkowitych dowolnej precyzji. Wykorzystuje gmp do wydajnej
+arytmetyki na dużych liczbach całkowitych. Małe liczby całkowite są
+reprezentowane jako nieograniczone liczby całkowite Camla, aby zyskać
+na szybkości i rozmiarze.
+
 %package devel
 Summary:       Zarith library development files
 %package devel
 Summary:       Zarith library development files
+Summary(pl.UTF-8):     Pliki programistyczne biblioteki Zarith
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %requires_eq   ocaml
 
 %description devel
 This package contains files needed to develop OCaml programs using
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %requires_eq   ocaml
 
 %description devel
 This package contains files needed to develop OCaml programs using
-zarith library.
+Zarith library.
+
+%description devel -l pl.UTF-8
+Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
+przy użyciu biblioteki Zarith.
 
 %prep
 
 %prep
-%setup -q -n %{module}-%{version}
+%setup -q -n Zarith-release-%{version}
 
 %build
 
 %build
+CC="%{__cc}" \
 CFLAGS="%{rpmcflags}" \
 ./configure \
 CFLAGS="%{rpmcflags}" \
 ./configure \
-       -installdir $RPM_BUILD_ROOT/%{_libdir}/ocaml \
+       -installdir $RPM_BUILD_ROOT%{_libdir}/ocaml \
        -gmp
 
        -gmp
 
-%{__make} -j1 VERBOSE=1
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -59,35 +77,32 @@ install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# move to dir pld ocamlfind looks
-install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}
-mv $OCAMLFIND_DESTDIR/%{module}/META \
-       $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}
-cat <<EOF >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{module}/META
-directory="+%{module}"
-EOF
+install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/
+
+# not required with system package manager
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.so.owner
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
-%{_libdir}/ocaml/stublibs/*.so.owner
+%doc Changes LICENSE README.md
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllzarith.so
 %dir %{_libdir}/ocaml/%{module}
 %dir %{_libdir}/ocaml/%{module}
+%{_libdir}/ocaml/%{module}/META
 %if %{with ocaml_opt}
 %if %{with ocaml_opt}
-%{_libdir}/ocaml/%{module}/*.cmxs
+%attr(755,root,root) %{_libdir}/ocaml/%{module}/zarith.cmxs
 %endif
 %endif
-%{_libdir}/ocaml/site-lib/%{module}
 
 %files devel
 %defattr(644,root,root,755)
 
 %files devel
 %defattr(644,root,root,755)
-%doc LICENSE
 %{_libdir}/ocaml/%{module}/*.cm[axi]
 %{_libdir}/ocaml/%{module}/*.mli
 %{_libdir}/ocaml/%{module}/*.cm[axi]
 %{_libdir}/ocaml/%{module}/*.mli
-%{_libdir}/ocaml/%{module}/*.h
+%{_libdir}/ocaml/%{module}/*.cmti
 %{_libdir}/ocaml/%{module}/libzarith.a
 %{_libdir}/ocaml/%{module}/libzarith.a
+%{_libdir}/ocaml/%{module}/zarith.h
 %if %{with ocaml_opt}
 %{_libdir}/ocaml/%{module}/zarith.a
 %if %{with ocaml_opt}
 %{_libdir}/ocaml/%{module}/zarith.a
-%{_libdir}/ocaml/%{module}/*.cmxa
+%{_libdir}/ocaml/%{module}/zarith.cmxa
 %endif
 %endif
This page took 0.048151 seconds and 4 git commands to generate.