]> git.pld-linux.org Git - packages/ocaml-zarith.git/blob - ocaml-zarith.spec
- update META file location
[packages/ocaml-zarith.git] / ocaml-zarith.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %define         module  zarith
11 Summary:        Zarith: arbitrary-precision integers
12 Summary(pl.UTF-8):      Zarith - liczby całkowite dowolnej precyzji
13 Name:           ocaml-zarith
14 Version:        1.12
15 Release:        3
16 License:        LGPL v2 with linking exception
17 Group:          Applications/Math
18 #Source0Download: https://github.com/ocaml/Zarith/releases
19 Source0:        https://github.com/ocaml/Zarith/archive/release-%{version}/Zarith-%{version}.tar.gz
20 # Source0-md5:  bf368f3d9e20b6b446d54681afc05a04
21 URL:            http://github.com/ocaml/Zarith
22 BuildRequires:  bash
23 BuildRequires:  gmp-devel
24 BuildRequires:  ocaml >= 3.12.1
25 BuildRequires:  ocaml-findlib
26 BuildRequires:  perl-base
27 %requires_eq    ocaml-runtime
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Zarith library implements arithmetic and logical operations over
32 arbitrary-precision integers. It uses GMP to efficiently implement
33 arithmetic over big integers. Small integers are represented as Caml
34 unboxed integers, for speed and space economy.
35
36 %description -l pl.UTF-8
37 Biblioteka Zarith implementuje operacje arytmetyczne i logiczne na
38 liczbach całkowitych dowolnej precyzji. Wykorzystuje gmp do wydajnej
39 arytmetyki na dużych liczbach całkowitych. Małe liczby całkowite są
40 reprezentowane jako nieograniczone liczby całkowite Camla, aby zyskać
41 na szybkości i rozmiarze.
42
43 %package devel
44 Summary:        Zarith library development files
45 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Zarith
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 %requires_eq    ocaml
49
50 %description devel
51 This package contains files needed to develop OCaml programs using
52 Zarith library.
53
54 %description devel -l pl.UTF-8
55 Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
56 przy użyciu biblioteki Zarith.
57
58 %prep
59 %setup -q -n Zarith-release-%{version}
60
61 %build
62 CC="%{__cc}" \
63 CFLAGS="%{rpmcflags}" \
64 ./configure \
65         -installdir $RPM_BUILD_ROOT%{_libdir}/ocaml \
66         -gmp
67
68 %{__make} -j1
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
73 install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/
79
80 # not required with system package manager
81 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.so.owner
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes LICENSE README.md
89 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllzarith.so
90 %dir %{_libdir}/ocaml/%{module}
91 %{_libdir}/ocaml/%{module}/META
92 %if %{with ocaml_opt}
93 %attr(755,root,root) %{_libdir}/ocaml/%{module}/zarith.cmxs
94 %endif
95
96 %files devel
97 %defattr(644,root,root,755)
98 %{_libdir}/ocaml/%{module}/*.cm[axi]
99 %{_libdir}/ocaml/%{module}/*.mli
100 %{_libdir}/ocaml/%{module}/*.cmti
101 %{_libdir}/ocaml/%{module}/libzarith.a
102 %{_libdir}/ocaml/%{module}/zarith.h
103 %if %{with ocaml_opt}
104 %{_libdir}/ocaml/%{module}/zarith.a
105 %{_libdir}/ocaml/%{module}/zarith.cmxa
106 %endif
This page took 0.041515 seconds and 3 git commands to generate.