]> git.pld-linux.org Git - packages/ocaml-graphics.git/blob - ocaml-graphics.spec
- missing Groups
[packages/ocaml-graphics.git] / ocaml-graphics.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %if %{without ocaml_opt}
11 %define         _enable_debug_packages  0
12 %endif
13
14 %define         module  graphics
15 Summary:        Portable drawing primitives for OCaml
16 Summary(pl.UTF-8):      Przenośne funkcje rysujące dla OCamla
17 Name:           ocaml-%{module}
18 Version:        5.1.1
19 Release:        1
20 License:        LGPL v2 with exceptions
21 Group:          Libraries
22 Source0:        https://github.com/ocaml/graphics/releases/download/%{version}/%{module}-%{version}.tbz
23 # Source0-md5:  bc127b5da919b61f4c928a6657c88886
24 URL:            https://github.com/ocaml/graphics
25 BuildRequires:  ocaml >= 4.09.0
26 BuildRequires:  ocaml-dune-devel >= 2.1
27 BuildRequires:  xorg-lib-libX11-devel
28 %requires_eq    ocaml-runtime
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The graphics library provides a set of portable drawing primitives.
33 Drawing takes place in a separate window that is created when
34 Graphics.open_graph is called.
35
36 %description -l pl.UTF-8
37 Biblioteka graphics dostarcza zbiór przenośnych funkcji rysujących.
38 Rysowanie jest wykonywane w osobnym oknie, tworzonym przy wywołaniu
39 Graphics.open_graph.
40
41 %package devel
42 Summary:        Development files for graphics library
43 Summary(pl.UTF-8):      Pliki programistyczne biblioteki graphics
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       xorg-lib-libX11-devel
47
48 %description devel
49 This package contains libraries and signature files for developing
50 applications that use OCaml graphics library.
51
52 %description devel -l pl.UTF-8
53 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
54 wykorzystujących bibliotekę OCamla graphics.
55
56 %prep
57 %setup -q -n %{module}-%{version}
58
59 %build
60 dune build %{?_smp_mflags} --display=verbose
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 dune install --destdir=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc CHANGES.md README.md
73 %dir %{_libdir}/ocaml/%{module}
74 %{_libdir}/ocaml/%{module}/META
75 %{_libdir}/ocaml/%{module}/*.cma
76 %{_libdir}/ocaml/%{module}/*.cmi
77 %if %{with ocaml_opt}
78 %attr(755,root,root) %{_libdir}/ocaml/%{module}/*.cmxs
79 %endif
80 %{_libdir}/ocaml/stublibs/dllgraphics_stubs.so
81
82 %files devel
83 %defattr(644,root,root,755)
84 %{_libdir}/ocaml/%{module}/dune-package
85 %{_libdir}/ocaml/%{module}/opam
86 %{_libdir}/ocaml/%{module}/*.a
87 %if %{with ocaml_opt}
88 %{_libdir}/ocaml/%{module}/*.cmx
89 %{_libdir}/ocaml/%{module}/*.cmxa
90 %endif
91 %{_libdir}/ocaml/%{module}/*.cmt
92 %{_libdir}/ocaml/%{module}/*.cmti
93 %{_libdir}/ocaml/%{module}/*.mli
This page took 0.065773 seconds and 3 git commands to generate.