]> git.pld-linux.org Git - packages/ocaml-fuse.git/blob - ocaml-fuse.spec
- fix noopt build
[packages/ocaml-fuse.git] / ocaml-fuse.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %define         module  ocamlfuse
11 Summary:        Fuse binding for OCaml
12 Summary(pl.UTF-8):      Wiązania Fuse dla OCamla
13 Name:           ocaml-fuse
14 Version:        2.7.1
15 Release:        1
16 License:        GPL v2
17 Group:          Libraries
18 Source0:        https://github.com/astrada/ocamlfuse/archive/v%{version}_cvs7/ocamlfuse-%{version}-7.tar.gz
19 # Source0-md5:  a5da871a0983b6723c6b9b735898fe34
20 URL:            http://sourceforge.net/apps/mediawiki/ocamlfuse/
21 BuildRequires:  libfuse-devel
22 BuildRequires:  ocaml >= 3.08
23 BuildRequires:  ocaml-dune
24 BuildRequires:  ocaml-findlib >= 1.4
25 BuildRequires:  ocaml-idl-devel >= 1.0.5
26 %requires_eq    ocaml-runtime
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         debug_package   %{nil}
30
31 %description
32 OcamlFuse is a binding to the high-level part of the fuse library,
33 allowing you to implement linux filesystems in OCaml. Other operating
34 systems are not supported, if you think you can help we will be glad
35 to hear.
36
37 The main features of ocamlfuse are:
38 - Multithreading: each callback runs in a separate ocaml thread, so
39   that a slow call can't block the filesystem
40 - Efficiency: read and write operations use the bigarray library
41   achieving very high troughput _ Ease of use: the fusexmp filesystem
42   (mimicking bindfs) is 73 lines of code, including in-memory extended
43   attributes using a hash table. The hello example is 42 lines of code.
44
45 %description -l pl.UTF-8
46 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
47 używających tej biblioteki.
48
49 %package devel
50 Summary:        ocamlfuse binding for OCaml - development part
51 Summary(pl.UTF-8):      Wiązania ocamlfuse dla OCamla - cześć programistyczna
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 %requires_eq    ocaml
55 Requires:       libfuse-devel
56 Requires:       ocaml-idl-devel >= 1.0.5
57
58 %description devel
59 This package contains files needed to develop OCaml programs using
60 this library.
61
62 %description devel -l pl.UTF-8
63 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
64 tej biblioteki.
65
66 %prep
67 %setup -q -n ocamlfuse-2.7.1_cvs7
68
69 %build
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %{_libdir}/ocaml/%{module}/META
84 %{_libdir}/ocaml/%{module}/dune-package
85 %{_libdir}/ocaml/%{module}/opam
86 %{_libdir}/ocaml/%{module}/*.cmi
87 %{_libdir}/ocaml/%{module}/*.cmt
88 %{_libdir}/ocaml/%{module}/*.cmti
89 %if %{with ocaml_opt}
90 %{_libdir}/ocaml/%{module}/*.cmxs
91 %endif
92 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
93
94 %files devel
95 %defattr(644,root,root,755)
96 %doc LICENSE lib/*.mli
97 %dir %{_libdir}/ocaml/%{module}
98 %{_libdir}/ocaml/%{module}/*.cma
99 %{_libdir}/ocaml/%{module}/*.cm[ix]
100 %{_libdir}/ocaml/%{module}/*.a
101 %{_libdir}/ocaml/%{module}/*.mli
102 %if %{with ocaml_opt}
103 %{_libdir}/ocaml/%{module}/*.cmxa
104 %endif
This page took 0.081736 seconds and 4 git commands to generate.