]> git.pld-linux.org Git - packages/ocaml-fuse.git/blob - ocaml-fuse.spec
- keep the original ocaml package name
[packages/ocaml-fuse.git] / ocaml-fuse.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %define         module  Fuse
11 Summary:        Fuse binding for OCaml
12 Summary(pl.UTF-8):      Wiązania Fuse dla OCamla
13 Name:           ocaml-fuse
14 Version:        2.7.1
15 Release:        2
16 License:        GPL v2
17 Group:          Libraries
18 Source0:        https://github.com/astrada/ocamlfuse/archive/v%{version}_cvs7/ocamlfuse-%{version}-7.tar.gz
19 # Source0-md5:  a5da871a0983b6723c6b9b735898fe34
20 Patch0:         keep-name.patch
21 URL:            http://sourceforge.net/apps/mediawiki/ocamlfuse/
22 BuildRequires:  libfuse-devel
23 BuildRequires:  ocaml >= 3.08
24 BuildRequires:  ocaml-dune
25 BuildRequires:  ocaml-findlib >= 1.4
26 BuildRequires:  ocaml-idl-devel >= 1.0.5
27 %requires_eq    ocaml-runtime
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         debug_package   %{nil}
31
32 %description
33 OcamlFuse is a binding to the high-level part of the fuse library,
34 allowing you to implement linux filesystems in OCaml. Other operating
35 systems are not supported, if you think you can help we will be glad
36 to hear.
37
38 The main features of ocamlfuse are:
39 - Multithreading: each callback runs in a separate ocaml thread, so
40   that a slow call can't block the filesystem
41 - Efficiency: read and write operations use the bigarray library
42   achieving very high troughput _ Ease of use: the fusexmp filesystem
43   (mimicking bindfs) is 73 lines of code, including in-memory extended
44   attributes using a hash table. The hello example is 42 lines of code.
45
46 %description -l pl.UTF-8
47 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
48 używających tej biblioteki.
49
50 %package devel
51 Summary:        ocamlfuse binding for OCaml - development part
52 Summary(pl.UTF-8):      Wiązania ocamlfuse dla OCamla - cześć programistyczna
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 %requires_eq    ocaml
56 Requires:       libfuse-devel
57 Requires:       ocaml-idl-devel >= 1.0.5
58
59 %description devel
60 This package contains files needed to develop OCaml programs using
61 this library.
62
63 %description devel -l pl.UTF-8
64 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
65 tej biblioteki.
66
67 %prep
68 %setup -q -n ocamlfuse-2.7.1_cvs7
69 %patch0 -p1
70
71 %{__mv} {ocamlfuse,Fuse}.opam
72
73 %build
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %{_libdir}/ocaml/%{module}/META
88 %{_libdir}/ocaml/%{module}/dune-package
89 %{_libdir}/ocaml/%{module}/opam
90 %{_libdir}/ocaml/%{module}/*.cmi
91 %{_libdir}/ocaml/%{module}/*.cmt
92 %{_libdir}/ocaml/%{module}/*.cmti
93 %if %{with ocaml_opt}
94 %{_libdir}/ocaml/%{module}/*.cmxs
95 %endif
96 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
97
98 %files devel
99 %defattr(644,root,root,755)
100 %doc LICENSE lib/*.mli
101 %dir %{_libdir}/ocaml/%{module}
102 %{_libdir}/ocaml/%{module}/*.cma
103 %{_libdir}/ocaml/%{module}/*.cm[ix]
104 %{_libdir}/ocaml/%{module}/*.a
105 %{_libdir}/ocaml/%{module}/*.mli
106 %if %{with ocaml_opt}
107 %{_libdir}/ocaml/%{module}/*.cmxa
108 %endif
This page took 0.054104 seconds and 3 git commands to generate.