]> git.pld-linux.org Git - packages/ocaml-fuse.git/blob - ocaml-fuse.spec
b0a92953616c7e113ce1e9e8ebdf4740faaf676d
[packages/ocaml-fuse.git] / ocaml-fuse.spec
1 #
2 # Conditional build:
3 %bcond_without  opt             # build opt
4
5 %define         modname Fuse
6 Summary:        %{modname} binding for OCaml
7 Summary(pl.UTF-8):      Wiązania %{modname} dla OCamla
8 Name:           ocaml-fuse
9 Version:        2.7
10 Release:        3
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/ocamlfuse/ocamlfuse-%{version}-1.tar.gz
14 # Source0-md5:  cb9cbe4fafb36ead1b78faaacc26f3e3
15 URL:            http://sourceforge.net/apps/mediawiki/ocamlfuse/
16 BuildRequires:  libfuse-devel
17 BuildRequires:  ocaml >= 3.08
18 BuildRequires:  ocaml-findlib >= 1.4
19 BuildRequires:  ocaml-idl-devel >= 1.0.5
20 %requires_eq    ocaml-runtime
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         debug_package   %{nil}
24
25 %description
26 OcamlFuse is a binding to the high-level part of the fuse library,
27 allowing you to implement linux filesystems in OCaml. Other operating
28 systems are not supported, if you think you can help we will be glad
29 to hear.
30
31 The main features of ocamlfuse are:
32 - Multithreading: each callback runs in a separate ocaml thread, so
33   that a slow call can't block the filesystem
34 - Efficiency: read and write operations use the bigarray library
35   achieving very high troughput _ Ease of use: the fusexmp filesystem
36   (mimicking bindfs) is 73 lines of code, including in-memory extended
37   attributes using a hash table. The hello example is 42 lines of code.
38
39 %description -l pl.UTF-8
40 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
41 używających tej biblioteki.
42
43 %package devel
44 Summary:        ocamlfuse binding for OCaml - development part
45 Summary(pl.UTF-8):      Wiązania ocamlfuse dla OCamla - cześć programistyczna
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 %requires_eq    ocaml
49 Requires:       libfuse-devel
50 Requires:       ocaml-idl-devel >= 1.0.5
51
52 %description devel
53 This package contains files needed to develop OCaml programs using
54 this library.
55
56 %description devel -l pl.UTF-8
57 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
58 tej biblioteki.
59
60 %prep
61 %setup -qc
62 mv ocamlfuse/* .
63
64 %build
65 %{__make} -j1 all -C lib \
66         PACKS=camlidl \
67         CC="%{__cc} %{rpmcflags} -fPIC"
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 cd lib
72
73 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{%{modname},stublibs}
74 install -p *.cm[ixa]* *.a $RPM_BUILD_ROOT%{_libdir}/ocaml/%{modname}
75 install -p dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
76
77 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{modname}
78 cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{modname}/META <<EOF
79 requires = ""
80 version = "%{version}"
81 directory = "+%{modname}"
82 archive(byte) = "%{modname}.cma"
83 archive(native) = "%{modname}.cmxa"
84 linkopts = ""
85 EOF
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
93
94 %files devel
95 %defattr(644,root,root,755)
96 %doc LICENSE lib/*.mli
97 %dir %{_libdir}/ocaml/%{modname}
98 %{_libdir}/ocaml/%{modname}/*.cm[ixa]*
99 %{_libdir}/ocaml/%{modname}/*.a
100 %{_libdir}/ocaml/site-lib/%{modname}
This page took 0.068565 seconds and 2 git commands to generate.