]> git.pld-linux.org Git - packages/ocaml-fuse.git/blame_incremental - ocaml-ocamlfuse.spec
use Fuse module name while packaging to match library names
[packages/ocaml-fuse.git] / ocaml-ocamlfuse.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with opt # build opt
4
5%define modname Fuse
6Summary: %{modname} binding for OCaml
7Summary(pl.UTF-8): Wiązania %{modname} dla OCamla
8Name: ocaml-ocamlfuse
9Version: 2.7
10Release: 1
11License: GPL v2
12Group: Libraries
13Source0: http://downloads.sourceforge.net/ocamlfuse/ocamlfuse-%{version}-1.tar.gz
14# Source0-md5: cb9cbe4fafb36ead1b78faaacc26f3e3
15URL: http://sourceforge.net/apps/mediawiki/ocamlfuse/
16BuildRequires: libfuse-devel
17BuildRequires: ocaml >= 3.08
18BuildRequires: ocaml-camlidl >= 1.0.5
19BuildRequires: ocaml-findlib >= 1.4
20%requires_eq ocaml-runtime
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define debug_package %{nil}
24
25%description
26OcamlFuse is a binding to the high-level part of the fuse library,
27allowing you to implement linux filesystems in OCaml. Other operating
28systems are not supported, if you think you can help we will be glad
29to hear.
30
31The main features of ocamlfuse are:
32- Multithreading: each callback runs in a separate ocaml thread, so
33 that a slow call can't block the filesystem
34- Efficiency: read and write operations use the bigarray library
35 achieving very high troughput _ Ease of use: the fusexmp filesystem
36 (mimicking bindfs) is 73 lines of code, including in-memory extended
37 attributes using a hash table. The hello example is 42 lines of code.
38
39%description -l pl.UTF-8
40Pakiet ten zawiera binaria potrzebne do uruchamiania programów
41używających tej biblioteki.
42
43%package devel
44Summary: ocamlfuse binding for OCaml - development part
45Summary(pl.UTF-8): Wiązania ocamlfuse dla OCamla - cześć programistyczna
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48%requires_eq ocaml
49
50%description devel
51This package contains files needed to develop OCaml programs using
52this library.
53
54%description devel -l pl.UTF-8
55Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
56tej biblioteki.
57
58%prep
59%setup -qc
60mv %{modname}/* .
61
62%build
63%{__make} all %{?with_opt:opt} -C lib \
64 CC="%{__cc} %{rpmcflags} -fPIC"
65
66%install
67rm -rf $RPM_BUILD_ROOT
68cd lib
69
70install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{%{modname},stublibs}
71install -p *.cm[ixa]* *.a dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/%{modname}
72install -p dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
73
74install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{modname}
75cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{modname}/META <<EOF
76requires = ""
77version = "%{version}"
78directory = "+%{modname}"
79archive(byte) = "%{modname}.cma"
80archive(native) = "%{modname}.cmxa"
81linkopts = ""
82EOF
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(644,root,root,755)
89%attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
90%dir %{_libdir}/ocaml/%{modname}
91%attr(755,root,root) %{_libdir}/ocaml/%{modname}/dll*_stubs.so
92
93%files devel
94%defattr(644,root,root,755)
95%doc LICENSE lib/*.mli
96%dir %{_libdir}/ocaml/%{modname}
97%{_libdir}/ocaml/%{modname}/*.cm[ixa]*
98%{_libdir}/ocaml/%{modname}/*.a
99%{_libdir}/ocaml/site-lib/%{modname}
This page took 0.058267 seconds and 4 git commands to generate.