]> git.pld-linux.org Git - packages/ocaml-fuse.git/blame_incremental - ocaml-fuse.spec
- fill in devel package reqs
[packages/ocaml-fuse.git] / ocaml-fuse.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without opt # build opt
4
5%define modname Fuse
6Summary: %{modname} binding for OCaml
7Summary(pl.UTF-8): Wiązania %{modname} dla OCamla
8Name: ocaml-fuse
9Version: 2.7
10Release: 2
11License: GPL v2
12Group: Libraries
13Source0: http://downloads.sourceforge.net/ocamlfuse/ocamlfuse-%{version}-1.tar.gz
14# Source0-md5: cb9cbe4fafb36ead1b78faaacc26f3e3
15URL: http://sourceforge.net/apps/mediawiki/ocamlfuse/
16BuildRequires: libfuse-devel
17BuildRequires: ocaml >= 3.08
18BuildRequires: ocaml-findlib >= 1.4
19BuildRequires: ocaml-idl-devel >= 1.0.5
20%requires_eq ocaml-runtime
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define debug_package %{nil}
24
25%description
26OcamlFuse is a binding to the high-level part of the fuse library,
27allowing you to implement linux filesystems in OCaml. Other operating
28systems are not supported, if you think you can help we will be glad
29to hear.
30
31The main features of ocamlfuse are:
32- Multithreading: each callback runs in a separate ocaml thread, so
33 that a slow call can't block the filesystem
34- Efficiency: read and write operations use the bigarray library
35 achieving very high troughput _ Ease of use: the fusexmp filesystem
36 (mimicking bindfs) is 73 lines of code, including in-memory extended
37 attributes using a hash table. The hello example is 42 lines of code.
38
39%description -l pl.UTF-8
40Pakiet ten zawiera binaria potrzebne do uruchamiania programów
41używających tej biblioteki.
42
43%package devel
44Summary: ocamlfuse binding for OCaml - development part
45Summary(pl.UTF-8): Wiązania ocamlfuse dla OCamla - cześć programistyczna
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48%requires_eq ocaml
49Requires: libfuse-devel
50Requires: ocaml-idl-devel >= 1.0.5
51
52%description devel
53This package contains files needed to develop OCaml programs using
54this library.
55
56%description devel -l pl.UTF-8
57Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
58tej biblioteki.
59
60%prep
61%setup -qc
62mv ocamlfuse/* .
63
64%build
65%{__make} -j1 all -C lib \
66 PACKS=camlidl \
67 CC="%{__cc} %{rpmcflags} -fPIC"
68
69%install
70rm -rf $RPM_BUILD_ROOT
71cd lib
72
73install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{%{modname},stublibs}
74install -p *.cm[ixa]* *.a $RPM_BUILD_ROOT%{_libdir}/ocaml/%{modname}
75install -p dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
76
77install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{modname}
78cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/%{modname}/META <<EOF
79requires = ""
80version = "%{version}"
81directory = "+%{modname}"
82archive(byte) = "%{modname}.cma"
83archive(native) = "%{modname}.cmxa"
84linkopts = ""
85EOF
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files
91%defattr(644,root,root,755)
92%attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
93
94%files devel
95%defattr(644,root,root,755)
96%doc LICENSE lib/*.mli
97%dir %{_libdir}/ocaml/%{modname}
98%{_libdir}/ocaml/%{modname}/*.cm[ixa]*
99%{_libdir}/ocaml/%{modname}/*.a
100%{_libdir}/ocaml/site-lib/%{modname}
This page took 0.061804 seconds and 4 git commands to generate.