]> git.pld-linux.org Git - packages/ocaml-fuse.git/blame - ocaml-fuse.spec
- do not restore old name, the only user wants it under new name now
[packages/ocaml-fuse.git] / ocaml-fuse.spec
CommitLineData
6d4859a1
ER
1#
2# Conditional build:
c5770cec
JR
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
6d4859a1 9
e91c320b 10%define module ocamlfuse
a93cf193
JR
11Summary: Fuse binding for OCaml
12Summary(pl.UTF-8): Wiązania Fuse dla OCamla
b1b243d7 13Name: ocaml-fuse
a93cf193 14Version: 2.7.1
2b7020f0 15Release: 3
6d4859a1
ER
16License: GPL v2
17Group: Libraries
a93cf193
JR
18Source0: https://github.com/astrada/ocamlfuse/archive/v%{version}_cvs7/ocamlfuse-%{version}-7.tar.gz
19# Source0-md5: a5da871a0983b6723c6b9b735898fe34
e91c320b 20Patch0: no-wrapped.patch
6d4859a1
ER
21URL: http://sourceforge.net/apps/mediawiki/ocamlfuse/
22BuildRequires: libfuse-devel
23BuildRequires: ocaml >= 3.08
a93cf193 24BuildRequires: ocaml-dune
6d4859a1 25BuildRequires: ocaml-findlib >= 1.4
789d8507 26BuildRequires: ocaml-idl-devel >= 1.0.5
6d4859a1
ER
27%requires_eq ocaml-runtime
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
ed1ca61e
ER
30%define debug_package %{nil}
31
6d4859a1
ER
32%description
33OcamlFuse is a binding to the high-level part of the fuse library,
34allowing you to implement linux filesystems in OCaml. Other operating
35systems are not supported, if you think you can help we will be glad
36to hear.
37
38The main features of ocamlfuse are:
39- Multithreading: each callback runs in a separate ocaml thread, so
40 that a slow call can't block the filesystem
41- Efficiency: read and write operations use the bigarray library
42 achieving very high troughput _ Ease of use: the fusexmp filesystem
43 (mimicking bindfs) is 73 lines of code, including in-memory extended
44 attributes using a hash table. The hello example is 42 lines of code.
45
46%description -l pl.UTF-8
47Pakiet ten zawiera binaria potrzebne do uruchamiania programów
48używających tej biblioteki.
49
50%package devel
51Summary: ocamlfuse binding for OCaml - development part
52Summary(pl.UTF-8): Wiązania ocamlfuse dla OCamla - cześć programistyczna
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55%requires_eq ocaml
b92f57da
JR
56Requires: libfuse-devel
57Requires: ocaml-idl-devel >= 1.0.5
6d4859a1
ER
58
59%description devel
60This package contains files needed to develop OCaml programs using
61this library.
62
63%description devel -l pl.UTF-8
64Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
65tej biblioteki.
66
67%prep
a93cf193 68%setup -q -n ocamlfuse-2.7.1_cvs7
3753bd0c 69%patch0 -p1
6d4859a1
ER
70
71%build
a93cf193 72%{__make}
6d4859a1
ER
73
74%install
75rm -rf $RPM_BUILD_ROOT
a93cf193
JR
76
77%{__make} install \
78 DESTDIR=$RPM_BUILD_ROOT
6d4859a1
ER
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(644,root,root,755)
a93cf193
JR
85%{_libdir}/ocaml/%{module}/META
86%{_libdir}/ocaml/%{module}/dune-package
87%{_libdir}/ocaml/%{module}/opam
88%{_libdir}/ocaml/%{module}/*.cmi
89%{_libdir}/ocaml/%{module}/*.cmt
90%{_libdir}/ocaml/%{module}/*.cmti
d3dc979d 91%if %{with ocaml_opt}
a93cf193 92%{_libdir}/ocaml/%{module}/*.cmxs
d3dc979d 93%endif
6d4859a1 94%attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
6d4859a1
ER
95
96%files devel
97%defattr(644,root,root,755)
98%doc LICENSE lib/*.mli
a93cf193
JR
99%dir %{_libdir}/ocaml/%{module}
100%{_libdir}/ocaml/%{module}/*.cma
101%{_libdir}/ocaml/%{module}/*.cm[ix]
102%{_libdir}/ocaml/%{module}/*.a
103%{_libdir}/ocaml/%{module}/*.mli
c5770cec 104%if %{with ocaml_opt}
a93cf193 105%{_libdir}/ocaml/%{module}/*.cmxa
c5770cec 106%endif
This page took 0.100005 seconds and 4 git commands to generate.