]> git.pld-linux.org Git - packages/ocaml-fuse.git/blame - ocaml-fuse.spec
- make library modules public
[packages/ocaml-fuse.git] / ocaml-fuse.spec
CommitLineData
6d4859a1
ER
1#
2# Conditional build:
c5770cec
JR
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
6d4859a1 9
3753bd0c 10%define module Fuse
a93cf193
JR
11Summary: Fuse binding for OCaml
12Summary(pl.UTF-8): Wiązania Fuse dla OCamla
b1b243d7 13Name: ocaml-fuse
a93cf193 14Version: 2.7.1
2b7020f0 15Release: 3
6d4859a1
ER
16License: GPL v2
17Group: Libraries
a93cf193
JR
18Source0: https://github.com/astrada/ocamlfuse/archive/v%{version}_cvs7/ocamlfuse-%{version}-7.tar.gz
19# Source0-md5: a5da871a0983b6723c6b9b735898fe34
3753bd0c 20Patch0: keep-name.patch
2b7020f0 21Patch1: no-wrapped.patch
6d4859a1
ER
22URL: http://sourceforge.net/apps/mediawiki/ocamlfuse/
23BuildRequires: libfuse-devel
24BuildRequires: ocaml >= 3.08
a93cf193 25BuildRequires: ocaml-dune
6d4859a1 26BuildRequires: ocaml-findlib >= 1.4
789d8507 27BuildRequires: ocaml-idl-devel >= 1.0.5
6d4859a1
ER
28%requires_eq ocaml-runtime
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
ed1ca61e
ER
31%define debug_package %{nil}
32
6d4859a1
ER
33%description
34OcamlFuse is a binding to the high-level part of the fuse library,
35allowing you to implement linux filesystems in OCaml. Other operating
36systems are not supported, if you think you can help we will be glad
37to hear.
38
39The main features of ocamlfuse are:
40- Multithreading: each callback runs in a separate ocaml thread, so
41 that a slow call can't block the filesystem
42- Efficiency: read and write operations use the bigarray library
43 achieving very high troughput _ Ease of use: the fusexmp filesystem
44 (mimicking bindfs) is 73 lines of code, including in-memory extended
45 attributes using a hash table. The hello example is 42 lines of code.
46
47%description -l pl.UTF-8
48Pakiet ten zawiera binaria potrzebne do uruchamiania programów
49używających tej biblioteki.
50
51%package devel
52Summary: ocamlfuse binding for OCaml - development part
53Summary(pl.UTF-8): Wiązania ocamlfuse dla OCamla - cześć programistyczna
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56%requires_eq ocaml
b92f57da
JR
57Requires: libfuse-devel
58Requires: ocaml-idl-devel >= 1.0.5
6d4859a1
ER
59
60%description devel
61This package contains files needed to develop OCaml programs using
62this library.
63
64%description devel -l pl.UTF-8
65Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
66tej biblioteki.
67
68%prep
a93cf193 69%setup -q -n ocamlfuse-2.7.1_cvs7
3753bd0c 70%patch0 -p1
2b7020f0 71%patch1 -p1
3753bd0c
JR
72
73%{__mv} {ocamlfuse,Fuse}.opam
6d4859a1
ER
74
75%build
a93cf193 76%{__make}
6d4859a1
ER
77
78%install
79rm -rf $RPM_BUILD_ROOT
a93cf193
JR
80
81%{__make} install \
82 DESTDIR=$RPM_BUILD_ROOT
6d4859a1
ER
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(644,root,root,755)
a93cf193
JR
89%{_libdir}/ocaml/%{module}/META
90%{_libdir}/ocaml/%{module}/dune-package
91%{_libdir}/ocaml/%{module}/opam
92%{_libdir}/ocaml/%{module}/*.cmi
93%{_libdir}/ocaml/%{module}/*.cmt
94%{_libdir}/ocaml/%{module}/*.cmti
d3dc979d 95%if %{with ocaml_opt}
a93cf193 96%{_libdir}/ocaml/%{module}/*.cmxs
d3dc979d 97%endif
6d4859a1 98%attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
6d4859a1
ER
99
100%files devel
101%defattr(644,root,root,755)
102%doc LICENSE lib/*.mli
a93cf193
JR
103%dir %{_libdir}/ocaml/%{module}
104%{_libdir}/ocaml/%{module}/*.cma
105%{_libdir}/ocaml/%{module}/*.cm[ix]
106%{_libdir}/ocaml/%{module}/*.a
107%{_libdir}/ocaml/%{module}/*.mli
c5770cec 108%if %{with ocaml_opt}
a93cf193 109%{_libdir}/ocaml/%{module}/*.cmxa
c5770cec 110%endif
This page took 0.061285 seconds and 4 git commands to generate.