]> git.pld-linux.org Git - packages/ocaml-findlib.git/blobdiff - ocaml-findlib.spec
- unify ocaml_opt bcond name
[packages/ocaml-findlib.git] / ocaml-findlib.spec
index c93eee46d700d134c669eab2c4f013da11e3399a..505f5b43ac7ba0c6919de5a4931ea0765bda1496 100644 (file)
@@ -1,9 +1,17 @@
+#
+# Conditional build:
+%bcond_without ocaml_opt               # build opt
+
+%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9 
+%undefine      with_ocaml_opt
+%endif
+
 %define                ocaml_ver       1:4.02
 Summary:       OCaml module manager
 Summary(pl.UTF-8):     Zarządca modułów OCamla
 Name:          ocaml-findlib
 Version:       1.5.5
-Release:       2
+Release:       9
 License:       distributable
 Group:         Development/Tools
 Source0:       http://download.camlcity.org/download/findlib-%{version}.tar.gz
@@ -14,11 +22,17 @@ BuildRequires:      m4
 BuildRequires: ncurses-devel
 BuildRequires: ocaml >= %{ocaml_ver}
 BuildRequires: ocaml-camlp4
-BuildRequires: ocaml-labltk
+BuildRequires: ocaml-labltk-devel
 BuildRequires: sed >= 4.0
 %requires_eq   ocaml
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%if %{without ocaml_opt}
+%define                no_install_post_strip   1
+# debug package strips binaries which renders ocamlfind broken
+%define                _enable_debug_packages  0
+%endif
+
 %description
 The "findlib" library provides a scheme to manage reusable software
 components (packages), and includes tools that support this scheme.
@@ -66,7 +80,7 @@ Ten pakiet zawiera biblioteki i skompilowane interfejsy findliba.
 
 sed -i -e 's/-g//' Makefile
 
-%{__make} -j1 all opt
+%{__make} -j1 all %{?with_ocaml_opt:opt}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -76,8 +90,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/findlib/*.mli
 
-# now provided by ocaml-labltk.spec
-%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/labltk
+# now provided by ocaml-labltk.spec (might not exist if building without ocaml-labltk installed)
+%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/labltk
 # now provided by ocaml-dbm.spec (might not exist if building without ocaml-dbm installed)
 %{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/dbm
 
@@ -141,8 +155,13 @@ rm -rf $RPM_BUILD_ROOT
 %files devel
 %defattr(644,root,root,755)
 %{_libdir}/ocaml/findlib/Makefile.config
-%{_libdir}/ocaml/findlib/*.cm[ixa]*
-%{_libdir}/ocaml/findlib/*.a
+%{_libdir}/ocaml/findlib/*.cm[xi]
+%{_libdir}/ocaml/findlib/*.cma
+%if %{with ocaml_opt}
+%{_libdir}/ocaml/findlib/*.[ao]
+%{_libdir}/ocaml/findlib/*.cmxa
+%{_libdir}/ocaml/findlib/*.cmxs
+%endif
 %dir %{_libdir}/ocaml/num-top
 %{_libdir}/ocaml/num-top/*.cm[ia]
 %{_libdir}/ocaml/ocamlfind
This page took 0.086995 seconds and 4 git commands to generate.