]> git.pld-linux.org Git - packages/ocaml-findlib.git/blob - ocaml-findlib.spec
- finally get the topfind thing working
[packages/ocaml-findlib.git] / ocaml-findlib.spec
1 Summary:        OCaml module manager
2 Summary(pl):    Zarz±dca modu³ów OCamla
3 Name:           ocaml-findlib
4 Version:        0.8.1
5 Release:        2
6 License:        distributable
7 Group:          Development/Tools
8 Vendor:         Gerd Stolpmann <gerd@gerd-stolpmann.de>
9 URL:            http://www.ocaml-programming.de/programming/page-4.html
10 # Source0-md5:  b4643888d1a6626981113e23a92b9154
11 Source0:        http://www.ocaml-programming.de/packages/findlib-%{version}.tar.gz
12 BuildRequires:  ocaml
13 BuildRequires:  ocaml-camlp4
14 BuildRequires:  ocaml-labltk-devel
15 BuildRequires:  m4
16 %requires_eq    ocaml
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The "findlib" library provides a scheme to manage reusable software
21 components (packages), and includes tools that support this scheme.
22 Packages are collections of OCaml modules for which metainformation
23 can be stored.
24
25 %description -l pl
26 Biblioteka "findlib" udostêpnia metodê zarz±dzania komponentami
27 oprogramowania (pakietami) oraz zawiera narzêdzia które ow± metodê
28 wspieraj±. Pakiety s± kolekcjami modu³ów w OCamlu, dla których jest
29 przechowywana metainformacja.
30
31 %package devel
32 Summary:        OCaml module manager
33 Summary(pl):    Zarz±dca modu³ów OCamla
34 Group:          Development/Libraries
35
36 %description devel
37 The "findlib" library provides a scheme to manage reusable software
38 components (packages), and includes tools that support this scheme.
39 Packages are collections of OCaml modules for which metainformation
40 can be stored.
41
42 This package includes libraries and compiled interfaces of findlib.
43
44 %description devel -l pl
45 Biblioteka "findlib" udostêpnia metodê zarz±dzania komponentami
46 oprogramowania (pakietami) oraz zawiera narzêdzia które ow± metodê
47 wspieraj±. Pakiety s± kolekcjami modu³ów w OCamlu, dla których jest
48 przechowywana metainformacja.
49
50 Ten pakiet zawiera biblioteki i skompilowane interfejsy findliba.
51
52 %prep
53 %setup -q -n findlib-%{version}
54
55 %build
56 ./configure \
57         -bindir %{_bindir} \
58         -mandir %{_mandir} \
59         -config %{_sysconfdir}/ocamlfind.conf
60
61 sed -e 's/-g//' Makefile > Makefile.tmp
62 mv -f Makefile.tmp Makefile
63
64 %{__make} all opt
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install PREFIX=$RPM_BUILD_ROOT
70
71 rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/findlib/*.mli
72
73 # in PLD only META files are stored in site-lib/pkg
74 sed -i -e 's|/site-lib||' $RPM_BUILD_ROOT%{_libdir}/ocaml/topfind
75 ln -sf %{_libdir}/ocaml/topfind $RPM_BUILD_ROOT%{_libdir}/ocaml/ocamlfind
76 rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/findlib
77 cp -a $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/findlib \
78         $RPM_BUILD_ROOT%{_libdir}/ocaml/findlib
79 rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/findlib/*.*
80 rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/findlib/META
81 echo 'directory = "+findlib"' >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/META
82 echo 'ldconf = "ignore"' >> $RPM_BUILD_ROOT%{_sysconfdir}/ocamlfind.conf
83
84 ln -s ../stublibs $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/libexec
85 ln -s ../stublibs $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/stublibs
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README LICENSE doc/html
93 %attr(755,root,root) %{_bindir}/*
94 %config %{_sysconfdir}/ocamlfind.conf
95 %{_libdir}/ocaml/site-lib
96 %{_mandir}/man[15]/*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %dir %{_libdir}/ocaml/findlib
101 %{_libdir}/ocaml/findlib/*.cm[ixa]*
102 %{_libdir}/ocaml/findlib/*.a
103 %{_libdir}/ocaml/ocamlfind
104 %{_libdir}/ocaml/topfind
105 %{_mandir}/man3/*
This page took 0.214163 seconds and 4 git commands to generate.