]> git.pld-linux.org Git - packages/ocaml-dune.git/blame - ocaml-dune.spec
- up to 2.8.4
[packages/ocaml-dune.git] / ocaml-dune.spec
CommitLineData
d5b28b2d
JR
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10%define module dune
11Summary: A composable build system for OCaml
12Name: ocaml-%{module}
5a04a328 13Version: 2.8.4
d5b28b2d
JR
14Release: 1
15License: MIT
16Group: Libraries
17Source0: https://github.com/ocaml/dune/archive/%{version}/%{module}-%{version}.tar.gz
5a04a328 18# Source0-md5: 68fbc294aeed510425d20498225d416b
d5b28b2d
JR
19URL: https://github.com/ocaml/dune
20BuildRequires: ocaml >= 3.04-7
21%requires_eq ocaml-runtime
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
d5b28b2d
JR
24%if %{without ocaml_opt}
25%define no_install_post_strip 1
26# no opt means no native binary, stripping bytecode breaks such programs
27%define _enable_debug_packages 0
28%endif
29
30%description
85cc6715
JR
31Dune is a build system designed for OCaml/Reason projects only. It
32focuses on providing the user with a consistent experience and takes
33care of most of the low-level details of OCaml compilation. All you
34have to do is provide a description of your project and dune will do
35the rest.
d5b28b2d
JR
36
37%prep
38%setup -q -n %{module}-%{version}
d5b28b2d
JR
39
40%build
5a04a328
JR
41./configure \
42 --libdir %{_libdir}/ocaml \
43 --mandir %{_mandir}
d5b28b2d 44
5a04a328 45%{__make} release \
d5b28b2d
JR
46 CC="%{__cc} %{rpmcflags} -fPIC"
47
5a04a328
JR
48%{__make} doc
49
d5b28b2d
JR
50%install
51rm -rf $RPM_BUILD_ROOT
52
53%{__make} install \
54 DESTDIR=$RPM_BUILD_ROOT
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%files
60%defattr(644,root,root,755)
61%doc LICENSE.md CHANGES.md README.md
62%attr(755,root,root) %{_bindir}/dune
5a04a328 63%{_libdir}/ocaml/dune
d5b28b2d
JR
64%{_mandir}/man1/dune*.1*
65%{_mandir}/man5/dune*.5*
This page took 0.048873 seconds and 4 git commands to generate.