]> git.pld-linux.org Git - packages/ocaml-curl.git/blobdiff - ocaml-curl.spec
- added sh patch (remove bashism from configure), unified ocaml files packaging
[packages/ocaml-curl.git] / ocaml-curl.spec
index 383fa81f7a841022b75a48050af143159afaa054..952853e58789cb57e039b65ea980eb9704bee417 100644 (file)
@@ -1,31 +1,37 @@
 #
 # Conditional build:
-%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
+%bcond_without ocaml_opt       # native optimized binaries (bytecode is always built)
 
-# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
-%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
+# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
+%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
 %undefine      with_ocaml_opt
 %endif
 
 %define debug_package %{nil}
-%define        pkgname curl
+
 Summary:       OCaml Curl library (ocurl)
-Name:          ocaml-%{pkgname}
-Version:       0.7.1
-Release:       2
+Summary(pl.UTF-8):     Biblioteka Curl dla OCamla (ocurl)
+Name:          ocaml-curl
+Version:       0.9.1
+Release:       4
 License:       MIT
 Group:         Libraries
-Source0:       https://forge.ocamlcore.org/frs/download.php/1400/ocurl-%{version}.tar.gz
-# Source0-md5: d138fd78538ae3bd008d6e9c2993d240
+Source0:       https://github.com/ygrek/ocurl/releases/download/%{version}/ocurl-%{version}.tar.gz
+# Source0-md5: 1ff6b12803fa0c6e9a4358dd29b83910
 Patch0:                ocaml_opt.patch
+Patch1:                %{name}-sh.patch
 URL:           http://ocurl.forge.ocamlcore.org/
-BuildRequires: curl-devel >= 7.12.0
+BuildRequires: autoconf >= 2.50
+BuildRequires: curl-devel >= 7.28.0
 BuildRequires: gawk
 BuildRequires: ocaml >= 3.10.0-7
 BuildRequires: ocaml-findlib-devel
+BuildRequires: ocaml-lwt-devel
+BuildRequires: ocaml-lwt-ppx-devel
+BuildRequires: pkgconfig
 # Explicitly require Curl (fixes RHBZ#711261). Since ocaml-curl uses
 # -custom rather than ocamlmklib, automatic detection is infeasible.
-Requires:      curl-devel >= 7.12.0
+Requires:      curl-devel >= 7.28.0
 %requires_eq   ocaml-runtime
 ExcludeArch:   sparc64 s390 s390x
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -34,29 +40,37 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 The Ocaml Curl Library (Ocurl) is an interface library for the
 programming language Ocaml to the networking library libcurl.
 
+%description -l pl.UTF-8
+Biblioteka Ocaml Curl (Ocurl) to biblioteka interfejsu języka
+programowania Ocaml do biblioteki sieciowe libcurl.
+
 %package devel
-Summary:       Development files for %{name}
+Summary:       OCaml Curl library (ocurl) - development part
+Summary(pl.UTF-8):     Biblioteka Curl dla OCamla (ocurl) - część programistyczna
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
-The %{name}-devel package contains libraries and signature files for
-developing applications that use %{name}.
+This package contains libraries and signature files for developing
+applications that use OCaml Curl library.
+
+%description devel -l pl.UTF-8
+Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
+z użyciem biblioteki OCamla Curl.
 
 %prep
 %setup -q -n ocurl-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
+%{__autoconf}
 %configure
-%{__make} -j1 all \
-%if %{with ocaml_opt}
-       OCBYTE="ocamlc.opt -g" \
-       OCOPT="ocamlopt.opt -g"
-%endif
+%{__make} -j1 all
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
 install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
 
@@ -66,8 +80,7 @@ install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
 # Install curl.mli
 cp -p curl.mli $OCAMLFIND_DESTDIR/curl
 
-install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/curl
-cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/curl/META <<EOF
+cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/curl/META <<EOF
 requires = ""
 version = "%{version}"
 directory = "+curl"
@@ -76,6 +89,9 @@ archive(native) = "curl.cmxa"
 linkopts = ""
 EOF
 
+# useless in rpm
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.so.owner
+
 # Make clean in the examples dir so our docs don't contain binaries.
 %{__make} -C examples clean
 
@@ -85,25 +101,26 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc COPYING
-%{_libdir}/ocaml/curl
-%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllcurl-helper.so
-%{_libdir}/ocaml/stublibs/dllcurl-helper.so.owner
+%dir %{_libdir}/ocaml/curl
+%{_libdir}/ocaml/curl/META
+%{_libdir}/ocaml/curl/*.cma
 %if %{with ocaml_opt}
-%exclude %{_libdir}/ocaml/curl/*.a
-%exclude %{_libdir}/ocaml/curl/*.o
-%exclude %{_libdir}/ocaml/curl/*.cmx
-%exclude %{_libdir}/ocaml/curl/*.cmxa
+%attr(755,root,root) %{_libdir}/ocaml/curl/*.cmxs
 %endif
-%exclude %{_libdir}/ocaml/curl/*.mli
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllcurl-helper.so
 
 %files devel
 %defattr(644,root,root,755)
 %doc examples/*
+%{_libdir}/ocaml/curl/libcurl-helper.a
+%{_libdir}/ocaml/curl/*.cmi
+%{_libdir}/ocaml/curl/*.cmo
+%{_libdir}/ocaml/curl/*.cmt
+%{_libdir}/ocaml/curl/*.cmti
+%{_libdir}/ocaml/curl/*.mli
 %if %{with ocaml_opt}
-%{_libdir}/ocaml/curl/*.a
-%{_libdir}/ocaml/curl/*.o
+%{_libdir}/ocaml/curl/curl*.a
 %{_libdir}/ocaml/curl/*.cmx
 %{_libdir}/ocaml/curl/*.cmxa
+%{_libdir}/ocaml/curl/*.o
 %endif
-%{_libdir}/ocaml/curl/*.mli
-%{_libdir}/ocaml/site-lib/curl
This page took 0.042068 seconds and 4 git commands to generate.