]> git.pld-linux.org Git - packages/ocaml-curl.git/blame_incremental - ocaml-curl.spec
rename to curl to match module name
[packages/ocaml-curl.git] / ocaml-curl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with opt # build opt
4
5%define debug_package %{nil}
6%define pkgname curl
7Summary: OCaml Curl library (ocurl)
8Name: ocaml-%{pkgname}
9Version: 0.6.0
10Release: 1
11License: MIT
12Group: Libraries
13Source0: https://forge.ocamlcore.org/frs/download.php/1238/ocurl-%{version}.tar.gz
14# Source0-md5: 21575e86b390c6c182a8dee42e8db1f3
15URL: http://ocurl.forge.ocamlcore.org/
16BuildRequires: curl-devel >= 7.12.0
17BuildRequires: gawk
18BuildRequires: ocaml >= 3.10.0-7
19BuildRequires: ocaml-findlib-devel
20# Explicitly require Curl (fixes RHBZ#711261). Since ocaml-curl uses
21# -custom rather than ocamlmklib, automatic detection is infeasible.
22Requires: curl-devel >= 7.12.0
23ExcludeArch: sparc64 s390 s390x
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27The Ocaml Curl Library (Ocurl) is an interface library for the
28programming language Ocaml to the networking library libcurl.
29
30%package devel
31Summary: Development files for %{name}
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34
35%description devel
36The %{name}-devel package contains libraries and signature files for
37developing applications that use %{name}.
38
39%prep
40%setup -q -n ocurl-%{version}
41
42%build
43%configure
44%{__make} -j1 all \
45%if %{with opt}
46 OCBYTE="ocamlc.opt -g" \
47 OCOPT="ocamlopt.opt -g"
48%endif
49
50%install
51rm -rf $RPM_BUILD_ROOT
52export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
53install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
54%{__make} install \
55 DESTDIR=$RPM_BUILD_ROOT
56
57# Install curl.mli
58cp -p curl.mli $OCAMLFIND_DESTDIR/curl
59
60# Make clean in the examples dir so our docs don't contain binaries.
61%{__make} -C examples clean
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
68%doc COPYING
69%{_libdir}/ocaml/curl
70%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllcurl-helper.so
71%{_libdir}/ocaml/stublibs/dllcurl-helper.so.owner
72%if %{with opt}
73%exclude %{_libdir}/ocaml/curl/*.a
74%exclude %{_libdir}/ocaml/curl/*.o
75%exclude %{_libdir}/ocaml/curl/*.cmx
76%exclude %{_libdir}/ocaml/curl/*.cmxa
77%endif
78%exclude %{_libdir}/ocaml/curl/*.mli
79
80%files devel
81%defattr(644,root,root,755)
82%doc examples/*
83%if %{with opt}
84%{_libdir}/ocaml/curl/*.a
85%{_libdir}/ocaml/curl/*.o
86%{_libdir}/ocaml/curl/*.cmx
87%{_libdir}/ocaml/curl/*.cmxa
88%endif
89%{_libdir}/ocaml/curl/*.mli
90
This page took 0.036508 seconds and 4 git commands to generate.