]> git.pld-linux.org Git - packages/ocaml-curl.git/blame_incremental - ocaml-curl.spec
- updated opt patch
[packages/ocaml-curl.git] / ocaml-curl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10%define debug_package %{nil}
11%define pkgname curl
12Summary: OCaml Curl library (ocurl)
13Name: ocaml-%{pkgname}
14Version: 0.9.1
15Release: 1
16License: MIT
17Group: Libraries
18Source0: https://github.com/ygrek/ocurl/releases/download/%{version}/ocurl-%{version}.tar.gz
19# Source0-md5: 1ff6b12803fa0c6e9a4358dd29b83910
20Patch0: ocaml_opt.patch
21URL: http://ocurl.forge.ocamlcore.org/
22BuildRequires: curl-devel >= 7.12.0
23BuildRequires: gawk
24BuildRequires: ocaml >= 3.10.0-7
25BuildRequires: ocaml-findlib-devel
26# Explicitly require Curl (fixes RHBZ#711261). Since ocaml-curl uses
27# -custom rather than ocamlmklib, automatic detection is infeasible.
28Requires: curl-devel >= 7.12.0
29%requires_eq ocaml-runtime
30ExcludeArch: sparc64 s390 s390x
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34The Ocaml Curl Library (Ocurl) is an interface library for the
35programming language Ocaml to the networking library libcurl.
36
37%package devel
38Summary: Development files for %{name}
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43The %{name}-devel package contains libraries and signature files for
44developing applications that use %{name}.
45
46%prep
47%setup -q -n ocurl-%{version}
48%patch0 -p1
49
50%build
51%configure
52%{__make} -j1 all
53
54%install
55rm -rf $RPM_BUILD_ROOT
56export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
57install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
58
59%{__make} install \
60 DESTDIR=$RPM_BUILD_ROOT
61
62# Install curl.mli
63cp -p curl.mli $OCAMLFIND_DESTDIR/curl
64
65cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/curl/META <<EOF
66requires = ""
67version = "%{version}"
68directory = "+curl"
69archive(byte) = "curl.cma"
70archive(native) = "curl.cmxa"
71linkopts = ""
72EOF
73
74install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/curl
75ln -sr $RPM_BUILD_ROOT%{_libdir}/ocaml/{curl,site-lib/curl}/META
76
77# Make clean in the examples dir so our docs don't contain binaries.
78%{__make} -C examples clean
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(644,root,root,755)
85%doc COPYING
86%{_libdir}/ocaml/curl
87%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllcurl-helper.so
88%{_libdir}/ocaml/stublibs/dllcurl-helper.so.owner
89%if %{with ocaml_opt}
90%exclude %{_libdir}/ocaml/curl/*.a
91%exclude %{_libdir}/ocaml/curl/*.cmxa
92%endif
93%exclude %{_libdir}/ocaml/curl/*.mli
94
95%files devel
96%defattr(644,root,root,755)
97%doc examples/*
98%if %{with ocaml_opt}
99%{_libdir}/ocaml/curl/*.a
100%{_libdir}/ocaml/curl/*.cmxa
101%endif
102%{_libdir}/ocaml/curl/*.mli
103%{_libdir}/ocaml/site-lib/curl
This page took 0.046411 seconds and 4 git commands to generate.