]> git.pld-linux.org Git - packages/ocaml-curl.git/blame - ocaml-curl.spec
- no need to (re)install .mli file
[packages/ocaml-curl.git] / ocaml-curl.spec
CommitLineData
26de232b
ER
1#
2# Conditional build:
6131789c 3%bcond_without ocaml_opt # native optimized binaries (bytecode is always built)
9781d077 4
6131789c
JB
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
9781d077
JR
7%undefine with_ocaml_opt
8%endif
26de232b
ER
9
10%define debug_package %{nil}
6131789c 11
26de232b 12Summary: OCaml Curl library (ocurl)
0acf091f 13Summary(pl.UTF-8): Biblioteka Curl dla OCamla (ocurl)
6131789c 14Name: ocaml-curl
e88cf738 15Version: 0.9.1
0680142d 16Release: 4
26de232b
ER
17License: MIT
18Group: Libraries
e88cf738
JR
19Source0: https://github.com/ygrek/ocurl/releases/download/%{version}/ocurl-%{version}.tar.gz
20# Source0-md5: 1ff6b12803fa0c6e9a4358dd29b83910
9781d077 21Patch0: ocaml_opt.patch
6131789c 22Patch1: %{name}-sh.patch
56573ec9 23URL: http://ocurl.forge.ocamlcore.org/
6131789c
JB
24BuildRequires: autoconf >= 2.50
25BuildRequires: curl-devel >= 7.28.0
26de232b
ER
26BuildRequires: gawk
27BuildRequires: ocaml >= 3.10.0-7
28BuildRequires: ocaml-findlib-devel
0680142d
JR
29BuildRequires: ocaml-lwt-devel
30BuildRequires: ocaml-lwt-ppx-devel
6131789c 31BuildRequires: pkgconfig
c81abe36 32# Explicitly require Curl (fixes RHBZ#711261). Since ocaml-curl uses
26de232b 33# -custom rather than ocamlmklib, automatic detection is infeasible.
6131789c 34Requires: curl-devel >= 7.28.0
c63f57ee 35%requires_eq ocaml-runtime
c81abe36 36ExcludeArch: sparc64 s390 s390x
26de232b
ER
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40The Ocaml Curl Library (Ocurl) is an interface library for the
41programming language Ocaml to the networking library libcurl.
42
0acf091f
JB
43%description -l pl.UTF-8
44Biblioteka Ocaml Curl (Ocurl) to biblioteka interfejsu języka
45programowania Ocaml do biblioteki sieciowe libcurl.
46
56573ec9 47%package devel
0acf091f
JB
48Summary: OCaml Curl library (ocurl) - development part
49Summary(pl.UTF-8): Biblioteka Curl dla OCamla (ocurl) - część programistyczna
26de232b
ER
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
56573ec9 53%description devel
0acf091f
JB
54This package contains libraries and signature files for developing
55applications that use OCaml Curl library.
56
57%description devel -l pl.UTF-8
58Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
59z użyciem biblioteki OCamla Curl.
26de232b
ER
60
61%prep
f6f0b5de 62%setup -q -n ocurl-%{version}
9ed04161 63%patch0 -p1
6131789c 64%patch1 -p1
26de232b
ER
65
66%build
6131789c 67%{__autoconf}
56573ec9 68%configure
5750614e 69%{__make} -j1 all
26de232b
ER
70
71%install
72rm -rf $RPM_BUILD_ROOT
0acf091f 73
26de232b
ER
74export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
75install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
9781d077 76
26de232b
ER
77%{__make} install \
78 DESTDIR=$RPM_BUILD_ROOT
79
9ed04161 80cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/curl/META <<EOF
4790749d
ER
81requires = ""
82version = "%{version}"
83directory = "+curl"
84archive(byte) = "curl.cma"
85archive(native) = "curl.cmxa"
86linkopts = ""
87EOF
88
6131789c
JB
89# useless in rpm
90%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.so.owner
91
26de232b
ER
92# Make clean in the examples dir so our docs don't contain binaries.
93%{__make} -C examples clean
aa521893
JB
94install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
26de232b
ER
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%files
101%defattr(644,root,root,755)
102%doc COPYING
a1673ef5
JR
103%dir %{_libdir}/ocaml/curl
104%{_libdir}/ocaml/curl/META
a1673ef5 105%{_libdir}/ocaml/curl/*.cma
90c843a1 106%if %{with ocaml_opt}
a1673ef5 107%attr(755,root,root) %{_libdir}/ocaml/curl/*.cmxs
26de232b 108%endif
6131789c 109%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllcurl-helper.so
26de232b
ER
110
111%files devel
112%defattr(644,root,root,755)
6131789c 113%{_libdir}/ocaml/curl/libcurl-helper.a
a1673ef5 114%{_libdir}/ocaml/curl/*.cmi
0680142d 115%{_libdir}/ocaml/curl/*.cmo
a1673ef5
JR
116%{_libdir}/ocaml/curl/*.cmt
117%{_libdir}/ocaml/curl/*.cmti
6131789c 118%{_libdir}/ocaml/curl/*.mli
9781d077 119%if %{with ocaml_opt}
6131789c 120%{_libdir}/ocaml/curl/curl*.a
a1673ef5 121%{_libdir}/ocaml/curl/*.cmx
26de232b 122%{_libdir}/ocaml/curl/*.cmxa
6131789c 123%{_libdir}/ocaml/curl/*.o
26de232b 124%endif
aa521893 125%{_examplesdir}/%{name}-%{version}
This page took 0.078809 seconds and 4 git commands to generate.