]> git.pld-linux.org Git - packages/ocaml-curl.git/blame - ocaml-curl.spec
- updated opt patch
[packages/ocaml-curl.git] / ocaml-curl.spec
CommitLineData
26de232b
ER
1#
2# Conditional build:
9781d077
JR
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
26de232b
ER
9
10%define debug_package %{nil}
f6f0b5de 11%define pkgname curl
26de232b 12Summary: OCaml Curl library (ocurl)
c81abe36 13Name: ocaml-%{pkgname}
e88cf738
JR
14Version: 0.9.1
15Release: 1
26de232b
ER
16License: MIT
17Group: Libraries
e88cf738
JR
18Source0: https://github.com/ygrek/ocurl/releases/download/%{version}/ocurl-%{version}.tar.gz
19# Source0-md5: 1ff6b12803fa0c6e9a4358dd29b83910
9781d077 20Patch0: ocaml_opt.patch
56573ec9 21URL: http://ocurl.forge.ocamlcore.org/
26de232b
ER
22BuildRequires: curl-devel >= 7.12.0
23BuildRequires: gawk
24BuildRequires: ocaml >= 3.10.0-7
25BuildRequires: ocaml-findlib-devel
c81abe36 26# Explicitly require Curl (fixes RHBZ#711261). Since ocaml-curl uses
26de232b
ER
27# -custom rather than ocamlmklib, automatic detection is infeasible.
28Requires: curl-devel >= 7.12.0
c63f57ee 29%requires_eq ocaml-runtime
c81abe36 30ExcludeArch: sparc64 s390 s390x
26de232b
ER
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34The Ocaml Curl Library (Ocurl) is an interface library for the
35programming language Ocaml to the networking library libcurl.
36
56573ec9 37%package devel
26de232b
ER
38Summary: Development files for %{name}
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
56573ec9 42%description devel
26de232b
ER
43The %{name}-devel package contains libraries and signature files for
44developing applications that use %{name}.
45
46%prep
f6f0b5de 47%setup -q -n ocurl-%{version}
9ed04161 48%patch0 -p1
26de232b
ER
49
50%build
56573ec9 51%configure
5750614e 52%{__make} -j1 all
26de232b
ER
53
54%install
55rm -rf $RPM_BUILD_ROOT
56export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
57install -d $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
9781d077 58
26de232b
ER
59%{__make} install \
60 DESTDIR=$RPM_BUILD_ROOT
61
62# Install curl.mli
63cp -p curl.mli $OCAMLFIND_DESTDIR/curl
64
9ed04161 65cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/curl/META <<EOF
4790749d
ER
66requires = ""
67version = "%{version}"
68directory = "+curl"
69archive(byte) = "curl.cma"
70archive(native) = "curl.cmxa"
71linkopts = ""
72EOF
73
9ed04161
JR
74install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/curl
75ln -sr $RPM_BUILD_ROOT%{_libdir}/ocaml/{curl,site-lib/curl}/META
76
26de232b
ER
77# Make clean in the examples dir so our docs don't contain binaries.
78%{__make} -C examples clean
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(644,root,root,755)
85%doc COPYING
86%{_libdir}/ocaml/curl
56573ec9
ER
87%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllcurl-helper.so
88%{_libdir}/ocaml/stublibs/dllcurl-helper.so.owner
9781d077 89%if %{with ocaml_opt}
26de232b 90%exclude %{_libdir}/ocaml/curl/*.a
26de232b
ER
91%exclude %{_libdir}/ocaml/curl/*.cmxa
92%endif
93%exclude %{_libdir}/ocaml/curl/*.mli
94
95%files devel
96%defattr(644,root,root,755)
97%doc examples/*
9781d077 98%if %{with ocaml_opt}
26de232b 99%{_libdir}/ocaml/curl/*.a
26de232b
ER
100%{_libdir}/ocaml/curl/*.cmxa
101%endif
102%{_libdir}/ocaml/curl/*.mli
4790749d 103%{_libdir}/ocaml/site-lib/curl
This page took 0.077394 seconds and 4 git commands to generate.