]> git.pld-linux.org Git - packages/ocaml-SDL.git/commitdiff
- fix safe string issues auto/th/ocaml-SDL-0.9.1-5
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 25 Mar 2021 20:55:18 +0000 (21:55 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 25 Mar 2021 20:55:18 +0000 (21:55 +0100)
- rel 5

ocaml-SDL.spec
safe-string.patch [new file with mode: 0644]

index 35698649c0dc8f01ed7d74db1f656d2cb8497c1a..ea0c0d921e60dd6360db77044b786f7a4e0a9f7f 100644 (file)
@@ -11,11 +11,12 @@ Summary:    SDL binding for OCaml
 Summary(pl.UTF-8):     Wiązania SDL dla OCamla
 Name:          ocaml-SDL
 Version:       0.9.1
-Release:       4
+Release:       5
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
 # Source0-md5: c3086423991fcdc1ba468afd52fc112b
+Patch0:                safe-string.patch
 URL:           http://ocamlsdl.sourceforge.net/
 BuildRequires: SDL-devel >= 1.2.0
 BuildRequires: SDL_image-devel
@@ -66,6 +67,7 @@ używających tej biblioteki.
 
 %prep
 %setup -q -n ocamlsdl-%{version}
+%patch0 -p1
 
 %build
 cp -f /usr/share/automake/config.* support
diff --git a/safe-string.patch b/safe-string.patch
new file mode 100644 (file)
index 0000000..7f757e9
--- /dev/null
@@ -0,0 +1,18 @@
+--- ocamlsdl-0.9.1.old/src/sdlmouse.ml 2011-04-10 16:33:52.000000000 +0100
++++ ocamlsdl-0.9.1/src/sdlmouse.ml     2017-11-18 11:24:01.989795950 +0000
+@@ -49,12 +49,12 @@
+     = "ml_SDL_Cursor_data"
+ let string_of_bits x =
+-  let s = String.make 8 ' ' in
++  let s = Bytes.make 8 ' ' in
+   for i=0 to 7 do
+     if x land (1 lsl i) <> 0
+-    then s.[7-i] <- '@'
++    then Bytes.set s (7-i) '@'
+   done ;
+-  s
++  Bytes.to_string s
+ let pprint_cursor c =
+   let { data = data ; mask = mask } = cursor_data c in
This page took 0.039854 seconds and 4 git commands to generate.