]> git.pld-linux.org Git - packages/ocaml-SDL.git/blobdiff - ocaml-SDL.spec
- rebuild with ocaml 4.02
[packages/ocaml-SDL.git] / ocaml-SDL.spec
index b692a55072b6dc17db6f796038a14626f913999c..f23cf67986756f3f864c68cad4891e4cabe2bd90 100644 (file)
@@ -1,19 +1,23 @@
+%define                ocaml_ver       1:3.09.2
 Summary:       SDL binding for OCaml
-Summary(pl):   Wi±zania SDL dla OCamla
+Summary(pl.UTF-8):     Wiązania SDL dla OCamla
 Name:          ocaml-SDL
-Version:       0.7.1
-Release:       0.1
+Version:       0.8.0
+Release:       2
 License:       GPL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
-# Source0-md5: 3829b20bd975e3bef5195a54e2cd04cb
+# Source0-md5: b7ee334cf107867cc8d08cbcc319c9af
 URL:           http://ocamlsdl.sourceforge.net/
 BuildRequires: SDL-devel
+BuildRequires: SDL_image-devel
 BuildRequires: SDL_mixer-devel
 BuildRequires: SDL_ttf-devel
-BuildRequires: SDLimage-devel
-BuildRequires: glut-devel
-BuildRequires: ocaml >= 3.07
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: ocaml >= %{ocaml_ver}
+BuildRequires: ocaml-findlib-devel
+BuildRequires: ocaml-lablgl-devel
 %requires_eq   ocaml-runtime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -24,9 +28,16 @@ between the ML programming language and the SDL C library.
 This package contains files needed to run bytecode executables using
 this library.
 
+%description -l pl.UTF-8
+OCamlSDL to próba napisania interfejsu programowego między językiem
+programowania ML a biblioteką C SDL.
+
+Ten pakiet zawiera pliki potrzebne do uruchamiania wykonywalnego
+bytecodu używającego tej biblioteki.
+
 %package devel
 Summary:       SDL binding for OCaml - development part
-Summary(pl):   Wi±zania SDL dla OCamla - cze¶æ programistyczna
+Summary(pl.UTF-8):     Wiązania SDL dla OCamla - cześć programistyczna
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %requires_eq   ocaml
@@ -38,56 +49,29 @@ between the ML programming language and the SDL C library.
 This package contains files needed to develop OCaml programs using
 this library.
 
+%description devel -l pl.UTF-8
+OCamlSDL to próba napisania interfejsu programowego między językiem
+programowania ML a biblioteką C SDL.
+
+Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
+używających tej biblioteki.
+
 %prep
-%setup -q -n ocamlsdl
+%setup -q -n ocamlsdl-%{version}
 
 %build
-%{__make} -C gl \
-       CC="%{__cc}" \
-       CFLAGS="%{rpmcflags} -fPIC"
-%{__make} -C hgl \
-       CC="%{__cc}" \
-       CFLAGS="%{rpmcflags} -fPIC"
-%{__make} -C glfw \
-       CC="%{__cc}" \
-       CFLAGS="%{rpmcflags} -fPIC" \
-       X11LIBS="-L/usr/X11R6/%{_lib}"
-%{__make} -C glut \
-       CC="%{__cc}" \
-       CFLAGS="%{rpmcflags} -fPIC" \
-       X11LIBS="-L/usr/X11R6/%{_lib}"
+cp -f /usr/share/automake/config.* support
+%{__aclocal} -I support
+%{__autoconf}
+%configure
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{gl,stublibs}
-
-install lib/*.cm[ixa]* lib/*.a $RPM_BUILD_ROOT%{_libdir}/ocaml/gl
-install lib/dll*.so $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-cp -r demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
-install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/ocamlgl-gl
-cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/ocamlgl-gl/META <<EOF
-requires = "bigarray"
-version = "%{version}"
-directory = "+gl"
-archive(byte) = "gl.cma"
-archive(native) = "gl.cmxa"
-linkopts = ""
-EOF
-
-for f in glut hgl glfw ; do
-       install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/ocamlgl-$f
-       cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/ocamlgl-$f/META <<EOF
-requires = "ocamlgl-gl"
-version = "%{version}"
-directory = "+gl"
-archive(byte) = "$f.cma"
-archive(native) = "$f.cmxa"
-linkopts = ""
-EOF
-done
+install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
+
+%{__make} install \
+       OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -98,9 +82,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc LICENSE glfw/license.txt README Announce doc/*
-%dir %{_libdir}/ocaml/gl
-%{_libdir}/ocaml/gl/*.cm[ixa]*
-%{_libdir}/ocaml/gl/*.a
-%{_libdir}/ocaml/site-lib/*
-%{_examplesdir}/%{name}-%{version}
+%doc README AUTHORS NEWS doc/html doc/ocaml*
+%dir %{_libdir}/ocaml/sdl
+%{_libdir}/ocaml/sdl/*
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/*.owner
This page took 0.055481 seconds and 4 git commands to generate.