]> git.pld-linux.org Git - packages/ocaml-SDL.git/blobdiff - ocaml-SDL.spec
- really disable ocamlopt if not supported (configure sets OCAMLOPT=no while Makefile...
[packages/ocaml-SDL.git] / ocaml-SDL.spec
index 0385e20926658b547383748666afca883dd425b5..ac1f70f2fb224f0c865f099e76929d785c63bd55 100644 (file)
@@ -1,18 +1,30 @@
+#
+# Conditional build:
+%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
+
+%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
+%undefine      with_ocaml_opt
+%endif
+
+%define                ocaml_ver       1:3.09.2
 Summary:       SDL binding for OCaml
-Summary(pl):   Wi±zania SDL dla OCamla
+Summary(pl.UTF-8):     Wiązania SDL dla OCamla
 Name:          ocaml-SDL
-Version:       0.7.2
-Release:       0.1
-License:       GPL
+Version:       0.9.1
+Release:       1
+License:       LGPL v2+
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
-# Source0-md5: 0707a9cf80bd9cfe18ad660dc077bad6
+Source0:       http://downloads.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
+# Source0-md5: c3086423991fcdc1ba468afd52fc112b
 URL:           http://ocamlsdl.sourceforge.net/
-BuildRequires: SDL-devel
+BuildRequires: SDL-devel >= 1.2.0
 BuildRequires: SDL_image-devel
 BuildRequires: SDL_mixer-devel
 BuildRequires: SDL_ttf-devel
-BuildRequires: ocaml >= 3.07
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: ocaml >= %{ocaml_ver}
+BuildRequires: ocaml-findlib
 BuildRequires: ocaml-lablgl-devel
 %requires_eq   ocaml-runtime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -24,16 +36,16 @@ between the ML programming language and the SDL C library.
 This package contains files needed to run bytecode executables using
 this library.
 
-%description -l pl
-OCamlSDL to próba napisania interfejsu programowego miêdzy jêzykiem
-programowania ML a bibliotek± C SDL.
+%description -l pl.UTF-8
+OCamlSDL to próba napisania interfejsu programowego między językiem
+programowania ML a biblioteką C SDL.
 
 Ten pakiet zawiera pliki potrzebne do uruchamiania wykonywalnego
-bytecodu u¿ywaj±cego tej biblioteki.
+bytecodu używającego tej biblioteki.
 
 %package devel
 Summary:       SDL binding for OCaml - development part
-Summary(pl):   Wi±zania SDL dla OCamla - cze¶æ programistyczna
+Summary(pl.UTF-8):     Wiązania SDL dla OCamla - cześć programistyczna
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %requires_eq   ocaml
@@ -45,39 +57,59 @@ between the ML programming language and the SDL C library.
 This package contains files needed to develop OCaml programs using
 this library.
 
-%description devel -l pl
-OCamlSDL to próba napisania interfejsu programowego miêdzy jêzykiem
-programowania ML a bibliotek± C SDL.
+%description devel -l pl.UTF-8
+OCamlSDL to próba napisania interfejsu programowego między językiem
+programowania ML a biblioteką C SDL.
 
-Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
-u¿ywaj±cych tej biblioteki.
+Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
+używających tej biblioteki.
 
 %prep
 %setup -q -n ocamlsdl-%{version}
 
 %build
+cp -f /usr/share/automake/config.* support
+%{__aclocal} -I support
+%{__autoconf}
 %configure
-%{__make}
+%{__make} \
+       %{!?with_ocaml_opt:OCAMLOPT=}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
 
 %{__make} install \
-       OCAMLLIBDIR=%{_libdir}/ocaml \
-       OCAMLSDLDIR=%{_libdir}/ocaml/sdl \
-       DESTDIR=$RPM_BUILD_ROOT
+       OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
+       %{!?with_ocaml_opt:OCAMLOPT=}
+
+# ocamlfind-specific, useless in rpm
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.owner
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
+%doc AUTHORS NEWS README
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlstub.so
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlgfxstub.so
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlloaderstub.so
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlmixerstub.so
+%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlttfstub.so
 
 %files devel
 %defattr(644,root,root,755)
-%doc README AUTHORS NEWS doc/html doc/ocaml*
+%doc doc/html/*
 %dir %{_libdir}/ocaml/sdl
-%{_libdir}/ocaml/sdl/*
-%attr(755,root,root) %{_libdir}/ocaml/stublibs/*
+%{_libdir}/ocaml/sdl/META
+%{_libdir}/ocaml/sdl/libsdl*.a
+%{_libdir}/ocaml/sdl/sdl*.cma
+%{_libdir}/ocaml/sdl/sdl*.cmi
+# doc?
+%{_libdir}/ocaml/sdl/sdl*.mli
+%if %{with ocaml_opt}
+%{_libdir}/ocaml/sdl/sdl*.a
+%{_libdir}/ocaml/sdl/sdl*.cmx
+%{_libdir}/ocaml/sdl/sdl*.cmxa
+%endif
This page took 0.039143 seconds and 4 git commands to generate.