]> git.pld-linux.org Git - packages/ocaml-SDL.git/blob - ocaml-SDL.spec
- tabs in preamble
[packages/ocaml-SDL.git] / ocaml-SDL.spec
1 %define         ocaml_ver       1:3.09.2
2 Summary:        SDL binding for OCaml
3 Summary(pl.UTF-8):      Wiązania SDL dla OCamla
4 Name:           ocaml-SDL
5 Version:        0.7.2
6 Release:        5
7 License:        GPL
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
10 # Source0-md5:  0707a9cf80bd9cfe18ad660dc077bad6
11 URL:            http://ocamlsdl.sourceforge.net/
12 BuildRequires:  SDL-devel
13 BuildRequires:  SDL_image-devel
14 BuildRequires:  SDL_mixer-devel
15 BuildRequires:  SDL_ttf-devel
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  ocaml >= %{ocaml_ver}
19 BuildRequires:  ocaml-findlib-devel
20 BuildRequires:  ocaml-lablgl-devel
21 %requires_eq    ocaml-runtime
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Simply speaking, OCamlSDL is an attempt to write a software interface
26 between the ML programming language and the SDL C library.
27
28 This package contains files needed to run bytecode executables using
29 this library.
30
31 %description -l pl.UTF-8
32 OCamlSDL to próba napisania interfejsu programowego między językiem
33 programowania ML a biblioteką C SDL.
34
35 Ten pakiet zawiera pliki potrzebne do uruchamiania wykonywalnego
36 bytecodu używającego tej biblioteki.
37
38 %package devel
39 Summary:        SDL binding for OCaml - development part
40 Summary(pl.UTF-8):      Wiązania SDL dla OCamla - cześć programistyczna
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 %requires_eq    ocaml
44
45 %description devel
46 Simply speaking, OCamlSDL is an attempt to write a software interface
47 between the ML programming language and the SDL C library.
48
49 This package contains files needed to develop OCaml programs using
50 this library.
51
52 %description devel -l pl.UTF-8
53 OCamlSDL to próba napisania interfejsu programowego między językiem
54 programowania ML a biblioteką C SDL.
55
56 Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
57 używających tej biblioteki.
58
59 %prep
60 %setup -q -n ocamlsdl-%{version}
61
62 %build
63 cp -f /usr/share/automake/config.* support
64 %{__aclocal} -I support
65 %{__autoconf}
66 %configure
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
72
73 %{__make} install \
74         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
82
83 %files devel
84 %defattr(644,root,root,755)
85 %doc README AUTHORS NEWS doc/html doc/ocaml*
86 %dir %{_libdir}/ocaml/sdl
87 %{_libdir}/ocaml/sdl/*
88 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.owner
This page took 0.059944 seconds and 4 git commands to generate.