]> git.pld-linux.org Git - packages/ocaml-SDL.git/blob - ocaml-SDL.spec
- updated to 0.9.1, added ocaml_opt bcond
[packages/ocaml-SDL.git] / ocaml-SDL.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4
5 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
6 %undefine       with_ocaml_opt
7 %endif
8
9 %define         ocaml_ver       1:3.09.2
10 Summary:        SDL binding for OCaml
11 Summary(pl.UTF-8):      Wiązania SDL dla OCamla
12 Name:           ocaml-SDL
13 Version:        0.9.1
14 Release:        1
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
18 # Source0-md5:  c3086423991fcdc1ba468afd52fc112b
19 URL:            http://ocamlsdl.sourceforge.net/
20 BuildRequires:  SDL-devel >= 1.2.0
21 BuildRequires:  SDL_image-devel
22 BuildRequires:  SDL_mixer-devel
23 BuildRequires:  SDL_ttf-devel
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  ocaml >= %{ocaml_ver}
27 BuildRequires:  ocaml-findlib
28 BuildRequires:  ocaml-lablgl-devel
29 %requires_eq    ocaml-runtime
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Simply speaking, OCamlSDL is an attempt to write a software interface
34 between the ML programming language and the SDL C library.
35
36 This package contains files needed to run bytecode executables using
37 this library.
38
39 %description -l pl.UTF-8
40 OCamlSDL to próba napisania interfejsu programowego między językiem
41 programowania ML a biblioteką C SDL.
42
43 Ten pakiet zawiera pliki potrzebne do uruchamiania wykonywalnego
44 bytecodu używającego tej biblioteki.
45
46 %package devel
47 Summary:        SDL binding for OCaml - development part
48 Summary(pl.UTF-8):      Wiązania SDL dla OCamla - cześć programistyczna
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 %requires_eq    ocaml
52
53 %description devel
54 Simply speaking, OCamlSDL is an attempt to write a software interface
55 between the ML programming language and the SDL C library.
56
57 This package contains files needed to develop OCaml programs using
58 this library.
59
60 %description devel -l pl.UTF-8
61 OCamlSDL to próba napisania interfejsu programowego między językiem
62 programowania ML a biblioteką C SDL.
63
64 Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
65 używających tej biblioteki.
66
67 %prep
68 %setup -q -n ocamlsdl-%{version}
69
70 %build
71 cp -f /usr/share/automake/config.* support
72 %{__aclocal} -I support
73 %{__autoconf}
74 %configure
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
80
81 %{__make} install \
82         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
83
84 # ocamlfind-specific, useless in rpm
85 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.owner
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS NEWS README
93 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlstub.so
94 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlgfxstub.so
95 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlloaderstub.so
96 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlmixerstub.so
97 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlttfstub.so
98
99 %files devel
100 %defattr(644,root,root,755)
101 %doc doc/html/*
102 %dir %{_libdir}/ocaml/sdl
103 %{_libdir}/ocaml/sdl/META
104 %{_libdir}/ocaml/sdl/libsdl*.a
105 %{_libdir}/ocaml/sdl/sdl*.cma
106 %{_libdir}/ocaml/sdl/sdl*.cmi
107 # doc?
108 %{_libdir}/ocaml/sdl/sdl*.mli
109 %if %{with ocaml_opt}
110 %{_libdir}/ocaml/sdl/sdl*.a
111 %{_libdir}/ocaml/sdl/sdl*.cmx
112 %{_libdir}/ocaml/sdl/sdl*.cmxa
113 %endif
This page took 0.040076 seconds and 3 git commands to generate.