]> git.pld-linux.org Git - packages/ocaml-SDL.git/blame - ocaml-SDL.spec
- release 2 (by relup.sh)
[packages/ocaml-SDL.git] / ocaml-SDL.spec
CommitLineData
e94c6065
JB
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
6%undefine with_ocaml_opt
7%endif
8
0eaf468a 9%define ocaml_ver 1:3.09.2
b741b828 10Summary: SDL binding for OCaml
3ebd64ba 11Summary(pl.UTF-8): Wiązania SDL dla OCamla
b741b828 12Name: ocaml-SDL
e94c6065 13Version: 0.9.1
451016dc 14Release: 2
e94c6065 15License: LGPL v2+
b741b828 16Group: Libraries
e94c6065
JB
17Source0: http://downloads.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
18# Source0-md5: c3086423991fcdc1ba468afd52fc112b
b741b828 19URL: http://ocamlsdl.sourceforge.net/
e94c6065 20BuildRequires: SDL-devel >= 1.2.0
93ef2896 21BuildRequires: SDL_image-devel
b741b828
JR
22BuildRequires: SDL_mixer-devel
23BuildRequires: SDL_ttf-devel
6ec8c8da
JB
24BuildRequires: autoconf
25BuildRequires: automake
480d0786 26BuildRequires: ocaml >= %{ocaml_ver}
e94c6065 27BuildRequires: ocaml-findlib
4607d6ce 28BuildRequires: ocaml-lablgl-devel
b741b828
JR
29%requires_eq ocaml-runtime
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Simply speaking, OCamlSDL is an attempt to write a software interface
34between the ML programming language and the SDL C library.
35
36This package contains files needed to run bytecode executables using
37this library.
38
9328c039
JR
39%description -l pl.UTF-8
40OCamlSDL to próba napisania interfejsu programowego między językiem
41programowania ML a biblioteką C SDL.
93ef2896
JB
42
43Ten pakiet zawiera pliki potrzebne do uruchamiania wykonywalnego
9328c039 44bytecodu używającego tej biblioteki.
93ef2896 45
b741b828
JR
46%package devel
47Summary: SDL binding for OCaml - development part
3ebd64ba 48Summary(pl.UTF-8): Wiązania SDL dla OCamla - cześć programistyczna
b741b828
JR
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51%requires_eq ocaml
52
53%description devel
54Simply speaking, OCamlSDL is an attempt to write a software interface
55between the ML programming language and the SDL C library.
56
57This package contains files needed to develop OCaml programs using
58this library.
59
9328c039
JR
60%description devel -l pl.UTF-8
61OCamlSDL to próba napisania interfejsu programowego między językiem
62programowania ML a biblioteką C SDL.
93ef2896 63
9328c039
JR
64Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
65używających tej biblioteki.
93ef2896 66
b741b828 67%prep
4607d6ce 68%setup -q -n ocamlsdl-%{version}
b741b828
JR
69
70%build
6ec8c8da 71cp -f /usr/share/automake/config.* support
476da9c0
JR
72%{__aclocal} -I support
73%{__autoconf}
4607d6ce 74%configure
6382d7bb
JB
75%{__make} \
76 %{!?with_ocaml_opt:OCAMLOPT=}
b741b828
JR
77
78%install
79rm -rf $RPM_BUILD_ROOT
07b43a1e 80install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
b741b828 81
6684267e 82%{__make} install \
6382d7bb
JB
83 OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
84 %{!?with_ocaml_opt:OCAMLOPT=}
b741b828 85
e94c6065
JB
86# ocamlfind-specific, useless in rpm
87%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.owner
88
b741b828
JR
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
e94c6065
JB
94%doc AUTHORS NEWS README
95%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlstub.so
96%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlgfxstub.so
97%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlloaderstub.so
98%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlmixerstub.so
99%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlttfstub.so
b741b828
JR
100
101%files devel
102%defattr(644,root,root,755)
e94c6065 103%doc doc/html/*
4607d6ce 104%dir %{_libdir}/ocaml/sdl
e94c6065
JB
105%{_libdir}/ocaml/sdl/META
106%{_libdir}/ocaml/sdl/libsdl*.a
107%{_libdir}/ocaml/sdl/sdl*.cma
108%{_libdir}/ocaml/sdl/sdl*.cmi
109# doc?
110%{_libdir}/ocaml/sdl/sdl*.mli
111%if %{with ocaml_opt}
112%{_libdir}/ocaml/sdl/sdl*.a
113%{_libdir}/ocaml/sdl/sdl*.cmx
114%{_libdir}/ocaml/sdl/sdl*.cmxa
115%endif
This page took 0.084533 seconds and 4 git commands to generate.