]> git.pld-linux.org Git - packages/ocaml-SDL.git/blame - ocaml-SDL.spec
rebuild with separate debuginfo build-ids
[packages/ocaml-SDL.git] / ocaml-SDL.spec
CommitLineData
e94c6065
JB
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
6%undefine with_ocaml_opt
7%endif
8
0eaf468a 9%define ocaml_ver 1:3.09.2
b741b828 10Summary: SDL binding for OCaml
3ebd64ba 11Summary(pl.UTF-8): Wiązania SDL dla OCamla
b741b828 12Name: ocaml-SDL
e94c6065 13Version: 0.9.1
29d61bd5 14Release: 6
e94c6065 15License: LGPL v2+
b741b828 16Group: Libraries
e94c6065
JB
17Source0: http://downloads.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
18# Source0-md5: c3086423991fcdc1ba468afd52fc112b
9808146f 19Patch0: safe-string.patch
b741b828 20URL: http://ocamlsdl.sourceforge.net/
e94c6065 21BuildRequires: SDL-devel >= 1.2.0
93ef2896 22BuildRequires: SDL_image-devel
b741b828
JR
23BuildRequires: SDL_mixer-devel
24BuildRequires: SDL_ttf-devel
6ec8c8da
JB
25BuildRequires: autoconf
26BuildRequires: automake
480d0786 27BuildRequires: ocaml >= %{ocaml_ver}
e94c6065 28BuildRequires: ocaml-findlib
4607d6ce 29BuildRequires: ocaml-lablgl-devel
b741b828
JR
30%requires_eq ocaml-runtime
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Simply speaking, OCamlSDL is an attempt to write a software interface
35between the ML programming language and the SDL C library.
36
37This package contains files needed to run bytecode executables using
38this library.
39
9328c039
JR
40%description -l pl.UTF-8
41OCamlSDL to próba napisania interfejsu programowego między językiem
42programowania ML a biblioteką C SDL.
93ef2896
JB
43
44Ten pakiet zawiera pliki potrzebne do uruchamiania wykonywalnego
9328c039 45bytecodu używającego tej biblioteki.
93ef2896 46
b741b828
JR
47%package devel
48Summary: SDL binding for OCaml - development part
3ebd64ba 49Summary(pl.UTF-8): Wiązania SDL dla OCamla - cześć programistyczna
b741b828
JR
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52%requires_eq ocaml
53
54%description devel
55Simply speaking, OCamlSDL is an attempt to write a software interface
56between the ML programming language and the SDL C library.
57
58This package contains files needed to develop OCaml programs using
59this library.
60
9328c039
JR
61%description devel -l pl.UTF-8
62OCamlSDL to próba napisania interfejsu programowego między językiem
63programowania ML a biblioteką C SDL.
93ef2896 64
9328c039
JR
65Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
66używających tej biblioteki.
93ef2896 67
b741b828 68%prep
4607d6ce 69%setup -q -n ocamlsdl-%{version}
9808146f 70%patch0 -p1
b741b828
JR
71
72%build
6ec8c8da 73cp -f /usr/share/automake/config.* support
476da9c0
JR
74%{__aclocal} -I support
75%{__autoconf}
4607d6ce 76%configure
6382d7bb
JB
77%{__make} \
78 %{!?with_ocaml_opt:OCAMLOPT=}
b741b828
JR
79
80%install
81rm -rf $RPM_BUILD_ROOT
07b43a1e 82install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
b741b828 83
6684267e 84%{__make} install \
6382d7bb
JB
85 OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
86 %{!?with_ocaml_opt:OCAMLOPT=}
b741b828 87
e94c6065
JB
88# ocamlfind-specific, useless in rpm
89%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.owner
90
b741b828
JR
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(644,root,root,755)
e94c6065
JB
96%doc AUTHORS NEWS README
97%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlstub.so
98%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlgfxstub.so
99%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlloaderstub.so
100%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlmixerstub.so
101%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlttfstub.so
b741b828
JR
102
103%files devel
104%defattr(644,root,root,755)
e94c6065 105%doc doc/html/*
4607d6ce 106%dir %{_libdir}/ocaml/sdl
e94c6065
JB
107%{_libdir}/ocaml/sdl/META
108%{_libdir}/ocaml/sdl/libsdl*.a
109%{_libdir}/ocaml/sdl/sdl*.cma
110%{_libdir}/ocaml/sdl/sdl*.cmi
111# doc?
112%{_libdir}/ocaml/sdl/sdl*.mli
113%if %{with ocaml_opt}
114%{_libdir}/ocaml/sdl/sdl*.a
115%{_libdir}/ocaml/sdl/sdl*.cmx
116%{_libdir}/ocaml/sdl/sdl*.cmxa
117%endif
This page took 0.053468 seconds and 4 git commands to generate.