]> git.pld-linux.org Git - packages/ocaml-SDL.git/blame - ocaml-SDL.spec
- uopdated BRs, rel 7
[packages/ocaml-SDL.git] / ocaml-SDL.spec
CommitLineData
e94c6065
JB
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
6%undefine with_ocaml_opt
7%endif
8
0eaf468a 9%define ocaml_ver 1:3.09.2
b741b828 10Summary: SDL binding for OCaml
3ebd64ba 11Summary(pl.UTF-8): Wiązania SDL dla OCamla
b741b828 12Name: ocaml-SDL
e94c6065 13Version: 0.9.1
b148f2c7 14Release: 7
e94c6065 15License: LGPL v2+
b741b828 16Group: Libraries
e94c6065
JB
17Source0: http://downloads.sourceforge.net/ocamlsdl/ocamlsdl-%{version}.tar.gz
18# Source0-md5: c3086423991fcdc1ba468afd52fc112b
9808146f 19Patch0: safe-string.patch
b741b828 20URL: http://ocamlsdl.sourceforge.net/
e94c6065 21BuildRequires: SDL-devel >= 1.2.0
b148f2c7 22BuildRequires: SDL_gfx-devel
93ef2896 23BuildRequires: SDL_image-devel
b741b828
JR
24BuildRequires: SDL_mixer-devel
25BuildRequires: SDL_ttf-devel
6ec8c8da
JB
26BuildRequires: autoconf
27BuildRequires: automake
480d0786 28BuildRequires: ocaml >= %{ocaml_ver}
e94c6065 29BuildRequires: ocaml-findlib
4607d6ce 30BuildRequires: ocaml-lablgl-devel
b741b828
JR
31%requires_eq ocaml-runtime
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Simply speaking, OCamlSDL is an attempt to write a software interface
36between the ML programming language and the SDL C library.
37
38This package contains files needed to run bytecode executables using
39this library.
40
9328c039
JR
41%description -l pl.UTF-8
42OCamlSDL to próba napisania interfejsu programowego między językiem
43programowania ML a biblioteką C SDL.
93ef2896
JB
44
45Ten pakiet zawiera pliki potrzebne do uruchamiania wykonywalnego
9328c039 46bytecodu używającego tej biblioteki.
93ef2896 47
b741b828
JR
48%package devel
49Summary: SDL binding for OCaml - development part
3ebd64ba 50Summary(pl.UTF-8): Wiązania SDL dla OCamla - cześć programistyczna
b741b828
JR
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53%requires_eq ocaml
54
55%description devel
56Simply speaking, OCamlSDL is an attempt to write a software interface
57between the ML programming language and the SDL C library.
58
59This package contains files needed to develop OCaml programs using
60this library.
61
9328c039
JR
62%description devel -l pl.UTF-8
63OCamlSDL to próba napisania interfejsu programowego między językiem
64programowania ML a biblioteką C SDL.
93ef2896 65
9328c039
JR
66Ten pakiet zawiera pliki potrzebne do tworzenia programów w OCamlu
67używających tej biblioteki.
93ef2896 68
b741b828 69%prep
4607d6ce 70%setup -q -n ocamlsdl-%{version}
9808146f 71%patch0 -p1
b741b828
JR
72
73%build
6ec8c8da 74cp -f /usr/share/automake/config.* support
476da9c0
JR
75%{__aclocal} -I support
76%{__autoconf}
4607d6ce 77%configure
6382d7bb
JB
78%{__make} \
79 %{!?with_ocaml_opt:OCAMLOPT=}
b741b828
JR
80
81%install
82rm -rf $RPM_BUILD_ROOT
07b43a1e 83install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
b741b828 84
6684267e 85%{__make} install \
6382d7bb
JB
86 OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
87 %{!?with_ocaml_opt:OCAMLOPT=}
b741b828 88
e94c6065
JB
89# ocamlfind-specific, useless in rpm
90%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.owner
91
b741b828
JR
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(644,root,root,755)
e94c6065
JB
97%doc AUTHORS NEWS README
98%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlstub.so
99%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlgfxstub.so
100%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlloaderstub.so
101%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlmixerstub.so
102%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsdlttfstub.so
b741b828
JR
103
104%files devel
105%defattr(644,root,root,755)
e94c6065 106%doc doc/html/*
4607d6ce 107%dir %{_libdir}/ocaml/sdl
e94c6065
JB
108%{_libdir}/ocaml/sdl/META
109%{_libdir}/ocaml/sdl/libsdl*.a
110%{_libdir}/ocaml/sdl/sdl*.cma
111%{_libdir}/ocaml/sdl/sdl*.cmi
112# doc?
113%{_libdir}/ocaml/sdl/sdl*.mli
114%if %{with ocaml_opt}
115%{_libdir}/ocaml/sdl/sdl*.a
116%{_libdir}/ocaml/sdl/sdl*.cmx
117%{_libdir}/ocaml/sdl/sdl*.cmxa
118%endif
This page took 0.046403 seconds and 4 git commands to generate.