]> git.pld-linux.org Git - packages/nuspell.git/blob - nuspell.spec
b8575127d1f14a0856ecbd740b1f7a3c73da6bc9
[packages/nuspell.git] / nuspell.spec
1 # TODO: catch2 for tests, https://github.com/catchorg/Catch2.git
2 Summary:        Nuspell spell checking library
3 Summary(pl.UTF-8):      Biblioteka sprawdzania pisowni Nuspell
4 Name:           nuspell
5 Version:        3.0.0
6 Release:        1
7 License:        LGPL v3+
8 Group:          Libraries
9 #Source0Download: https://github.com/nuspell/nuspell/releases
10 Source0:        https://github.com/nuspell/nuspell/archive/v%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  4d8bd5582fd3d467267bdea31bdc1767
12 URL:            https://nuspell.github.io/
13 BuildRequires:  boost-devel >= 1.62
14 BuildRequires:  cmake >= 3.8
15 BuildRequires:  libicu-devel
16 # -std=c++17
17 BuildRequires:  libstdc++-devel >= 6:7
18 BuildRequires:  ronn
19 Requires:       %{name}-libs = %{version}-%{release}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Nuspell is a spell checker library and command-line program designed
24 for languages with rich morphology and complex word compounding.
25 Nuspell is a pure C++ re-implementation of Hunspell.
26
27 Main features of Nuspell spell checker:
28 - Full unicode support backed by ICU
29 - Backward compatibility with Hunspell dictionary file format
30 - Twofold affix stripping (for agglutinative languages, like Azeri,
31   Basque, Estonian, Finnish, Hungarian, Turkish, etc.)
32 - Support complex compounds (for example, Hungarian and German)
33 - Support language specific features (for example, special casing of
34   Azeri and Turkish dotted i, or German sharp s)
35 - Handle conditional affixes, circumfixes, fogemorphemes, forbidden
36   words, pseudoroots and homonyms.
37 - Free software. Licensed under GNU LGPL v3.
38
39 %description -l pl.UTF-8
40 Nuspell to biblioteka i narzędzie linii poleceń do sprawdzania
41 pisowni, zaprojektowane dla języków o bogatej morfologii i złożonym
42 łączeniu słów. Nuspell jest reimplementacją Hunspella w czystym C++.
43
44 Główne cechy Nuspella:
45 - pełna obsługa Unicode oparta o ICU
46 - wsteczna zgodność z formatem plików słówników Hunspella
47 - dwukrotne usuwanie formantów (dla języków aglutynacyjnych, jak
48   azerski, baskijski, estoński, fiński, węgierski, turecki...)
49 - obsługa złożonego łączenia (języki np. węgierski, niemiecki)
50 - obsługa cech specyficznych dla języków (np. specjalne przypadki
51   azerskiego i tureckiego "i" z kropkami czy niemieckiego ß)
52 - obsługa formantów warunkowych, okołorostków, fogemorfemów, słów
53   zakazanych, pseudordzeni i homonimów
54 - oprogramowanie wolnodostępne, na licencji GNU LGPL v3
55
56 %package libs
57 Summary:        Nuspell spell checking library
58 Summary(pl.UTF-8):      Biblioteka sprawdzania pisowni Nuspell
59 Group:          Libraries
60
61 %description libs
62 Nuspell spell checking library.
63
64 %description libs -l pl.UTF-8
65 Biblioteka sprawdzania pisowni Nuspell.
66
67 %package devel
68 Summary:        Header files for Nuspell library
69 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Nuspell
70 Group:          Development/Libraries
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       libicu-devel
73 Requires:       libstdc++-devel >= 6:7
74
75 %description devel
76 Header files for Nuspell library.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe biblioteki Nuspell.
80
81 %prep
82 %setup -q
83
84 %build
85 install -d build
86 cd build
87 %cmake ..
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} -C build install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 # packaged as %doc
98 %{__rm} $RPM_BUILD_ROOT%{_docdir}/README.md
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   libs -p /sbin/ldconfig
104 %postun libs -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS CHANGELOG.md README.md docs/Third-party_licenses
109 %attr(755,root,root) %{_bindir}/nuspell
110 %{_mandir}/man1/nuspell.1*
111
112 %files libs
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libnuspell.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libnuspell.so.3
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libnuspell.so
120 %{_includedir}/nuspell
121 %{_pkgconfigdir}/nuspell.pc
122 %{_libdir}/cmake/nuspell
This page took 0.066304 seconds and 2 git commands to generate.