]> git.pld-linux.org Git - packages/nuspell.git/blob - nuspell.spec
icu rebuild
[packages/nuspell.git] / nuspell.spec
1 # TODO: catch2 >= 2.3.0 for tests, https://github.com/catchorg/Catch2.git
2 #
3 # Conditional build:
4 %bcond_without  man     # build without man pages
5
6 Summary:        Nuspell spell checking library
7 Summary(pl.UTF-8):      Biblioteka sprawdzania pisowni Nuspell
8 Name:           nuspell
9 Version:        4.2.0
10 Release:        3
11 License:        LGPL v3+
12 Group:          Libraries
13 #Source0Download: https://github.com/nuspell/nuspell/releases
14 Source0:        https://github.com/nuspell/nuspell/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  16441229868de708939765e52f75a2b1
16 URL:            https://nuspell.github.io/
17 BuildRequires:  cmake >= 3.8
18 BuildRequires:  libicu-devel
19 # -std=c++17
20 BuildRequires:  libstdc++-devel >= 6:7
21 %{?with_man:BuildRequires:      pandoc}
22 Requires:       %{name}-libs = %{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Nuspell is a spell checker library and command-line program designed
27 for languages with rich morphology and complex word compounding.
28 Nuspell is a pure C++ re-implementation of Hunspell.
29
30 Main features of Nuspell spell checker:
31 - Full unicode support backed by ICU
32 - Backward compatibility with Hunspell dictionary file format
33 - Twofold affix stripping (for agglutinative languages, like Azeri,
34   Basque, Estonian, Finnish, Hungarian, Turkish, etc.)
35 - Support complex compounds (for example, Hungarian and German)
36 - Support language specific features (for example, special casing of
37   Azeri and Turkish dotted i, or German sharp s)
38 - Handle conditional affixes, circumfixes, fogemorphemes, forbidden
39   words, pseudoroots and homonyms.
40 - Free software. Licensed under GNU LGPL v3.
41
42 %description -l pl.UTF-8
43 Nuspell to biblioteka i narzędzie linii poleceń do sprawdzania
44 pisowni, zaprojektowane dla języków o bogatej morfologii i złożonym
45 łączeniu słów. Nuspell jest reimplementacją Hunspella w czystym C++.
46
47 Główne cechy Nuspella:
48 - pełna obsługa Unicode oparta o ICU
49 - wsteczna zgodność z formatem plików słówników Hunspella
50 - dwukrotne usuwanie formantów (dla języków aglutynacyjnych, jak
51   azerski, baskijski, estoński, fiński, węgierski, turecki...)
52 - obsługa złożonego łączenia (języki np. węgierski, niemiecki)
53 - obsługa cech specyficznych dla języków (np. specjalne przypadki
54   azerskiego i tureckiego "i" z kropkami czy niemieckiego ß)
55 - obsługa formantów warunkowych, okołorostków, fogemorfemów, słów
56   zakazanych, pseudordzeni i homonimów
57 - oprogramowanie wolnodostępne, na licencji GNU LGPL v3
58
59 %package libs
60 Summary:        Nuspell spell checking library
61 Summary(pl.UTF-8):      Biblioteka sprawdzania pisowni Nuspell
62 Group:          Libraries
63
64 %description libs
65 Nuspell spell checking library.
66
67 %description libs -l pl.UTF-8
68 Biblioteka sprawdzania pisowni Nuspell.
69
70 %package devel
71 Summary:        Header files for Nuspell library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Nuspell
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{version}-%{release}
75 Requires:       libicu-devel
76 Requires:       libstdc++-devel >= 6:7
77
78 %description devel
79 Header files for Nuspell library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki Nuspell.
83
84 %prep
85 %setup -q
86
87 %build
88 install -d build
89 cd build
90 %cmake ..
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} -C build install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 # packaged as %doc
101 %{__rm} $RPM_BUILD_ROOT%{_docdir}/README.md
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   libs -p /sbin/ldconfig
107 %postun libs -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS CHANGELOG.md README.md docs/Third-party_licenses
112 %attr(755,root,root) %{_bindir}/nuspell
113 %{?with_man:%{_mandir}/man1/nuspell.1*}
114
115 %files libs
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libnuspell.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libnuspell.so.4
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libnuspell.so
123 %{_includedir}/nuspell
124 %{_pkgconfigdir}/nuspell.pc
125 %{_libdir}/cmake/nuspell
This page took 0.036356 seconds and 3 git commands to generate.