]> git.pld-linux.org Git - packages/nuspell.git/blob - nuspell.spec
- icu 67 rebuild
[packages/nuspell.git] / nuspell.spec
1 # TODO: catch2 for tests, https://github.com/catchorg/Catch2.git
2 #
3 # Conditional build:
4 %bcond_without  man     # build without man pages
5
6 Summary:        Nuspell spell checking library
7 Summary(pl.UTF-8):      Biblioteka sprawdzania pisowni Nuspell
8 Name:           nuspell
9 Version:        3.0.0
10 Release:        2
11 License:        LGPL v3+
12 Group:          Libraries
13 #Source0Download: https://github.com/nuspell/nuspell/releases
14 Source0:        https://github.com/nuspell/nuspell/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  4d8bd5582fd3d467267bdea31bdc1767
16 URL:            https://nuspell.github.io/
17 BuildRequires:  boost-devel >= 1.62
18 BuildRequires:  cmake >= 3.8
19 BuildRequires:  libicu-devel
20 # -std=c++17
21 BuildRequires:  libstdc++-devel >= 6:7
22 %{?with_man:BuildRequires:      ronn}
23 Requires:       %{name}-libs = %{version}-%{release}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Nuspell is a spell checker library and command-line program designed
28 for languages with rich morphology and complex word compounding.
29 Nuspell is a pure C++ re-implementation of Hunspell.
30
31 Main features of Nuspell spell checker:
32 - Full unicode support backed by ICU
33 - Backward compatibility with Hunspell dictionary file format
34 - Twofold affix stripping (for agglutinative languages, like Azeri,
35   Basque, Estonian, Finnish, Hungarian, Turkish, etc.)
36 - Support complex compounds (for example, Hungarian and German)
37 - Support language specific features (for example, special casing of
38   Azeri and Turkish dotted i, or German sharp s)
39 - Handle conditional affixes, circumfixes, fogemorphemes, forbidden
40   words, pseudoroots and homonyms.
41 - Free software. Licensed under GNU LGPL v3.
42
43 %description -l pl.UTF-8
44 Nuspell to biblioteka i narzędzie linii poleceń do sprawdzania
45 pisowni, zaprojektowane dla języków o bogatej morfologii i złożonym
46 łączeniu słów. Nuspell jest reimplementacją Hunspella w czystym C++.
47
48 Główne cechy Nuspella:
49 - pełna obsługa Unicode oparta o ICU
50 - wsteczna zgodność z formatem plików słówników Hunspella
51 - dwukrotne usuwanie formantów (dla języków aglutynacyjnych, jak
52   azerski, baskijski, estoński, fiński, węgierski, turecki...)
53 - obsługa złożonego łączenia (języki np. węgierski, niemiecki)
54 - obsługa cech specyficznych dla języków (np. specjalne przypadki
55   azerskiego i tureckiego "i" z kropkami czy niemieckiego ß)
56 - obsługa formantów warunkowych, okołorostków, fogemorfemów, słów
57   zakazanych, pseudordzeni i homonimów
58 - oprogramowanie wolnodostępne, na licencji GNU LGPL v3
59
60 %package libs
61 Summary:        Nuspell spell checking library
62 Summary(pl.UTF-8):      Biblioteka sprawdzania pisowni Nuspell
63 Group:          Libraries
64
65 %description libs
66 Nuspell spell checking library.
67
68 %description libs -l pl.UTF-8
69 Biblioteka sprawdzania pisowni Nuspell.
70
71 %package devel
72 Summary:        Header files for Nuspell library
73 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Nuspell
74 Group:          Development/Libraries
75 Requires:       %{name}-libs = %{version}-%{release}
76 Requires:       libicu-devel
77 Requires:       libstdc++-devel >= 6:7
78
79 %description devel
80 Header files for Nuspell library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki Nuspell.
84
85 %prep
86 %setup -q
87
88 %build
89 install -d build
90 cd build
91 %cmake ..
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # packaged as %doc
102 %{__rm} $RPM_BUILD_ROOT%{_docdir}/README.md
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   libs -p /sbin/ldconfig
108 %postun libs -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS CHANGELOG.md README.md docs/Third-party_licenses
113 %attr(755,root,root) %{_bindir}/nuspell
114 %{?with_man:%{_mandir}/man1/nuspell.1*}
115
116 %files libs
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libnuspell.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libnuspell.so.3
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libnuspell.so
124 %{_includedir}/nuspell
125 %{_pkgconfigdir}/nuspell.pc
126 %{_libdir}/cmake/nuspell
This page took 0.052153 seconds and 3 git commands to generate.