]> git.pld-linux.org Git - packages/nuspell.git/blame - nuspell.spec
add man bcond (to avoid ruby dependency)
[packages/nuspell.git] / nuspell.spec
CommitLineData
08eb1a1a 1# TODO: catch2 for tests, https://github.com/catchorg/Catch2.git
191460ee
JP
2#
3# Conditional build:
4%bcond_without man # build without man pages
5
08eb1a1a
JB
6Summary: Nuspell spell checking library
7Summary(pl.UTF-8): Biblioteka sprawdzania pisowni Nuspell
8Name: nuspell
9Version: 3.0.0
10Release: 1
11License: LGPL v3+
12Group: Libraries
13#Source0Download: https://github.com/nuspell/nuspell/releases
14Source0: https://github.com/nuspell/nuspell/archive/v%{version}/%{name}-%{version}.tar.gz
15# Source0-md5: 4d8bd5582fd3d467267bdea31bdc1767
16URL: https://nuspell.github.io/
17BuildRequires: boost-devel >= 1.62
18BuildRequires: cmake >= 3.8
19BuildRequires: libicu-devel
20# -std=c++17
21BuildRequires: libstdc++-devel >= 6:7
191460ee 22%{?with_man:BuildRequires: ronn}
08eb1a1a
JB
23Requires: %{name}-libs = %{version}-%{release}
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Nuspell is a spell checker library and command-line program designed
28for languages with rich morphology and complex word compounding.
29Nuspell is a pure C++ re-implementation of Hunspell.
30
31Main features of Nuspell spell checker:
32- Full unicode support backed by ICU
33- Backward compatibility with Hunspell dictionary file format
34- Twofold affix stripping (for agglutinative languages, like Azeri,
35 Basque, Estonian, Finnish, Hungarian, Turkish, etc.)
36- Support complex compounds (for example, Hungarian and German)
37- Support language specific features (for example, special casing of
38 Azeri and Turkish dotted i, or German sharp s)
39- Handle conditional affixes, circumfixes, fogemorphemes, forbidden
40 words, pseudoroots and homonyms.
41- Free software. Licensed under GNU LGPL v3.
42
43%description -l pl.UTF-8
44Nuspell to biblioteka i narzędzie linii poleceń do sprawdzania
45pisowni, zaprojektowane dla języków o bogatej morfologii i złożonym
46łączeniu słów. Nuspell jest reimplementacją Hunspella w czystym C++.
47
48Główne cechy Nuspella:
49- pełna obsługa Unicode oparta o ICU
50- wsteczna zgodność z formatem plików słówników Hunspella
51- dwukrotne usuwanie formantów (dla języków aglutynacyjnych, jak
52 azerski, baskijski, estoński, fiński, węgierski, turecki...)
53- obsługa złożonego łączenia (języki np. węgierski, niemiecki)
54- obsługa cech specyficznych dla języków (np. specjalne przypadki
55 azerskiego i tureckiego "i" z kropkami czy niemieckiego ß)
56- obsługa formantów warunkowych, okołorostków, fogemorfemów, słów
57 zakazanych, pseudordzeni i homonimów
58- oprogramowanie wolnodostępne, na licencji GNU LGPL v3
59
60%package libs
61Summary: Nuspell spell checking library
62Summary(pl.UTF-8): Biblioteka sprawdzania pisowni Nuspell
63Group: Libraries
64
65%description libs
66Nuspell spell checking library.
67
68%description libs -l pl.UTF-8
69Biblioteka sprawdzania pisowni Nuspell.
70
71%package devel
72Summary: Header files for Nuspell library
73Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Nuspell
74Group: Development/Libraries
75Requires: %{name}-libs = %{version}-%{release}
76Requires: libicu-devel
77Requires: libstdc++-devel >= 6:7
78
79%description devel
80Header files for Nuspell library.
81
82%description devel -l pl.UTF-8
83Pliki nagłówkowe biblioteki Nuspell.
84
85%prep
86%setup -q
87
88%build
89install -d build
90cd build
91%cmake ..
92
93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98%{__make} -C build install \
99 DESTDIR=$RPM_BUILD_ROOT
100
101# packaged as %doc
102%{__rm} $RPM_BUILD_ROOT%{_docdir}/README.md
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post libs -p /sbin/ldconfig
108%postun libs -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
112%doc AUTHORS CHANGELOG.md README.md docs/Third-party_licenses
113%attr(755,root,root) %{_bindir}/nuspell
191460ee 114%{?with_man:%{_mandir}/man1/nuspell.1*}
08eb1a1a
JB
115
116%files libs
117%defattr(644,root,root,755)
118%attr(755,root,root) %{_libdir}/libnuspell.so.*.*.*
119%attr(755,root,root) %ghost %{_libdir}/libnuspell.so.3
120
121%files devel
122%defattr(644,root,root,755)
123%attr(755,root,root) %{_libdir}/libnuspell.so
124%{_includedir}/nuspell
125%{_pkgconfigdir}/nuspell.pc
126%{_libdir}/cmake/nuspell
This page took 0.106701 seconds and 4 git commands to generate.