]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
- release 6 (by relup.sh)
[packages/ntop.git] / ntop.spec
1 # TODO
2 # - see if it uses system files for ettercap and geoip, ieee-oui files we did not package
3 # - see where plugins are needed in plugin dir or in system dir
4 # - unpackaged
5 #        /etc/ntop/GeoIPASNum.dat
6 #        /etc/ntop/GeoLiteCity.dat
7 #        /usr/lib64/libntop.a
8 #        /usr/lib64/libntopreport.a
9 # NOTE: can read oui.txt.xz if MAKE_WITH_ZLIB enabled
10 #
11 # Conditional build:
12 %bcond_with     mysql   # with mysql support
13
14 Summary:        Network monitoring tool
15 Summary(pl.UTF-8):      Narzędzie do monitorowania sieci
16 Name:           ntop
17 Version:        5.0.1
18 Release:        6
19 License:        GPL v3+
20 Group:          Networking
21 Source0:        http://downloads.sourceforge.net/ntop/%{name}-%{version}.tar.gz
22 # Source0-md5:  01710b6925a8a5ffe1a41b8b512ebd69
23 Source1:        %{name}.init
24 Source2:        %{name}.sysconfig
25 # http://ettercap.cvs.sourceforge.net/ettercap/ettercap_ng/share/etter.finger.os?rev=HEAD
26 Source3:        etter.finger.os
27 Patch0:         %{name}-conf.patch
28 Patch1:         %{name}-config.patch
29 Patch2:         %{name}-am.patch
30 Patch3:         %{name}-lua_wget.patch
31 Patch4:         %{name}-http_c.patch
32 Patch5:         %{name}-running-user.patch
33 Patch6:         ieee-oui.patch
34 Patch7:         %{name}-install.patch
35 Patch8:         %{name}-rrdtool-1.6.0.patch
36 Patch9:         ac-am.patch
37 URL:            http://www.ntop.org/
38 BuildRequires:  GeoIP-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake >= 1.6
41 BuildRequires:  gawk
42 BuildRequires:  gd-devel >= 2.0.1
43 BuildRequires:  gdbm-devel >= 1.8.3
44 BuildRequires:  gdome2-devel
45 BuildRequires:  glib2-devel
46 BuildRequires:  libdbi-devel
47 BuildRequires:  libevent-devel >= 1.4.0
48 BuildRequires:  libpcap-devel
49 BuildRequires:  libpng-devel
50 BuildRequires:  libtiff-devel
51 BuildRequires:  libtool
52 BuildRequires:  libwrap-devel
53 BuildRequires:  lua51-devel
54 BuildRequires:  ncurses-devel >= 5.2
55 BuildRequires:  net-snmp-devel
56 BuildRequires:  openssl-devel >= 0.9.7d
57 BuildRequires:  perl-devel
58 BuildRequires:  readline-devel >= 4.2
59 BuildRequires:  rpm-pythonprov
60 BuildRequires:  rpmbuild(macros) >= 1.268
61 BuildRequires:  rrdtool-devel >= 1.1.0
62 BuildRequires:  sed >= 4.0
63 BuildRequires:  zlib-devel
64 Requires(post,postun):  /sbin/ldconfig
65 Requires(post,preun):   /sbin/chkconfig
66 Requires(postun):       /usr/sbin/groupdel
67 Requires(postun):       /usr/sbin/userdel
68 Requires(pre):  /bin/id
69 Requires(pre):  /usr/bin/getgid
70 Requires(pre):  /usr/sbin/groupadd
71 Requires(pre):  /usr/sbin/useradd
72 Requires:       hwdata >= 0.243-2
73 Requires:       rc-scripts >= 0.4.2.8
74 # maybe is optional, needs checking
75 Suggests:       GeoIP-db-City
76 Suggests:       GeoIP-db-IPASNum
77 Suggests:       ettercap
78 Provides:       group(ntop)
79 Provides:       user(ntop)
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _localstatedir          /var/lib
83
84 %description
85 ntop is a tool that shows the network usage, similar to what the
86 popular top Unix command does.
87
88 %description -l pl.UTF-8
89 ntop to narzędzie, które pokazuje użycie sieci w podobny sposób jak
90 robi to popularna uniksowa komenda top.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98 %patch4 -p1
99 %patch5 -p1
100 %patch6 -p1
101 %patch7 -p1
102 %patch8 -p1
103 %patch9 -p1
104
105 gzip -9c %{SOURCE3} >etter.finger.os.gz
106
107 # taken from autogen.sh
108 cp -f %{_aclocaldir}/libtool.m4 libtool.m4.in
109 cat acinclude.m4.in libtool.m4.in acinclude.m4.ntop > acinclude.m4
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117
118 cd nDPI
119 %configure
120 %{__make}
121 cd ..
122
123 # "verified.awk -u" calls require gawk
124 %configure \
125         AWK=gawk \
126         --disable-static \
127         --with-gnu-ld \
128         --with-ossl-root=%{_prefix} \
129         --with-tcpwrap \
130         --enable-snmp \
131         %{?with_mysql:--enable-mysql}
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{%{_localstatedir}/ntop/rrd,/etc/{rc.d/init.d,sysconfig},%{_sbindir}}
138
139 %{__make} install \
140         GEOIP_FILES= \
141         OUI_FILES= \
142         ETTER_PASSIVE= \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ntop
146 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ntop
147 cp -a packages/RedHat/ntop.conf.sample $RPM_BUILD_ROOT%{_sysconfdir}/ntop.conf
148
149 # these are identical files according to find-debuginfo
150 for p in icmpPlugin lastSeenPlugin netflowPlugin cpacketPlugin rrdPlugin sflowPlugin; do
151         ln -snf ../../lib$p-%{version}.so $RPM_BUILD_ROOT%{_libdir}/ntop/plugins/$p.so
152 done
153
154 # read by checkForInputFile() scanning various dirs and extensions
155 ln -s /lib/hwdata/oui.txt $RPM_BUILD_ROOT%{_sysconfdir}/ntop/oui.txt
156
157 # no -devel
158 rm -f $RPM_BUILD_ROOT%{_libdir}{,/ntop/plugins}/*.la
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %pre
164 %groupadd -g 120 ntop
165 %useradd -u 120 -d %{_localstatedir}/ntop -s /bin/false -c "ntop User" -g ntop ntop
166
167 %post
168 /sbin/ldconfig
169 /sbin/chkconfig --add ntop
170 %service ntop restart "ntop daemon"
171
172 %preun
173 if [ "$1" = "0" ]; then
174         %service ntop stop
175         /sbin/chkconfig --del ntop
176 fi
177
178 %postun
179 /sbin/ldconfig
180 if [ "$1" = "0" ]; then
181         %userremove ntop
182         %groupremove ntop
183 fi
184
185 %files
186 %defattr(644,root,root,755)
187 %doc AUTHORS ChangeLog NEWS README THANKS docs/{1STRUN.txt,FAQ}
188 %attr(750,root,ntop) %dir %{_sysconfdir}/ntop
189 %attr(640,root,ntop) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ntop/ntop-cert.pem
190 %attr(640,root,ntop) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ntop/oui.txt
191 %attr(640,root,ntop) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ntop/specialMAC.txt.gz
192 %attr(660,root,ntop) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ntop.conf
193 %attr(754,root,root) /etc/rc.d/init.d/ntop
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ntop
195 %attr(755,root,root) %{_sbindir}/ntop
196 %attr(755,root,root) %{_libdir}/lib*.so
197 %attr(755,root,root) %{_datadir}/%{name}
198 %dir %{_libdir}/%{name}
199 %attr(755,root,root) %{_libdir}/%{name}/plugins
200 %{_mandir}/man8/ntop.8*
201
202 %attr(770,root,ntop) %dir %{_localstatedir}/ntop
203 %attr(770,root,ntop) %dir %{_localstatedir}/ntop/rrd
This page took 0.101294 seconds and 3 git commands to generate.