]> git.pld-linux.org Git - packages/npm.git/commitdiff
- pl, updated dependencies auto/th/npm-6.14.8-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 10 Sep 2020 15:25:52 +0000 (17:25 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 10 Sep 2020 15:25:52 +0000 (17:25 +0200)
- package more man pages (hoping they won't conflict with future packages)

npm.spec

index c66ee30bc85faa116fa0f36ccdc7b53190553054..03bf8af0d0c9481275dd43564241560ec008d393 100644 (file)
--- a/npm.spec
+++ b/npm.spec
@@ -2,30 +2,30 @@
 # - put man3 to some -devel-doc package (man pages for npm programming)
 # - it can't live without this path: Error: ENOENT, no such file or directory '/usr/lib/node_modules/npm/man/man1/'
 # - npm-debug.log is created with 777 perms, should respect umask instead
-
-# build package without bundled node-gyp module
-%bcond_without  bundled_gyp
+#
+# Conditional build:
+%bcond_without  bundled_gyp    # package without bundled node-gyp module
 
 Summary:       A package manager for node.js
+Summary(pl.UTF-8):     Zarządca pakietów dla node.js
 Name:          npm
 Version:       6.14.8
 Release:       1
-License:       Artistic-2.0
-Group:         Development/Libraries
+License:       Artistic v2.0
+Group:         Development/Tools
 Source0:       http://registry.npmjs.org/npm/-/%{name}-%{version}.tgz
 # Source0-md5: ef90bb5e76fda0a1e248036b916c8fd8
 Patch0:                link-globalPaths.patch
 Patch1:                cmd-shim-optional.patch
-URL:           http://npmjs.org/
+URL:           https://www.npmjs.com/
 BuildRequires: bash
-BuildRequires: nodejs >= 0.9
+BuildRequires: nodejs >= 6
 BuildRequires: rpmbuild(macros) >= 1.634
 BuildRequires: sed >= 4.0
-Requires:      nodejs
+Requires:      nodejs >= 6
 %if %{without bundled_gyp}
-Suggests:      nodejs-gyp
-Conflicts:     nodejs-gyp < 3.5.0
-Conflicts:     nodejs-gyp >= 3.4.0
+Suggests:      nodejs-gyp = 5.1.0
+Conflicts:     nodejs-gyp < 5.1.0
 %endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -35,22 +35,26 @@ NPM is a package manager for node.js. You can use it to install and
 publish your node programs. It manages dependencies and does other
 cool stuff.
 
+%description -l pl.UTF-8
+NPM to zarządca pakietów dla node.js. Można go używać do instalowania
+i publikowania kodu w Node.
+
 %package -n bash-completion-%{name}
-Summary:       bash-completion for %{name}
-Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla %{name}
+Summary:       bash completion for NPM commands
+Summary(pl.UTF-8):     bashowe uzupełnianie parametrów dla poleceń NPM
 Group:         Applications/Shells
-Requires:      %{name}
+Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
 
 %description -n bash-completion-%{name}
-bash-completion for %{name}.
+bash completion for NPM commands.
 
 %description -n bash-completion-%{name} -l pl.UTF-8
-bashowe uzupełnianie nazw dla %{name}.
+bashowe uzupełnianie parametrów dla poleceń NPM.
 
 %prep
 %setup -qc
-mv package/* .
+%{__mv} package/* .
 %patch0 -p1
 %patch1 -p1
 
@@ -62,15 +66,15 @@ grep -rl '#!.*env \(node\|python\|sh\|bash\)' . | xargs %{__sed} -i -e '1{
 }'
 
 # startup helpers we don't need
-rm bin/npm bin/npm.cmd
+%{__rm} bin/npm bin/npm.cmd
 
 # clean up node_modules/
 for i in README.markdown LICENSE \
        .npmignore .travis.yml test examples example samples; do
-       find node_modules -name $i -print0 | sort -rz | xargs -0r rm -rv
+       find node_modules -name $i -print0 | sort -rz | xargs -0r %{__rm} -rv
 done
-find node_modules -name \*.md -print0 -exec rm -v {} \;
-rm lib/fetch-package-metadata.md
+find node_modules -name \*.md -print0 -exec %{__rm} -v {} \;
+%{__rm} lib/fetch-package-metadata.md
 
 %build
 # forces npm to keep config files in /etc instead of /usr/etc
@@ -91,7 +95,7 @@ ln -s %{nodejs_libdir}/npm/bin/npm-cli.js $RPM_BUILD_ROOT%{_bindir}/npm
 ln -s %{nodejs_libdir}/npm/bin/npx-cli.js $RPM_BUILD_ROOT%{_bindir}/npx
 
 %if %{without bundled_gyp}
-rm -r node_modules/node-gyp
+%{__rm} -r node_modules/node-gyp
 %endif
 cp -r node_modules $RPM_BUILD_ROOT%{nodejs_libdir}/npm/
 
@@ -112,7 +116,7 @@ cp -pr man/* $RPM_BUILD_ROOT%{_mandir}
 # FIXME: "npm help" requires this
 ln -s %{_mandir} $RPM_BUILD_ROOT%{nodejs_libdir}/npm/man
 
-mv $RPM_BUILD_ROOT%{nodejs_libdir}/npm/lib/utils/completion.sh \
+%{__mv} $RPM_BUILD_ROOT%{nodejs_libdir}/npm/lib/utils/completion.sh \
        $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}.sh
 
 %clean
@@ -120,7 +124,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS LICENSE README.md
+%doc AUTHORS CHANGELOG.md LICENSE README.md
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/npmrc
 %ghost %{_sysconfdir}/npmignore
 %attr(755,root,root) %{_bindir}/npm
@@ -150,13 +154,24 @@ rm -rf $RPM_BUILD_ROOT
 %{nodejs_libdir}/npm/doc/configuring-npm
 %{nodejs_libdir}/npm/doc/using-npm
 
-%{_mandir}/man1/npm*.1*
-%{_mandir}/man1/npx*.1*
+%{_mandir}/man1/npm.1*
+%{_mandir}/man1/npm-*.1*
+%{_mandir}/man1/npx.1*
+%{_mandir}/man5/folders.5*
+%{_mandir}/man5/install.5*
 %{_mandir}/man5/npm*.5*
 %{_mandir}/man5/package-json.5*
 %{_mandir}/man5/package-lock-json.5*
 %{_mandir}/man5/package-locks.5*
 %{_mandir}/man5/shrinkwrap-json.5*
+%{_mandir}/man7/config.7*
+%{_mandir}/man7/developers.7*
+%{_mandir}/man7/disputes.7*
+%{_mandir}/man7/orgs.7*
+%{_mandir}/man7/registry.7*
+%{_mandir}/man7/removal.7*
+%{_mandir}/man7/scope.7*
+%{_mandir}/man7/scripts.7*
 %{_mandir}/man7/semver.7*
 
 %files -n bash-completion-%{name}
This page took 0.083099 seconds and 4 git commands to generate.