]> git.pld-linux.org Git - packages/nomacs.git/blame - nomacs.spec
- rebuild with opencv 3.4
[packages/nomacs.git] / nomacs.spec
CommitLineData
723c4b5a 1# TODO: add plugins (https://github.com/nomacs/nomacs-plugins/)
baec5b45 2Summary: Lightweight image viewer
cd4112e8 3Summary(pl.UTF-8): Lekka przeglądarka obrazków
baec5b45 4Name: nomacs
af2a9792 5Version: 3.4.1
2d410ba1 6Release: 4
baec5b45
ER
7License: GPL v3+
8Group: X11/Applications
af2a9792
JB
9Source0: https://github.com/nomacs/nomacs/archive/%{version}/%{name}-%{version}-source.tar.gz
10# Source0-md5: 1daf7458717eb545b2da8534cff36d6e
af2a9792 11Patch0: quazip-qt5.patch
723c4b5a 12Patch1: %{name}-libqpsd.patch
baec5b45 13URL: http://nomacs.org/
af2a9792
JB
14BuildRequires: Qt5Concurrent-devel >= 5.2.1
15BuildRequires: Qt5Core-devel >= 5.2.1
16BuildRequires: Qt5Gui-devel >= 5.2.1
17BuildRequires: Qt5Network-devel >= 5.2.1
18BuildRequires: Qt5Svg-devel >= 5.2.1
19BuildRequires: cmake >= 2.8
baec5b45
ER
20BuildRequires: desktop-file-utils
21BuildRequires: dos2unix
af2a9792 22BuildRequires: exiv2-devel >= 0.25
723c4b5a 23BuildRequires: libqpsd-qt5-devel
af2a9792
JB
24BuildRequires: libraw-devel >= 0.17
25BuildRequires: libstdc++-devel >= 6:4.3
baec5b45
ER
26BuildRequires: libtiff-devel
27BuildRequires: libwebp-devel >= 0.3.1
af2a9792 28BuildRequires: opencv-devel >= 2.4.6
8861805b 29BuildRequires: pkgconfig
af2a9792
JB
30BuildRequires: qt5-build >= 5.2.1
31BuildRequires: qt5-linguist >= 5.2.1
32BuildRequires: qt5-qmake >= 5.2.1
cd4112e8 33BuildRequires: quazip-qt5-devel >= 0.7
af2a9792
JB
34Requires: Qt5Concurrent >= 5.2.1
35Requires: Qt5Core >= 5.2.1
36Requires: Qt5Gui >= 5.2.1
37Requires: Qt5Network >= 5.2.1
38Requires: Qt5Svg >= 5.2.1
def72f2b 39Requires: exiv2-libs >= 0.25
af2a9792
JB
40Requires: libraw >= 0.17
41Requires: opencv >= 2.4.6
baec5b45
ER
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
afd8e3bd 45nomacs is image viewer based on Qt library.
baec5b45
ER
46
47nomacs is small, fast and able to handle the most common image
48formats. Additionally it is possible to synchronize multiple viewers
49running on the same computer or via LAN is possible. It allows to
50compare images and spot the differences e.g. schemes of architects to
51show the progress).
52
cd4112e8 53%description -l pl.UTF-8
afd8e3bd 54nomacs to przeglądarka obrazków oparta na bibliotece Qt.
cd4112e8
JB
55
56nomacs jest mała, szybka i potrafi obsłużyć większość popularnych
57formatów obrazów. Ponadto możliwa jest synchronizacja wielu
58przeglądarek działających na tym samym komputerze lub poprzez sieć
59lokalną. Przeglądarka pozwala porównywać obrazki i wskazywać różnice,
60np. projekty architektów w celu pokazania postępów.
61
baec5b45
ER
62%prep
63%setup -q
af2a9792 64cd ImageLounge
afd8e3bd 65%patch0 -p1
723c4b5a 66%patch1 -p1
baec5b45
ER
67
68dos2unix Readme/*
69
723c4b5a 70%{__rm} -r 3rdparty/{libqpsd,quazip-0.7}
baec5b45
ER
71
72%build
73install -d build
74cd build
af2a9792 75%cmake ../ImageLounge \
7ca6d37a 76 -DENABLE_PLUGINS=ON \
baec5b45 77 -DENABLE_RAW=1 \
723c4b5a
JB
78 -DUSE_SYSTEM_LIBQPSD=ON \
79 -DUSE_SYSTEM_QUAZIP=ON \
80 -DUSE_SYSTEM_WEBP=ON
af2a9792 81
baec5b45
ER
82%{__make}
83
84%install
85rm -rf $RPM_BUILD_ROOT
baec5b45
ER
86
87%{__make} -C build install \
88 DESTDIR=$RPM_BUILD_ROOT
89
af2a9792
JB
90# unify
91%{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/nomacs_{zh,zh_CN}.qm
cd4112e8
JB
92# translation to German "Vorarlbergerisch" dialect - should be de_AT@Vorarlberg?
93# ("als" is wrong code - it's Tosk Albanian in iso-639-3)
94%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/nomacs_als.qm
baec5b45 95
af2a9792
JB
96# API not exported, so keep only library files + soname symlinks
97%{__rm} $RPM_BUILD_ROOT%{_libdir}/libnomacs*.so
98
baec5b45
ER
99desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
100
baec5b45
ER
101%find_lang %{name} --with-qm --without-mo
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post
7ca6d37a 107/sbin/ldconfig
baec5b45
ER
108%update_desktop_database
109
110%postun
7ca6d37a 111/sbin/ldconfig
baec5b45
ER
112%update_desktop_database
113
114%files -f %{name}.lang
115%defattr(644,root,root,755)
af2a9792
JB
116%doc ImageLounge/Readme/{COPYRIGHT,LICENSE.OPENCV,README}
117%attr(755,root,root) %{_bindir}/nomacs
118%attr(755,root,root) %{_libdir}/libnomacsCore.so.*.*.*
119%attr(755,root,root) %ghost %{_libdir}/libnomacsCore.so.3
120%attr(755,root,root) %{_libdir}/libnomacsGui.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libnomacsGui.so.3
122%attr(755,root,root) %{_libdir}/libnomacsLoader.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libnomacsLoader.so.3
124%{_mandir}/man1/nomacs.1*
baec5b45
ER
125%dir %{_datadir}/%{name}
126%dir %{_datadir}/%{name}/translations
af2a9792
JB
127%{_datadir}/appdata/nomacs.appdata.xml
128%{_desktopdir}/nomacs.desktop
129%{_pixmapsdir}/nomacs.svg
This page took 0.087934 seconds and 4 git commands to generate.