]> git.pld-linux.org Git - packages/nomacs.git/blame - nomacs.spec
- release 3 (by relup.sh)
[packages/nomacs.git] / nomacs.spec
CommitLineData
cd4112e8
JB
1# TODO: system qpsd (http://sourceforge.net/projects/libqpsd/)
2#
3# Conditional build:
4%bcond_with qt5 # use Qt 5 instead of 4
5#
6%define qt4_ver 4.7.0
baec5b45 7Summary: Lightweight image viewer
cd4112e8 8Summary(pl.UTF-8): Lekka przeglądarka obrazków
baec5b45 9Name: nomacs
cd4112e8 10Version: 2.4.6
83ef27d4 11Release: 3
baec5b45
ER
12License: GPL v3+
13Group: X11/Applications
14Source0: http://downloads.sourceforge.net/nomacs/%{name}-%{version}-source.tar.bz2
cd4112e8 15# Source0-md5: a154966dc5c1fed71279bc70d8078935
8861805b 16Source1: %{name}.appdata.xml
baec5b45 17URL: http://nomacs.org/
cd4112e8 18BuildRequires: cmake >= 2.6
baec5b45
ER
19BuildRequires: desktop-file-utils
20BuildRequires: dos2unix
21BuildRequires: exiv2-devel >= 0.20
22BuildRequires: libraw-devel >= 0.12.0
23BuildRequires: libtiff-devel
24BuildRequires: libwebp-devel >= 0.3.1
25BuildRequires: opencv-devel >= 2.1.0
8861805b 26BuildRequires: pkgconfig
cd4112e8
JB
27%if %{with qt5}
28BuildRequires: Qt5Core-devel >= 5
29BuildRequires: Qt5Gui-devel >= 5
30BuildRequires: Qt5Network-devel >= 5
31BuildRequires: qt5-build >= 5
32BuildRequires: qt5-linguist >= 5
33BuildRequires: qt5-qmake >= 5
34BuildRequires: quazip-qt5-devel >= 0.7
35%else
36BuildRequires: QtCore-devel >= %{qt4_ver}
37BuildRequires: QtGui-devel >= %{qt4_ver}
38BuildRequires: QtNetwork-devel >= %{qt4_ver}
39BuildRequires: qt4-build >= %{qt4_ver}
40BuildRequires: qt4-linguist >= %{qt4_ver}
41BuildRequires: qt4-qmake >= %{qt4_ver}
baec5b45 42BuildRequires: quazip-devel >= 0.7
cd4112e8 43%endif
baec5b45
ER
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
cd4112e8 47nomacs is image viewer based on Qt 4 library.
baec5b45
ER
48
49nomacs is small, fast and able to handle the most common image
50formats. Additionally it is possible to synchronize multiple viewers
51running on the same computer or via LAN is possible. It allows to
52compare images and spot the differences e.g. schemes of architects to
53show the progress).
54
cd4112e8
JB
55%description -l pl.UTF-8
56nomacs to przeglądarka obrazków oparta na bibliotece Qt 4.
57
58nomacs jest mała, szybka i potrafi obsłużyć większość popularnych
59formatów obrazów. Ponadto możliwa jest synchronizacja wielu
60przeglądarek działających na tym samym komputerze lub poprzez sieć
61lokalną. Przeglądarka pozwala porównywać obrazki i wskazywać różnice,
62np. projekty architektów w celu pokazania postępów.
63
baec5b45
ER
64%prep
65%setup -q
66
67dos2unix Readme/*
68
cd4112e8
JB
69%{__rm} -r 3rdparty/libwebp
70%{__rm} -r 3rdparty/quazip-0.7
baec5b45
ER
71
72%build
73install -d build
74cd build
75%cmake \
cd4112e8 76 %{?with_qt5:-DENABLE_QT5} \
baec5b45
ER
77 -DENABLE_RAW=1 \
78 -DUSE_SYSTEM_WEBP=ON \
79 -DUSE_SYSTEM_QUAZIP=ON \
80 ..
cd4112e8 81# -DUSE_SYSTEM_LIBQPSD=ON
baec5b45
ER
82%{__make}
83
84%install
85rm -rf $RPM_BUILD_ROOT
baec5b45
ER
86
87%{__make} -C build install \
88 DESTDIR=$RPM_BUILD_ROOT
89
cd4112e8
JB
90# translation to German "Vorarlbergerisch" dialect - should be de_AT@Vorarlberg?
91# ("als" is wrong code - it's Tosk Albanian in iso-639-3)
92%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/nomacs_als.qm
baec5b45
ER
93
94desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
95
96install -d $RPM_BUILD_ROOT%{_datadir}/appdata
97cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/appdata/%{name}.appdata.xml
98
99%find_lang %{name} --with-qm --without-mo
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post
105%update_desktop_database
106
107%postun
108%update_desktop_database
109
110%files -f %{name}.lang
111%defattr(644,root,root,755)
cd4112e8 112%doc Readme/{COPYRIGHT,LICENSE.OPENCV,README}
baec5b45 113%attr(755,root,root) %{_bindir}/%{name}
cd4112e8 114%{_mandir}/man1/%{name}.1*
baec5b45
ER
115%dir %{_datadir}/%{name}
116%dir %{_datadir}/%{name}/translations
117%{_datadir}/appdata/%{name}.appdata.xml
118%{_desktopdir}/%{name}.desktop
119%{_pixmapsdir}/%{name}.png
This page took 0.09456 seconds and 4 git commands to generate.