]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
up to 16.13.0 auto/th/nodejs-16.13.0-1
authorJan Palus <atler@pld-linux.org>
Sun, 31 Oct 2021 22:27:20 +0000 (23:27 +0100)
committerJan Palus <atler@pld-linux.org>
Sun, 31 Oct 2021 22:27:20 +0000 (23:27 +0100)
- add out/tools/bin to PATH: nodejs creates 'python' symlink there
  pointing to applicable python version. while Makefile has PATH
  customization for newly spawned processes, it does not apply to make
  invocation itself

nodejs.spec

index 43983cdab51e30f784e8bc7b581e740ea0ce13e9..0b388fe02209bc1756bbdabeb9c09b22cb63a157 100644 (file)
@@ -25,12 +25,12 @@ Name:               nodejs
 # Active start: 2020-10-27
 # Maintenance start: October 2020
 # Maintenance end: April 2023
-Version:       16.10.0
+Version:       16.13.0
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 8c5f13de865ad83d4d759414fe12e261
+# Source0-md5: c8571e797b311520ec19ece7c7c64247
 Patch0:                system_cares.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
@@ -158,7 +158,7 @@ Sondy systemtap/dtrace dla Node.js.
 %patch4 -p1
 %patch5 -p1
 
-grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python3},'
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
 
 %{?with_system_brotli:%{__rm} -r deps/brotli}
 %{__rm} -r deps/cares
@@ -201,6 +201,7 @@ GYP_DEFINES="soname_version=%{sover}" \
 # CXXFLAGS must be exported, as it is needed for make, not gyp
 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
 LDFLAGS="%{rpmldflags}" \
+PATH="$(pwd)/out/tools/bin:$PATH" \
 %{__make} -C out \
        BUILDTYPE=Release \
        V=1
This page took 0.134289 seconds and 4 git commands to generate.