]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
- create .py[co]; fix shebangs auto/th/nodejs-0_6_8-3
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 26 Jan 2012 15:52:36 +0000 (15:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nodejs.spec -> 1.30

nodejs.spec

index c1fab215444e0eea763961668a6b9aa8f7c95f4f..84ef263c195aae0f4633c76d33bbe8fd11869729 100644 (file)
@@ -13,6 +13,7 @@ Patch2:               %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
 BuildRequires: c-ares-devel >= 1.7.4
+BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: gcc >= 5:4.0
 BuildRequires: libeio-devel
 BuildRequires: libev-devel >= 4.0.0
@@ -75,9 +76,10 @@ used by Node.js and many of its modules.
 %patch2 -p1
 %endif
 
+# fix #!/usr/bin/env python -> #!/usr/bin/python:
+grep -rl 'bin/env python' tools | xargs %{__sed} -i -e '1s,^#!.*python,#!%{__python},'
+
 %build
-%undefine      with_ccache
-# build library
 CFLAGS="%{rpmcflags} -fPIC"
 CXXFLAGS="%{rpmcxxflags} -fPIC"
 LDFLAGS="%{rpmcflags}"
@@ -100,6 +102,7 @@ export PYTHONPATH=tools
        --libdir=%{_libdir} \
        --prefix=%{_prefix}
 
+# build library
 %{__make} dynamiclib
 %{__make} program
 
@@ -142,6 +145,11 @@ Version: ${version}
 Cflags: -I${includedir}
 EOF
 
+%py_ocomp $RPM_BUILD_ROOT%{_libdir}/node/wafadmin
+%py_comp $RPM_BUILD_ROOT%{_libdir}/node/wafadmin
+# TODO: check it first
+#%%py_postclean %{_libdir}/node/wafadmin
+
 # install documentation
 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
 cp -a doc/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
@@ -185,5 +193,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/node-waf
 %dir %{_libdir}/node/wafadmin
 %dir %{_libdir}/node/wafadmin/Tools
+%{_libdir}/node/wafadmin/*.py[co]
 %{_libdir}/node/wafadmin/*.py
 %{_libdir}/node/wafadmin/Tools/*.py
+%{_libdir}/node/wafadmin/Tools/*.py[co]
This page took 0.161223 seconds and 4 git commands to generate.