up to 14.16.0 (fixes CVE-2021-22883 CVE-2021-22884) auto/th/nodejs-14.16.0-1
authorJan Palus <atler@pld-linux.org>
Tue, 2 Mar 2021 19:01:22 +0000 (20:01 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 2 Mar 2021 19:01:22 +0000 (20:01 +0100)
0001-Disable-running-gyp-on-shared-deps.patch
0002-Install-both-binaries-and-use-libdir.patch
nodejs.spec

index 9372be66b332b18a2e0c969c4848153ec70af50a..ea84738d22246a48fa5040c07bc40bc0a4edfd02 100644 (file)
@@ -12,7 +12,7 @@ index 0947300f24028d00bcfb79b38d96bded136228e3..5d4f88a705053fbdd6b56ec85e999767
 --- a/Makefile
 +++ b/Makefile
 @@ -141,9 +141,9 @@ test-code-cache: with-code-cache
-       echo "'test-code-cache' target is a noop"
+       $(warning '$@' target is a noop)
  
  out/Makefile: config.gypi common.gypi node.gyp \
 -      deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
@@ -30,8 +30,8 @@ index 0947300f24028d00bcfb79b38d96bded136228e3..5d4f88a705053fbdd6b56ec85e999767
 --- node-v12.16.1/deps/uvwasi/uvwasi.gyp.orig  2020-02-18 06:08:33.000000000 +0100
 +++ node-v12.16.1/deps/uvwasi/uvwasi.gyp       2020-03-21 17:51:55.372551818 +0100
 @@ -14,9 +14,6 @@
-         'src/uv_mapping.c',
-         'src/uvwasi.c',
+         'src/wasi_rights.c',
+         'src/wasi_serdes.c',
        ],
 -      'dependencies': [
 -        '../uv/uv.gyp:libuv',
index d5d690acebf6af3cb8fd3e1a62f13f2232873ad0..eb589ea04a40e60111e610e62f990b198f975c3f 100644 (file)
@@ -30,13 +30,13 @@ index 20cce214dbb113aeef8f1044d7af88d842a11fd7..e2d78a2a51ef81621618cb20fa76f4a1
      action='store_true',
      dest='without_v8_platform',
 @@ -1103,6 +1109,7 @@ def configure_node(o):
-   if o['variables']['want_separate_host_toolset'] == 0:
-     o['variables']['node_code_cache'] = 'yes' # For testing
+   o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
    o['variables']['node_shared'] = b(options.shared)
 +  o['variables']['libdir'] = options.libdir
    node_module_version = getmoduleversion.get_version()
  
-   if sys.platform == 'darwin':
+   if options.dest_os == 'android':
 diff --git a/tools/install.py b/tools/install.py
 index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c049b0503 100755
 --- a/tools/install.py
index 148d55cd07024c65938e09dee4db7725276da586..df8a49a01bb2d3ffe6f2cb049b6631ccf42cd5a1 100644 (file)
@@ -25,12 +25,12 @@ Name:               nodejs
 # Active start: 2020-10-27
 # Maintenance start: October 2020
 # Maintenance end: April 2023
-Version:       14.15.5
+Version:       14.16.0
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 12c059975256114cbe983292c20ae26a
+# Source0-md5: 7dc3666f407bf4e12a01ce1be2883d31
 
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
This page took 0.214075 seconds and 4 git commands to generate.