up to 16.10.0 auto/th/nodejs-16.10.0-1
authorJan Palus <atler@pld-linux.org>
Tue, 5 Oct 2021 11:48:07 +0000 (13:48 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 5 Oct 2021 11:48:07 +0000 (13:48 +0200)
nodejs v16 becomes LTS on 2021-10-26 but push it ahead of time as it
ships fixes for openssl 3.0

0001-Disable-running-gyp-on-shared-deps.patch
0002-Install-both-binaries-and-use-libdir.patch
nodejs-lib64path.patch
nodejs-libpath.patch
nodejs.spec

index ea84738d22246a48fa5040c07bc40bc0a4edfd02..9798dc13ea97680127bc88361060be45b46bd3a4 100644 (file)
@@ -27,15 +27,3 @@ index 0947300f24028d00bcfb79b38d96bded136228e3..5d4f88a705053fbdd6b56ec85e999767
 -- 
 2.23.0
 
---- node-v12.16.1/deps/uvwasi/uvwasi.gyp.orig  2020-02-18 06:08:33.000000000 +0100
-+++ node-v12.16.1/deps/uvwasi/uvwasi.gyp       2020-03-21 17:51:55.372551818 +0100
-@@ -14,9 +14,6 @@
-         'src/wasi_rights.c',
-         'src/wasi_serdes.c',
-       ],
--      'dependencies': [
--        '../uv/uv.gyp:libuv',
--      ],
-       'direct_dependent_settings': {
-         'include_dirs': ['include']
-       },
index eb589ea04a40e60111e610e62f990b198f975c3f..4ce85c2c2f24997c7a26b4cbca4feed189c98c24 100644 (file)
@@ -20,13 +20,13 @@ index 20cce214dbb113aeef8f1044d7af88d842a11fd7..e2d78a2a51ef81621618cb20fa76f4a1
      help='compile shared library for embedding node in another project. ' +
           '(This mode is not officially supported for regular applications)')
  
-+parser.add_option('--libdir',
++parser.add_argument('--libdir',
 +    action='store',
 +    dest='libdir',
 +    default='lib',
 +    help='a directory to install the shared library into')
 +
- parser.add_option('--without-v8-platform',
+ parser.add_argument('--without-v8-platform',
      action='store_true',
      dest='without_v8_platform',
 @@ -1103,6 +1109,7 @@ def configure_node(o):
index 1b348a4e0f77c0f1cb3c6a9a8d60154f154e9bf1..b591933022f7da945f14f0b47347f15dfab4a6e7 100644 (file)
@@ -4,8 +4,8 @@
      path.resolve(process.execPath, '..') :
      path.resolve(process.execPath, '..', '..');
  
--  let paths = [path.resolve(prefixDir, 'lib', 'node')];
-+  let paths = ["/usr/lib64/node", "/usr/lib/node", "/usr/lib/node_modules", path.resolve(prefixDir, 'lib', 'node')];
+-  const paths = [path.resolve(prefixDir, 'lib', 'node')];
++  const paths = ["/usr/lib64/node", "/usr/lib/node", "/usr/lib/node_modules", path.resolve(prefixDir, 'lib', 'node')];
  
    if (homeDir) {
      ArrayPrototypeUnshift(paths, path.resolve(homeDir, '.node_libraries'));
index 272c6e3af8d527f2b40ca0e9764319d0f495e999..4025b9e08e5924ad62af5ecfcbed29238fd8e4d1 100644 (file)
@@ -4,8 +4,8 @@
      path.resolve(process.execPath, '..') :
      path.resolve(process.execPath, '..', '..');
  
--  let paths = [path.resolve(prefixDir, 'lib', 'node')];
-+  let paths = ["/usr/lib/node", "/usr/lib/node_modules", path.resolve(prefixDir, 'lib', 'node')];
+-  const paths = [path.resolve(prefixDir, 'lib', 'node')];
++  const paths = ["/usr/lib/node", "/usr/lib/node_modules", path.resolve(prefixDir, 'lib', 'node')];
  
    if (homeDir) {
      ArrayPrototypeUnshift(paths, path.resolve(homeDir, '.node_libraries'));
index 4bc4bc38a3e7e9b301cc6bf64bd81cb5bd5f0996..43983cdab51e30f784e8bc7b581e740ea0ce13e9 100644 (file)
@@ -17,7 +17,7 @@
 # add-on binaries can be loaded in to without needing to be re-compiled. It
 # used to be stored as hex value in earlier versions, but is now represented as
 # an integer.
-%define                node_module_version     83
+%define                node_module_version     93
 Summary:       Asynchronous JavaScript Engine
 Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
@@ -25,12 +25,12 @@ Name:               nodejs
 # Active start: 2020-10-27
 # Maintenance start: October 2020
 # Maintenance end: April 2023
-Version:       14.17.5
+Version:       16.10.0
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 1e42a4be9a1983f60d97038435b010ce
+# Source0-md5: 8c5f13de865ad83d4d759414fe12e261
 Patch0:                system_cares.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
@@ -49,14 +49,14 @@ BuildRequires:      llhttp-devel >= 2.1.3
 BuildRequires: libatomic-devel
 %endif
 %{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.9}
-BuildRequires: libicu-devel >= 67
+BuildRequires: libicu-devel >= 69.1
 BuildRequires: libstdc++-devel >= 6:4.8
-%{?with_system_uv:BuildRequires:       libuv-devel >= 1.41.0}
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.42.0}
 BuildRequires: nghttp2-devel >= 1.42.0
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
-BuildRequires: python3
-BuildRequires: python3-modules
+BuildRequires: python3 >= 1:3.6
+BuildRequires: python3-modules >= 1:3.6
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: sed >= 4.0
@@ -65,7 +65,7 @@ Requires:     c-ares >= 1.17.1
 Requires:      ca-certificates
 %{?with_http_parser:Requires:  http-parser >= 2.9.3}
 %{?with_system_brotli:Requires:        libbrotli >= 1.0.9}
-%{?with_system_uv:Requires:    libuv >= 1.41.0}
+%{?with_system_uv:Requires:    libuv >= 1.42.0}
 Requires:      nghttp2-libs >= 1.42.0
 Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
@@ -102,7 +102,7 @@ Requires:   %{name} = %{version}-%{release}
 Requires:      gcc
 %{?with_http_parser:Requires:  http-parser-devel >= 2.9.3}
 Requires:      libstdc++-devel
-%{?with_system_uv:Requires:    libuv-devel >= 1.41.0}
+%{?with_system_uv:Requires:    libuv-devel >= 1.42.0}
 Requires:      openssl-devel
 Requires:      zlib-devel >= 1.2.11
 
This page took 0.108465 seconds and 4 git commands to generate.