]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
add system_v8 bcond
authorElan Ruusamäe <glen@delfi.ee>
Sat, 17 Oct 2015 14:02:00 +0000 (17:02 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 17 Oct 2015 14:02:00 +0000 (17:02 +0300)
nodejs.spec

index 6f4b4ed3137b0e57b56117a8ff87e72fb44d3696..38276a059067a04b1b94140cd111e3b7b41c3764 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_without system_v8       # system v8
+
 # NOTES:
 # - https://nodejs.org/en/download/releases/
 
@@ -35,7 +39,7 @@ BuildRequires:        python-jsmin
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
-BuildRequires: v8-devel >= 3.15.11.10
+%{?with_system_v8:BuildRequires:       v8-devel >= 3.15.11.10}
 BuildRequires: zlib-devel
 Requires:      ca-certificates
 Obsoletes:     nodejs-waf
@@ -61,7 +65,7 @@ Requires:     http-parser-devel
 Requires:      libstdc++-devel
 Requires:      libuv-devel
 Requires:      openssl-devel
-Requires:      v8-devel
+%{?with_system_v8:Requires:    v8-devel}
 Requires:      zlib-devel
 
 %description devel
@@ -93,7 +97,13 @@ This package contains the documentation for nodejs.
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-rm -r deps
+rm -r deps/npm
+rm -r deps/cares
+rm -r deps/http_parser
+rm -r deps/openssl
+rm -r deps/uv
+%{?with_system_v8:rm -r deps/v8}
+rm -r deps/zlib
 
 %build
 # CC used only to detect if CC is clang, not used for compiling
@@ -101,7 +111,7 @@ CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-v8 \
+       %{?with_system_v8:--shared-v8} \
        --shared-zlib \
        --shared-openssl \
        --shared-cares \
This page took 0.077823 seconds and 4 git commands to generate.