]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
v0.10.0
authorAria <aredridel@nbtsc.org>
Tue, 12 Mar 2013 01:02:30 +0000 (19:02 -0600)
committerAria <aredridel@nbtsc.org>
Tue, 12 Mar 2013 01:03:44 +0000 (19:03 -0600)
nodejs-shared.patch
nodejs-soname.patch
nodejs.spec

index de46587c2e53624b6772dcd992a0455de3001afd..4201e86462c355489905737a29d4043f581fa112 100644 (file)
@@ -55,8 +55,8 @@ diff -ur node-v0.9.9-o/node.gyp node-v0.9.9/node.gyp
 +    {
 +      'target_name': 'libnode',
 +      'type': 'shared_library',
-+      'product_extension': 'so.9.0.0',
-+      'soname_version': '9.0.0',
++      'product_extension': 'so.10.0.0',
++      'soname_version': '10.0.0',
 +      'cflags': ['-fPIC'],
 +
 +      'sources': [
@@ -585,7 +585,7 @@ diff -ur node-v0.9.9-o/tools/install.py node-v0.9.9/tools/install.py
 +  global lib_dir
    action(['doc/node.1'], 'share/man/man1/')
    action(['out/Release/node'], 'bin/node')
-+  action(['out/Release/lib.target/libnode.so.9.0.0'], lib_dir + '/libnode.so.9.0.0')
++  action(['out/Release/lib.target/libnode.so.10.0.0'], lib_dir + '/libnode.so.10.0.0')
  
    # install unconditionally, checking if the platform supports dtrace doesn't
    # work when cross-compiling and besides, there's at least one linux flavor
index bc4717de1a12aa8e4aafc76ee7560b1eb2d64a70..812c7debabc5c5c30d6a35554c9c49471e102701 100644 (file)
@@ -4,7 +4,7 @@
    node.add_objects = 'eio http_parser'
    if product_type_is_lib:
      node.install_path = '${LIBDIR}'
-+    node.vnum = "6.0.0" # Fixme, derive from version
++    node.vnum = "10.0.0" # Fixme, derive from version
    else:
      node.install_path = '${PREFIX}/bin'
    node.chmod = 0755
index 1fc8929b1ea66130f683cf4981d7a93d66cde534..aace049160788c9a7a5a092a99d908d5749bab7a 100644 (file)
@@ -1,13 +1,13 @@
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.9.12
+Version:       0.10.0
 Release:       1
 License:       BSD and MIT and ASL 2.0 and GPLv3
 Group:         Development/Languages
 URL:           http://www.nodejs.org/
 Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 0521950111ba1b2165b125b0832ffef8
-Patch1:                %{name}-shared.patch
+# Source0-md5: 23df2c1aeb9dcf17284047f2530b0525
+Patch1:     %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
@@ -104,8 +104,8 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT \
     LIBDIR=%{_lib}
 
-ln -s libnode.so.9.0.0 $RPM_BUILD_ROOT%{_libdir}/libnode.so.9
-ln -s libnode.so.9.0.0 $RPM_BUILD_ROOT%{_libdir}/libnode.so
+ln -s libnode.so.10.0.0 $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
+ln -s libnode.so.10.0.0 $RPM_BUILD_ROOT%{_libdir}/libnode.so
 
 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
 
@@ -153,7 +153,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.9
+%ghost %{_libdir}/libnode.so.10
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
 %endif
This page took 0.032392 seconds and 4 git commands to generate.