]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
drop more internal deps
[packages/nodejs.git] / nodejs.spec
index b68ab05a7ae35776218286f90760e4e045c1fda9..dc7c863d123e3700f14720c16241648d066cad1a 100644 (file)
@@ -3,8 +3,9 @@
 #   /usr/share/doc/node/gdbinit
 
 # Conditional build:
+%bcond_without system_brotli   # system brotli
 %bcond_without system_uv       # system uv
-%bcond_with    httpparse       # use system http-parser and llhttp
+%bcond_with    http_parser     # system http-parser and llhttp
 
 # NOTES:
 # - https://nodejs.org/en/download/releases/
@@ -22,12 +23,12 @@ Name:               nodejs
 # Active start: 2019-10-21
 # Maintenance start: October 2020
 # Maintenance end: April 2022
-Version:       12.14.1
+Version:       12.18.3
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 7f2fa2f5df2b8179b5b00ec7de361b34
+# Source0-md5: 28bf6a4d98b238403fa58a0805f4a979
 
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
@@ -36,16 +37,17 @@ Patch3:             %{name}-lib64path.patch
 Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
 Patch5:                0002-Install-both-binaries-and-use-libdir.patch
 URL:           https://nodejs.org/
-BuildRequires: c-ares-devel >= 1.14.0
+BuildRequires: c-ares-devel >= 1.16.0
 BuildRequires: gcc >= 6:4.8
-%if %{with httpparse}
-BuildRequires: http-parser-devel >= 2.9.2
-BuildRequires: llhttp-devel
+%if %{with http_parser}
+BuildRequires: http-parser-devel >= 2.9.3
+BuildRequires: llhttp-devel >= 2.0.4
 %endif
+%{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.7}
 BuildRequires: libicu-devel >= 0.64
 BuildRequires: libstdc++-devel >= 6:4.8
-%{?with_system_uv:BuildRequires:       libuv-devel >= 1.29.0}
-BuildRequires: nghttp2-devel >= 1.39.1
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.38.0}
+BuildRequires: nghttp2-devel >= 1.41.0
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.7
@@ -54,12 +56,18 @@ BuildRequires:      python-modules >= 1:2.7
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
-BuildRequires: zlib-devel
+BuildRequires: zlib-devel >= 1.2.11
+Requires:      c-ares >= 1.16.0
 Requires:      ca-certificates
+%{?with_http_parser:Requires:  http-parser >= 2.9.3}
+%{?with_system_brotli:Requires:        libbrotli >= 1.0.7}
+%{?with_system_uv:Requires:    libuv >= 1.38.0}
+Requires:      nghttp2-libs >= 1.41.0
+Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
 Provides:      nodejs(module-version) = %{node_module_version}
 Obsoletes:     nodejs-waf
-ExclusiveArch: %{ix86} %{x8664} arm
+ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                sover   %(echo %{version} | cut -d. -f2)
@@ -88,11 +96,11 @@ Summary(pl.UTF-8):  Pliki nagłówkowe nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gcc
-%{?with_http_parse:Requires:   http-parser-devel >= 2.9.2}
+%{?with_http_parser:Requires:  http-parser-devel >= 2.9.3}
 Requires:      libstdc++-devel
-%{?with_system_uv:Requires:    libuv-devel >= 1.29.0}
+%{?with_system_uv:Requires:    libuv-devel >= 1.38.0}
 Requires:      openssl-devel
-Requires:      zlib-devel
+Requires:      zlib-devel >= 1.2.11
 
 %description devel
 Development headers for nodejs.
@@ -105,7 +113,7 @@ Summary:    Documentation for Node.js engine
 Summary(pl.UTF-8):     Dokumentacja silnika Node.js
 Group:         Documentation
 URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
-%if "%{_rpmversion}" >= "5"
+%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
 %endif
 
@@ -139,7 +147,6 @@ Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
-#%patch1 -p1
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
@@ -150,8 +157,15 @@ Sondy systemtap/dtrace dla Node.js.
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
+%{?with_system_brotli:%{__rm} -r deps/brotli}
+%{__rm} -r deps/cares
+%if %{with http_parser}
+%{__rm} -r deps/http_parser
+%{__rm} -r deps/llhttp
+%endif
+%{__rm} -r deps/icu-small
+%{__rm} -r deps/nghttp2
 %{__rm} -r deps/npm
-%{?with_httpparse:%{__rm} -r deps/http_parser}
 %{__rm} -r deps/openssl
 %{?with_system_uv:%{__rm} -r deps/uv}
 %{__rm} -r deps/zlib
@@ -165,19 +179,20 @@ CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
+       --prefix=%{_prefix} \
+       --libdir=%{_lib} \
        --openssl-use-def-ca-store \
        --shared \
+       %{?with_system_brotli:--shared-brotli} \
        --shared-cares \
-       --shared-openssl \
-       %{?with_http_parse:--shared-http-parser} \
-       --shared-nghttp2 \
-       --with-intl=system-icu \
+       %{?with_http_parser:--shared-http-parser} \
        %{?with_system_uv:--shared-libuv} \
+       --shared-nghttp2 \
+       --shared-openssl \
        --shared-zlib \
-       --without-npm \
+       --with-intl=system-icu \
        --without-dtrace \
-       --libdir=%{_lib} \
-       --prefix=%{_prefix}
+       --without-npm
 
 # add LFS defines from libuv (RHBZ#892601)
 # CXXFLAGS must be exported, as it is needed for make, not gyp
@@ -241,7 +256,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS CHANGELOG.md LICENSE
+%doc AUTHORS CHANGELOG.md LICENSE README.md SECURITY.md
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
 %attr(755,root,root) %{_libdir}/libnode.so.%{node_module_version}
This page took 0.038942 seconds and 4 git commands to generate.