]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
fix brotli BR
[packages/nodejs.git] / nodejs.spec
index bd3b78f3623c342b0ec7449c4f33282d132e1104..ab9c907e3a6cc34f9808273299184c65b99a2c6d 100644 (file)
@@ -3,8 +3,9 @@
 #   /usr/share/doc/node/gdbinit
 
 # Conditional build:
+%bcond_without system_brotli   # system brotli
 %bcond_without system_uv       # system uv
-%bcond_with    http_parser     # use system http-parser and llhttp
+%bcond_with    http_parser     # system http-parser and llhttp
 
 # NOTES:
 # - https://nodejs.org/en/download/releases/
@@ -22,12 +23,12 @@ Name:               nodejs
 # Active start: 2019-10-21
 # Maintenance start: October 2020
 # Maintenance end: April 2022
-Version:       12.18.2
+Version:       12.18.3
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 9ad002a872543c606fad10370afda87c
+# Source0-md5: 28bf6a4d98b238403fa58a0805f4a979
 
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
@@ -36,15 +37,16 @@ Patch3:             %{name}-lib64path.patch
 Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
 Patch5:                0002-Install-both-binaries-and-use-libdir.patch
 URL:           https://nodejs.org/
-BuildRequires: c-ares-devel >= 1.14.0
+BuildRequires: c-ares-devel >= 1.16.0
 BuildRequires: gcc >= 6:4.8
 %if %{with http_parser}
 BuildRequires: http-parser-devel >= 2.9.3
-BuildRequires: llhttp-devel >= 2.0.1
+BuildRequires: llhttp-devel >= 2.0.4
 %endif
+%{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.7}
 BuildRequires: libicu-devel >= 0.64
 BuildRequires: libstdc++-devel >= 6:4.8
-%{?with_system_uv:BuildRequires:       libuv-devel >= 1.34.0}
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.38.0}
 BuildRequires: nghttp2-devel >= 1.41.0
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
@@ -54,11 +56,14 @@ BuildRequires:      python-modules >= 1:2.7
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
-BuildRequires: zlib-devel
+BuildRequires: zlib-devel >= 1.2.11
+Requires:      c-ares >= 1.16.0
+Requires:      ca-certificates
 %{?with_http_parser:Requires:  http-parser >= 2.9.3}
-%{?with_system_uv:Requires:    libuv >= 1.34.0}
+%{?with_system_brotli:Requires:        libbrotli >= 1.0.7}
+%{?with_system_uv:Requires:    libuv >= 1.38.0}
 Requires:      nghttp2-libs >= 1.41.0
-Requires:      ca-certificates
+Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
 Provides:      nodejs(module-version) = %{node_module_version}
 Obsoletes:     nodejs-waf
@@ -93,9 +98,9 @@ Requires:     %{name} = %{version}-%{release}
 Requires:      gcc
 %{?with_http_parser:Requires:  http-parser-devel >= 2.9.3}
 Requires:      libstdc++-devel
-%{?with_system_uv:Requires:    libuv-devel >= 1.34.0}
+%{?with_system_uv:Requires:    libuv-devel >= 1.38.0}
 Requires:      openssl-devel
-Requires:      zlib-devel
+Requires:      zlib-devel >= 1.2.11
 
 %description devel
 Development headers for nodejs.
@@ -142,7 +147,6 @@ Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
-#%patch1 -p1
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
@@ -172,6 +176,7 @@ GYP_DEFINES="soname_version=%{sover}" \
        --libdir=%{_lib} \
        --openssl-use-def-ca-store \
        --shared \
+       %{?with_system_brotli:--shared-brotli} \
        --shared-cares \
        %{?with_http_parser:--shared-http-parser} \
        %{?with_system_uv:--shared-libuv} \
This page took 0.042946 seconds and 4 git commands to generate.