]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
fix brotli BR
[packages/nodejs.git] / nodejs.spec
index 53f2a899a8de1f776bdbd985ee72ca0eead6e07b..ab9c907e3a6cc34f9808273299184c65b99a2c6d 100644 (file)
@@ -1,30 +1,79 @@
+# TODO
+# - unpackaged files
+#   /usr/share/doc/node/gdbinit
+
+# Conditional build:
+%bcond_without system_brotli   # system brotli
+%bcond_without system_uv       # system uv
+%bcond_with    http_parser     # system http-parser and llhttp
+
+# NOTES:
+# - https://nodejs.org/en/download/releases/
+
+# NODE_MODULE_VERSION refers to the ABI (application binary interface) version
+# number of Node.js, used to determine which versions of Node.js compiled C++
+# add-on binaries can be loaded in to without needing to be re-compiled. It
+# used to be stored as hex value in earlier versions, but is now represented as
+# an integer.
+%define                node_module_version     72
 Summary:       Asynchronous JavaScript Engine
+Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
-Version:       0.6.15
+# 12.x LTS - https://github.com/nodejs/Release
+# Active start: 2019-10-21
+# Maintenance start: October 2020
+# Maintenance end: April 2022
+Version:       12.18.3
 Release:       1
-License:       BSD and MIT and ASL 2.0 and GPLv3
+License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-URL:           http://www.nodejs.org/
-Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 852cfb1ed8125a4cdba456446d869d19
-Patch1:                %{name}-soname.patch
+Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
+# Source0-md5: 28bf6a4d98b238403fa58a0805f4a979
+
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
-BuildRequires: c-ares-devel >= 1.7.4
-BuildRequires: gcc >= 5:4.0
-BuildRequires: libeio-devel
-BuildRequires: libev-devel >= 4.0.0
-BuildRequires: libstdc++-devel
-BuildRequires: python >= 1:2.5.2
+Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
+Patch5:                0002-Install-both-binaries-and-use-libdir.patch
+URL:           https://nodejs.org/
+BuildRequires: c-ares-devel >= 1.16.0
+BuildRequires: gcc >= 6:4.8
+%if %{with http_parser}
+BuildRequires: http-parser-devel >= 2.9.3
+BuildRequires: llhttp-devel >= 2.0.4
+%endif
+%{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.7}
+BuildRequires: libicu-devel >= 0.64
+BuildRequires: libstdc++-devel >= 6:4.8
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.38.0}
+BuildRequires: nghttp2-devel >= 1.41.0
+BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: pkgconfig
+BuildRequires: python >= 1:2.7
 BuildRequires: python-jsmin
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
-BuildRequires: v8-devel >= 3.6
-ExclusiveArch: %{ix86} %{x8664} arm
+BuildRequires: sed >= 4.0
+BuildRequires: zlib-devel >= 1.2.11
+Requires:      c-ares >= 1.16.0
+Requires:      ca-certificates
+%{?with_http_parser:Requires:  http-parser >= 2.9.3}
+%{?with_system_brotli:Requires:        libbrotli >= 1.0.7}
+%{?with_system_uv:Requires:    libuv >= 1.38.0}
+Requires:      nghttp2-libs >= 1.41.0
+Requires:      zlib >= 1.2.11
+Provides:      nodejs(engine) = %{version}
+Provides:      nodejs(module-version) = %{node_module_version}
+Obsoletes:     nodejs-waf
+ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                sover   %(echo %{version} | cut -d. -f2)
+# add macro, so adapter won't replace it back literal
+%define                doc_ver %{version}
+
 %description
 Node.js is a platform built on Chrome's JavaScript runtime for easily
 building fast, scalable network applications. Node.js uses an
@@ -32,91 +81,136 @@ event-driven, non-blocking I/O model that makes it lightweight and
 efficient, perfect for data-intensive real-time applications that run
 across distributed devices.
 
+%description -l pl.UTF-8
+Node.js to platforma zbudowana w opacriu o silnik JavaScriptu
+przeglądarki Chrome, służąca do tworzenia szybkich, skalowalnych
+aplikacji sieciowych. Node.js wykorzystuje nieblokujący model
+wejścia/wyjścia sterowany zdarzeniami, dzięki czemu jest lekki i
+wydajny, dobrze nadający się do aplikacji przetwarzających duże
+ilości danych w czasie rzeczywistym, uruchamianych na rozproszonych
+urządzeniach.
+
 %package devel
 Summary:       Development headers for nodejs
+Summary(pl.UTF-8):     Pliki nagłówkowe nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      %{name}-waf = %{version}-%{release}
 Requires:      gcc
+%{?with_http_parser:Requires:  http-parser-devel >= 2.9.3}
 Requires:      libstdc++-devel
-Requires:      v8-devel
+%{?with_system_uv:Requires:    libuv-devel >= 1.38.0}
+Requires:      openssl-devel
+Requires:      zlib-devel >= 1.2.11
 
 %description devel
 Development headers for nodejs.
 
+%description devel -l pl.UTF-8
+Pliki nagłówkowe nodejs.
+
 %package doc
-Summary:       Evented I/O for V8 JavaScript - documentation
+Summary:       Documentation for Node.js engine
+Summary(pl.UTF-8):     Dokumentacja silnika Node.js
 Group:         Documentation
+URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
+%if "%{_rpmversion}" >= "4.6"
+BuildArch:     noarch
+%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
 asynchronous event-driven model. Node's goal is to provide an easy way
 to build scalable network programs.
 
-This package contains the documentation for nodejs.
+This package contains the documentation for Node.js.
+
+%description doc -l pl.UTF-8
+Node.js to serwerowe środowisko JavaScriptu wykorzystujące
+asynchroniczny model sterowany zdarzeniami. Celem Node jest
+zapewnienie łatwego sposobu tworzenia skalowalnych programów
+sieciowych.
 
-%package waf
-Summary:       Evented I/O for V8 JavaScript - customized WAF build system
-Group:         Libraries
+Ten pakiet zawiera dokumentację Node.js.
+
+%package -n systemtap-nodejs
+Summary:       systemtap/dtrace probes for Node.js
+Summary(pl.UTF-8):     Sondy systemtap/dtrace dla Node.js
+Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
+Requires:      systemtap-client
 
-%description waf
-Node.js is a server-side JavaScript environment that uses an
-asynchronous event-driven model. Node's goal is to provide an easy way
-to build scalable network programs.
+%description -n systemtap-nodejs
+systemtap/dtrace probes for Node.js.
 
-This package contains the customized version of the WAF build system
-used by Node.js and many of its modules.
+%description -n systemtap-nodejs -l pl.UTF-8
+Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
-%patch1 -p1
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
+%patch4 -p1
+%patch5 -p1
 
-# fix #!/usr/bin/env python -> #!/usr/bin/python:
-grep -rl 'bin/env python' tools | xargs %{__sed} -i -e '1s,^#!.*python,#!%{__python},'
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-%build
-CFLAGS="%{rpmcflags} -fPIC"
-CXXFLAGS="%{rpmcxxflags} -fPIC"
-LDFLAGS="%{rpmcflags}"
-%if "%{pld_release}" == "ac"
-CC="%{__cc}4"
-CXX="%{__cxx}4"
-%else
-CC="%{__cc}"
-CXX="%{__cxx}"
-%endif
-export CFLAGS LDFLAGS CXXFLAGS CC CXX
+%{__rm} -r deps/npm
+%{?with_http_parser:%{__rm} -r deps/http_parser}
+%{__rm} -r deps/openssl
+%{?with_system_uv:%{__rm} -r deps/uv}
+%{__rm} -r deps/zlib
 
-# Error: V8 doesn't like ccache. Please set your CC env var to 'gcc'
-CC=${CC#ccache }
+%build
+ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
+test "$ver" = "%{node_module_version}"
 
-# NOT autoconf so dont use macro
-export PYTHONPATH=tools
+# CC used only to detect if CC is clang, not used for compiling
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
+       --prefix=%{_prefix} \
+       --libdir=%{_lib} \
+       --openssl-use-def-ca-store \
+       --shared \
+       %{?with_system_brotli:--shared-brotli} \
        --shared-cares \
-       --shared-v8 \
+       %{?with_http_parser:--shared-http-parser} \
+       %{?with_system_uv:--shared-libuv} \
+       --shared-nghttp2 \
+       --shared-openssl \
        --shared-zlib \
-       --without-npm \
-       --libdir=%{_libdir} \
-       --prefix=%{_prefix}
-
-# build library
-%{__make} dynamiclib
-%{__make} program
-
-# relink with shared lib
-$CC -o out/Release/node src/node_main.cc -Isrc -Ideps/uv/include -lnode -Lout/Release
+       --with-intl=system-icu \
+       --without-dtrace \
+       --without-npm
+
+# add LFS defines from libuv (RHBZ#892601)
+# CXXFLAGS must be exported, as it is needed for make, not gyp
+CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
+LDFLAGS="%{rpmldflags}" \
+%{__make} -C out \
+       BUILDTYPE=Release \
+       V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+
+%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
+
+ln -s libnode.so.%{node_module_version} $RPM_BUILD_ROOT%{_libdir}/libnode.so
+
+echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
+
+install -d $RPM_BUILD_ROOT%{_includedir}/node
+cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
+
+# install for node-gyp
+install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
 
 # for compat of fedora derivered scripts (shebangs)
 ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
@@ -127,14 +221,6 @@ install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
 # default searchpaths
 install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
 
-# install shared lib
-export PYTHONPATH=tools
-%{__python} tools/waf-light install \
-       --product-type=cshlib \
-       --destdir=$RPM_BUILD_ROOT
-
-chmod a+x $RPM_BUILD_ROOT%{_libdir}/*.so*
-
 # create pkgconfig
 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
@@ -149,55 +235,43 @@ Version: ${version}
 Cflags: -I${includedir}
 EOF
 
-%py_ocomp $RPM_BUILD_ROOT%{_libdir}/node/wafadmin
-%py_comp $RPM_BUILD_ROOT%{_libdir}/node/wafadmin
-# TODO: check it first
-#%%py_postclean %{_libdir}/node/wafadmin
-
 # install documentation
-install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
-cp -a doc/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
-cd $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
-install -d api
-mv html/api/*.markdown api
-mv html/api/api/* html/api
-rm -rf html/api/api
-cd -
+install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
+cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS ChangeLog LICENSE
+%doc AUTHORS CHANGELOG.md LICENSE README.md SECURITY.md
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
-%attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.6
+%attr(755,root,root) %{_libdir}/libnode.so.%{node_module_version}
+%if "%{_lib}" != "lib"
 %dir %{_libdir}/node
+%endif
 %dir %{_prefix}/lib/node
 %dir %{_prefix}/lib/node_modules
 %{_mandir}/man1/node.1*
+%{_mandir}/man1/nodejs.1*
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/libnode.so
+%attr(755,root,root) %{_libdir}/libnode.so
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
+%{_usrsrc}/%{name}
 
 %files doc
 %defattr(644,root,root,755)
 %doc %{_docdir}/%{name}-doc-%{version}
 
-%files waf
+%files -n systemtap-nodejs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/node-waf
-%dir %{_libdir}/node/wafadmin
-%dir %{_libdir}/node/wafadmin/Tools
-%{_libdir}/node/wafadmin/*.py[co]
-%{_libdir}/node/wafadmin/*.py
-%{_libdir}/node/wafadmin/Tools/*.py
-%{_libdir}/node/wafadmin/Tools/*.py[co]
+%{_datadir}/systemtap/tapset/node.stp
This page took 0.115425 seconds and 4 git commands to generate.