]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
up to 16.13.2 (fixes CVE-2021-44531 CVE-2021-44532 CVE-2021-44533 CVE-2022-21824)
[packages/nodejs.git] / nodejs.spec
index dc7c863d123e3700f14720c16241648d066cad1a..847859e26e4168fa7473ecbdba1d815239041007 100644 (file)
@@ -7,6 +7,8 @@
 %bcond_without system_uv       # system uv
 %bcond_with    http_parser     # system http-parser and llhttp
 
+%define                _enable_debug_packages  0
+
 # NOTES:
 # - https://nodejs.org/en/download/releases/
 
 # add-on binaries can be loaded in to without needing to be re-compiled. It
 # used to be stored as hex value in earlier versions, but is now represented as
 # an integer.
-%define                node_module_version     72
+%define                node_module_version     93
 Summary:       Asynchronous JavaScript Engine
 Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
-# 12.x LTS - https://github.com/nodejs/Release
-# Active start: 2019-10-21
+# 14.x LTS - https://github.com/nodejs/Release
+# Active start: 2020-10-27
 # Maintenance start: October 2020
-# Maintenance end: April 2022
-Version:       12.18.3
+# Maintenance end: April 2023
+Version:       16.13.2
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 28bf6a4d98b238403fa58a0805f4a979
-
+# Source0-md5: ae3a05fc273536f83c685a7425a7882d
+Patch0:                system_cares.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
@@ -37,32 +39,34 @@ Patch3:             %{name}-lib64path.patch
 Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
 Patch5:                0002-Install-both-binaries-and-use-libdir.patch
 URL:           https://nodejs.org/
-BuildRequires: c-ares-devel >= 1.16.0
-BuildRequires: gcc >= 6:4.8
+BuildRequires: c-ares-devel >= 1.17.2
+BuildRequires: gcc >= 6:6.3
 %if %{with http_parser}
 BuildRequires: http-parser-devel >= 2.9.3
-BuildRequires: llhttp-devel >= 2.0.4
+BuildRequires: llhttp-devel >= 2.1.3
 %endif
-%{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.7}
-BuildRequires: libicu-devel >= 0.64
+%ifarch mips mipsel mips64 mips64el ppc %{arm}
+BuildRequires: libatomic-devel
+%endif
+%{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.9}
+BuildRequires: libicu-devel >= 69.1
 BuildRequires: libstdc++-devel >= 6:4.8
-%{?with_system_uv:BuildRequires:       libuv-devel >= 1.38.0}
-BuildRequires: nghttp2-devel >= 1.41.0
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.42.0}
+BuildRequires: nghttp2-devel >= 1.42.0
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
-BuildRequires: python >= 1:2.7
-BuildRequires: python-jsmin
-BuildRequires: python-modules >= 1:2.7
+BuildRequires: python3 >= 1:3.6
+BuildRequires: python3-modules >= 1:3.6
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel >= 1.2.11
-Requires:      c-ares >= 1.16.0
+Requires:      c-ares >= 1.17.1
 Requires:      ca-certificates
 %{?with_http_parser:Requires:  http-parser >= 2.9.3}
-%{?with_system_brotli:Requires:        libbrotli >= 1.0.7}
-%{?with_system_uv:Requires:    libuv >= 1.38.0}
-Requires:      nghttp2-libs >= 1.41.0
+%{?with_system_brotli:Requires:        libbrotli >= 1.0.9}
+%{?with_system_uv:Requires:    libuv >= 1.42.0}
+Requires:      nghttp2-libs >= 1.42.0
 Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
 Provides:      nodejs(module-version) = %{node_module_version}
@@ -98,7 +102,7 @@ Requires:    %{name} = %{version}-%{release}
 Requires:      gcc
 %{?with_http_parser:Requires:  http-parser-devel >= 2.9.3}
 Requires:      libstdc++-devel
-%{?with_system_uv:Requires:    libuv-devel >= 1.38.0}
+%{?with_system_uv:Requires:    libuv-devel >= 1.42.0}
 Requires:      openssl-devel
 Requires:      zlib-devel >= 1.2.11
 
@@ -113,9 +117,7 @@ Summary:    Documentation for Node.js engine
 Summary(pl.UTF-8):     Dokumentacja silnika Node.js
 Group:         Documentation
 URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
-%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
-%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -147,7 +149,8 @@ Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
-%if %{_lib} == "lib64"
+%patch0 -p1
+%if "%{_lib}" == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
@@ -155,7 +158,7 @@ Sondy systemtap/dtrace dla Node.js.
 %patch4 -p1
 %patch5 -p1
 
-grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
 
 %{?with_system_brotli:%{__rm} -r deps/brotli}
 %{__rm} -r deps/cares
@@ -198,6 +201,7 @@ GYP_DEFINES="soname_version=%{sover}" \
 # CXXFLAGS must be exported, as it is needed for make, not gyp
 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
 LDFLAGS="%{rpmldflags}" \
+PATH="$(pwd)/out/tools/bin:$PATH" \
 %{__make} -C out \
        BUILDTYPE=Release \
        V=1
@@ -205,7 +209,7 @@ LDFLAGS="%{rpmldflags}" \
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
+%{__python3} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
 
 ln -s libnode.so.%{node_module_version} $RPM_BUILD_ROOT%{_libdir}/libnode.so
 
This page took 0.097773 seconds and 4 git commands to generate.