]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
up to 16.13.2 (fixes CVE-2021-44531 CVE-2021-44532 CVE-2021-44533 CVE-2022-21824)
[packages/nodejs.git] / nodejs.spec
index 75a95d34844b5000c0fa3d216e7834bb8e9eab3a..847859e26e4168fa7473ecbdba1d815239041007 100644 (file)
@@ -1,58 +1,82 @@
-#
+# TODO
+# - unpackaged files
+#   /usr/share/doc/node/gdbinit
+
 # Conditional build:
-%bcond_without system_v8       # system v8
+%bcond_without system_brotli   # system brotli
 %bcond_without system_uv       # system uv
-%bcond_without shared  # build libnode.so shared library
+%bcond_with    http_parser     # system http-parser and llhttp
+
+%define                _enable_debug_packages  0
 
 # NOTES:
 # - https://nodejs.org/en/download/releases/
 
-# see "Modules" column in https://nodejs.org/en/download/releases/
-%define                node_module_version     11
+# NODE_MODULE_VERSION refers to the ABI (application binary interface) version
+# number of Node.js, used to determine which versions of Node.js compiled C++
+# add-on binaries can be loaded in to without needing to be re-compiled. It
+# used to be stored as hex value in earlier versions, but is now represented as
+# an integer.
+%define                node_module_version     93
 Summary:       Asynchronous JavaScript Engine
+Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
-Version:       0.10.40
-Release:       3
+# 14.x LTS - https://github.com/nodejs/Release
+# Active start: 2020-10-27
+# Maintenance start: October 2020
+# Maintenance end: April 2023
+Version:       16.13.2
+Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: f6ef20f327ecd6cb1586c41c7184290c
-Patch1:                %{name}-shared.patch
+# Source0-md5: ae3a05fc273536f83c685a7425a7882d
+Patch0:                system_cares.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
-Patch4:                %{name}-use-system-certs.patch
-Patch5:                uv-fpic.patch
-# The invalid UTF8 fix has been reverted since this breaks v8 API, which cannot
-# be done in a stable distribution release.  This build of nodejs will behave as
-# if NODE_INVALID_UTF8 was set.  For more information on the implications, see:
-# http://blog.nodejs.org/2014/06/16/openssl-and-breaking-utf-8-change/
-Patch6:                %{name}-revert-utf8-v8.patch
-Patch7:                %{name}-revert-utf8-node.patch
+Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
+Patch5:                0002-Install-both-binaries-and-use-libdir.patch
 URL:           https://nodejs.org/
-BuildRequires: c-ares-devel
-BuildRequires: gcc >= 5:4.0
-BuildRequires: http-parser-devel >= 2.0
-BuildRequires: libstdc++-devel
-%{?with_system_uv:BuildRequires:       libuv-devel >= 0.10}
-BuildRequires: openssl-devel
+BuildRequires: c-ares-devel >= 1.17.2
+BuildRequires: gcc >= 6:6.3
+%if %{with http_parser}
+BuildRequires: http-parser-devel >= 2.9.3
+BuildRequires: llhttp-devel >= 2.1.3
+%endif
+%ifarch mips mipsel mips64 mips64el ppc %{arm}
+BuildRequires: libatomic-devel
+%endif
+%{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.9}
+BuildRequires: libicu-devel >= 69.1
+BuildRequires: libstdc++-devel >= 6:4.8
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.42.0}
+BuildRequires: nghttp2-devel >= 1.42.0
+BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
-BuildRequires: python >= 1:2.5.2
-BuildRequires: python-jsmin
+BuildRequires: python3 >= 1:3.6
+BuildRequires: python3-modules >= 1:3.6
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: sed >= 4.0
-%{?with_system_v8:BuildRequires:       v8-devel >= 3.15.11.18-2}
-BuildRequires: zlib-devel
+BuildRequires: zlib-devel >= 1.2.11
+Requires:      c-ares >= 1.17.1
 Requires:      ca-certificates
+%{?with_http_parser:Requires:  http-parser >= 2.9.3}
+%{?with_system_brotli:Requires:        libbrotli >= 1.0.9}
+%{?with_system_uv:Requires:    libuv >= 1.42.0}
+Requires:      nghttp2-libs >= 1.42.0
+Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
 Provides:      nodejs(module-version) = %{node_module_version}
 Obsoletes:     nodejs-waf
-ExclusiveArch: %{ix86} %{x8664} arm
+ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                sover   %(echo %{version} | cut -d. -f2)
+# add macro, so adapter won't replace it back literal
+%define                doc_ver %{version}
 
 %description
 Node.js is a platform built on Chrome's JavaScript runtime for easily
@@ -61,96 +85,133 @@ event-driven, non-blocking I/O model that makes it lightweight and
 efficient, perfect for data-intensive real-time applications that run
 across distributed devices.
 
+%description -l pl.UTF-8
+Node.js to platforma zbudowana w opacriu o silnik JavaScriptu
+przeglądarki Chrome, służąca do tworzenia szybkich, skalowalnych
+aplikacji sieciowych. Node.js wykorzystuje nieblokujący model
+wejścia/wyjścia sterowany zdarzeniami, dzięki czemu jest lekki i
+wydajny, dobrze nadający się do aplikacji przetwarzających duże
+ilości danych w czasie rzeczywistym, uruchamianych na rozproszonych
+urządzeniach.
+
 %package devel
 Summary:       Development headers for nodejs
+Summary(pl.UTF-8):     Pliki nagłówkowe nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      c-ares-devel
 Requires:      gcc
-Requires:      http-parser-devel
+%{?with_http_parser:Requires:  http-parser-devel >= 2.9.3}
 Requires:      libstdc++-devel
-%{?with_system_uv:Requires:    libuv-devel}
+%{?with_system_uv:Requires:    libuv-devel >= 1.42.0}
 Requires:      openssl-devel
-%{?with_system_v8:Requires:    v8-devel}
-Requires:      zlib-devel
+Requires:      zlib-devel >= 1.2.11
 
 %description devel
 Development headers for nodejs.
 
+%description devel -l pl.UTF-8
+Pliki nagłówkowe nodejs.
+
 %package doc
-Summary:       Evented I/O for V8 JavaScript - documentation
+Summary:       Documentation for Node.js engine
+Summary(pl.UTF-8):     Dokumentacja silnika Node.js
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
+URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
 BuildArch:     noarch
-%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
 asynchronous event-driven model. Node's goal is to provide an easy way
 to build scalable network programs.
 
-This package contains the documentation for nodejs.
+This package contains the documentation for Node.js.
+
+%description doc -l pl.UTF-8
+Node.js to serwerowe środowisko JavaScriptu wykorzystujące
+asynchroniczny model sterowany zdarzeniami. Celem Node jest
+zapewnienie łatwego sposobu tworzenia skalowalnych programów
+sieciowych.
+
+Ten pakiet zawiera dokumentację Node.js.
+
+%package -n systemtap-nodejs
+Summary:       systemtap/dtrace probes for Node.js
+Summary(pl.UTF-8):     Sondy systemtap/dtrace dla Node.js
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+Requires:      systemtap-client
+
+%description -n systemtap-nodejs
+systemtap/dtrace probes for Node.js.
+
+%description -n systemtap-nodejs -l pl.UTF-8
+Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
-%{?with_shared:%patch1 -p1}
-%if %{_lib} == "lib64"
+%patch0 -p1
+%if "%{_lib}" == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
-%patch7 -p1
 
-grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
 
-rm -r deps/npm
-rm -r deps/cares
-rm -r deps/http_parser
-rm -r deps/openssl
-%{?with_system_uv:rm -r deps/uv}
-%{?with_system_v8:rm -r deps/v8}
-rm -r deps/zlib
+%{?with_system_brotli:%{__rm} -r deps/brotli}
+%{__rm} -r deps/cares
+%if %{with http_parser}
+%{__rm} -r deps/http_parser
+%{__rm} -r deps/llhttp
+%endif
+%{__rm} -r deps/icu-small
+%{__rm} -r deps/nghttp2
+%{__rm} -r deps/npm
+%{__rm} -r deps/openssl
+%{?with_system_uv:%{__rm} -r deps/uv}
+%{__rm} -r deps/zlib
 
 %build
-ver=$(awk '/#define NODE_MODULE_VERSION/{print $NF}' src/node.h)
-if [ $ver != %{node_module_version} ]; then
-       echo "Set %%define node_module_version to $ver and re-run."
-       exit 1
-fi
+ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
+test "$ver" = "%{node_module_version}"
 
 # CC used only to detect if CC is clang, not used for compiling
 CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       %{?with_system_v8:--shared-v8} \
-       --shared-zlib \
-       --shared-openssl \
+       --prefix=%{_prefix} \
+       --libdir=%{_lib} \
+       --openssl-use-def-ca-store \
+       --shared \
+       %{?with_system_brotli:--shared-brotli} \
        --shared-cares \
+       %{?with_http_parser:--shared-http-parser} \
        %{?with_system_uv:--shared-libuv} \
-       --shared-http-parser \
-       --without-npm \
+       --shared-nghttp2 \
+       --shared-openssl \
+       --shared-zlib \
+       --with-intl=system-icu \
        --without-dtrace \
-       --prefix=%{_prefix}
+       --without-npm
 
 # add LFS defines from libuv (RHBZ#892601)
 # CXXFLAGS must be exported, as it is needed for make, not gyp
 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
 LDFLAGS="%{rpmldflags}" \
-%{__make} -C out V=1 BUILDTYPE=Release
+PATH="$(pwd)/out/tools/bin:$PATH" \
+%{__make} -C out \
+       BUILDTYPE=Release \
+       V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_lib}"
 
-%if %{with shared}
-lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
-ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
-ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
-%endif
+%{__python3} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
+
+ln -s libnode.so.%{node_module_version} $RPM_BUILD_ROOT%{_libdir}/libnode.so
 
 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
 
@@ -188,39 +249,32 @@ EOF
 # install documentation
 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
 cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.markdown
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with shared}
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
-%endif
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS ChangeLog LICENSE
+%doc AUTHORS CHANGELOG.md LICENSE README.md SECURITY.md
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
-%if %{with shared}
-%attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.10
-%endif
+%attr(755,root,root) %{_libdir}/libnode.so.%{node_module_version}
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
 %endif
 %dir %{_prefix}/lib/node
 %dir %{_prefix}/lib/node_modules
 %{_mandir}/man1/node.1*
-%{_mandir}/man1/nodejs.1
+%{_mandir}/man1/nodejs.1*
 
 %files devel
 %defattr(644,root,root,755)
-%if %{with shared}
-%{_libdir}/libnode.so
-%endif
+%attr(755,root,root) %{_libdir}/libnode.so
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
 %{_usrsrc}/%{name}
@@ -228,3 +282,7 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 %doc %{_docdir}/%{name}-doc-%{version}
+
+%files -n systemtap-nodejs
+%defattr(644,root,root,755)
+%{_datadir}/systemtap/tapset/node.stp
This page took 0.058803 seconds and 4 git commands to generate.