]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
up to 16.13.2 (fixes CVE-2021-44531 CVE-2021-44532 CVE-2021-44533 CVE-2022-21824)
[packages/nodejs.git] / nodejs.spec
index 6f3e19359dd20ae7d34bd67e2e8da4dd6461d7ac..847859e26e4168fa7473ecbdba1d815239041007 100644 (file)
@@ -3,8 +3,11 @@
 #   /usr/share/doc/node/gdbinit
 
 # Conditional build:
+%bcond_without system_brotli   # system brotli
 %bcond_without system_uv       # system uv
-%bcond_with    shared          # build libnode.so shared library
+%bcond_with    http_parser     # system http-parser and llhttp
+
+%define                _enable_debug_packages  0
 
 # NOTES:
 # - https://nodejs.org/en/download/releases/
 # add-on binaries can be loaded in to without needing to be re-compiled. It
 # used to be stored as hex value in earlier versions, but is now represented as
 # an integer.
-%define                node_module_version     57
+%define                node_module_version     93
 Summary:       Asynchronous JavaScript Engine
 Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
-# 8.x LTS - https://github.com/nodejs/LTS:
-# Active start: 2017-10-31
-# Maintenance start: April 2019
-# Maintenance end: December 2019
-Version:       8.9.3
+# 14.x LTS - https://github.com/nodejs/Release
+# Active start: 2020-10-27
+# Maintenance start: October 2020
+# Maintenance end: April 2023
+Version:       16.13.2
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 88c12ccd5806a101b00139140d958c2b
-Patch1:                %{name}-shared.patch
+# Source0-md5: ae3a05fc273536f83c685a7425a7882d
+Patch0:                system_cares.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
-Patch5:                uv-fpic.patch
+Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
+Patch5:                0002-Install-both-binaries-and-use-libdir.patch
 URL:           https://nodejs.org/
-BuildRequires: gcc >= 6:4.8
-BuildRequires: http-parser-devel >= 2.7.0
+BuildRequires: c-ares-devel >= 1.17.2
+BuildRequires: gcc >= 6:6.3
+%if %{with http_parser}
+BuildRequires: http-parser-devel >= 2.9.3
+BuildRequires: llhttp-devel >= 2.1.3
+%endif
+%ifarch mips mipsel mips64 mips64el ppc %{arm}
+BuildRequires: libatomic-devel
+%endif
+%{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.9}
+BuildRequires: libicu-devel >= 69.1
 BuildRequires: libstdc++-devel >= 6:4.8
-%{?with_system_uv:BuildRequires:       libuv-devel >= 1.18.0}
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.42.0}
+BuildRequires: nghttp2-devel >= 1.42.0
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
-BuildRequires: python >= 1:2.7
-BuildRequires: python-jsmin
-BuildRequires: python-modules >= 1:2.7
+BuildRequires: python3 >= 1:3.6
+BuildRequires: python3-modules >= 1:3.6
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: sed >= 4.0
-BuildRequires: zlib-devel
+BuildRequires: zlib-devel >= 1.2.11
+Requires:      c-ares >= 1.17.1
 Requires:      ca-certificates
+%{?with_http_parser:Requires:  http-parser >= 2.9.3}
+%{?with_system_brotli:Requires:        libbrotli >= 1.0.9}
+%{?with_system_uv:Requires:    libuv >= 1.42.0}
+Requires:      nghttp2-libs >= 1.42.0
+Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
 Provides:      nodejs(module-version) = %{node_module_version}
 Obsoletes:     nodejs-waf
-ExclusiveArch: %{ix86} %{x8664} arm
+ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                sover   %(echo %{version} | cut -d. -f2)
@@ -81,11 +100,11 @@ Summary(pl.UTF-8): Pliki nagłówkowe nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gcc
-Requires:      http-parser-devel >= 2.5.0
+%{?with_http_parser:Requires:  http-parser-devel >= 2.9.3}
 Requires:      libstdc++-devel
-%{?with_system_uv:Requires:    libuv-devel >= 1.6.0}
+%{?with_system_uv:Requires:    libuv-devel >= 1.42.0}
 Requires:      openssl-devel
-Requires:      zlib-devel
+Requires:      zlib-devel >= 1.2.11
 
 %description devel
 Development headers for nodejs.
@@ -98,9 +117,7 @@ Summary:     Documentation for Node.js engine
 Summary(pl.UTF-8):     Dokumentacja silnika Node.js
 Group:         Documentation
 URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -132,19 +149,26 @@ Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
-%{?with_shared:%patch1 -p1}
-#%patch1 -p1
-%if %{_lib} == "lib64"
+%patch0 -p1
+%if "%{_lib}" == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
-#%{?with_system_uv:%patch5 -p1}
+%patch4 -p1
+%patch5 -p1
 
-grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
 
-%{__rm} -r deps/npm
+%{?with_system_brotli:%{__rm} -r deps/brotli}
+%{__rm} -r deps/cares
+%if %{with http_parser}
 %{__rm} -r deps/http_parser
+%{__rm} -r deps/llhttp
+%endif
+%{__rm} -r deps/icu-small
+%{__rm} -r deps/nghttp2
+%{__rm} -r deps/npm
 %{__rm} -r deps/openssl
 %{?with_system_uv:%{__rm} -r deps/uv}
 %{__rm} -r deps/zlib
@@ -158,20 +182,26 @@ CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
+       --prefix=%{_prefix} \
+       --libdir=%{_lib} \
        --openssl-use-def-ca-store \
-       %{?0:--shared-cares} \
-       --shared-openssl \
-       --shared-http-parser \
+       --shared \
+       %{?with_system_brotli:--shared-brotli} \
+       --shared-cares \
+       %{?with_http_parser:--shared-http-parser} \
        %{?with_system_uv:--shared-libuv} \
+       --shared-nghttp2 \
+       --shared-openssl \
        --shared-zlib \
-       --without-npm \
+       --with-intl=system-icu \
        --without-dtrace \
-       --prefix=%{_prefix}
+       --without-npm
 
 # add LFS defines from libuv (RHBZ#892601)
 # CXXFLAGS must be exported, as it is needed for make, not gyp
 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
 LDFLAGS="%{rpmldflags}" \
+PATH="$(pwd)/out/tools/bin:$PATH" \
 %{__make} -C out \
        BUILDTYPE=Release \
        V=1
@@ -179,13 +209,9 @@ LDFLAGS="%{rpmldflags}" \
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
+%{__python3} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
 
-%if %{with shared}
-lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
-ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
-ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
-%endif
+ln -s libnode.so.%{node_module_version} $RPM_BUILD_ROOT%{_libdir}/libnode.so
 
 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
 
@@ -229,20 +255,15 @@ cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with shared}
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
-%endif
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS CHANGELOG.md LICENSE
+%doc AUTHORS CHANGELOG.md LICENSE README.md SECURITY.md
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
-%if %{with shared}
-%attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libnode.so.10
-%endif
+%attr(755,root,root) %{_libdir}/libnode.so.%{node_module_version}
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
 %endif
@@ -253,9 +274,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so
-%endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
 %{_usrsrc}/%{name}
This page took 0.104051 seconds and 4 git commands to generate.