]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
up to 16.13.2 (fixes CVE-2021-44531 CVE-2021-44532 CVE-2021-44533 CVE-2022-21824)
[packages/nodejs.git] / nodejs.spec
index 148d55cd07024c65938e09dee4db7725276da586..847859e26e4168fa7473ecbdba1d815239041007 100644 (file)
@@ -17,7 +17,7 @@
 # add-on binaries can be loaded in to without needing to be re-compiled. It
 # used to be stored as hex value in earlier versions, but is now represented as
 # an integer.
-%define                node_module_version     83
+%define                node_module_version     93
 Summary:       Asynchronous JavaScript Engine
 Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
@@ -25,13 +25,13 @@ Name:               nodejs
 # Active start: 2020-10-27
 # Maintenance start: October 2020
 # Maintenance end: April 2023
-Version:       14.15.5
+Version:       16.13.2
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 12c059975256114cbe983292c20ae26a
-
+# Source0-md5: ae3a05fc273536f83c685a7425a7882d
+Patch0:                system_cares.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
@@ -39,31 +39,34 @@ Patch3:             %{name}-lib64path.patch
 Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
 Patch5:                0002-Install-both-binaries-and-use-libdir.patch
 URL:           https://nodejs.org/
-BuildRequires: c-ares-devel >= 1.16.1
+BuildRequires: c-ares-devel >= 1.17.2
 BuildRequires: gcc >= 6:6.3
 %if %{with http_parser}
 BuildRequires: http-parser-devel >= 2.9.3
 BuildRequires: llhttp-devel >= 2.1.3
 %endif
+%ifarch mips mipsel mips64 mips64el ppc %{arm}
+BuildRequires: libatomic-devel
+%endif
 %{?with_system_brotli:BuildRequires:   libbrotli-devel >= 1.0.9}
-BuildRequires: libicu-devel >= 67
+BuildRequires: libicu-devel >= 69.1
 BuildRequires: libstdc++-devel >= 6:4.8
-%{?with_system_uv:BuildRequires:       libuv-devel >= 1.38.1}
-BuildRequires: nghttp2-devel >= 1.41.0
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.42.0}
+BuildRequires: nghttp2-devel >= 1.42.0
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
-BuildRequires: python3
-BuildRequires: python3-modules
+BuildRequires: python3 >= 1:3.6
+BuildRequires: python3-modules >= 1:3.6
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel >= 1.2.11
-Requires:      c-ares >= 1.16.1
+Requires:      c-ares >= 1.17.1
 Requires:      ca-certificates
 %{?with_http_parser:Requires:  http-parser >= 2.9.3}
 %{?with_system_brotli:Requires:        libbrotli >= 1.0.9}
-%{?with_system_uv:Requires:    libuv >= 1.38.1}
-Requires:      nghttp2-libs >= 1.41.0
+%{?with_system_uv:Requires:    libuv >= 1.42.0}
+Requires:      nghttp2-libs >= 1.42.0
 Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
 Provides:      nodejs(module-version) = %{node_module_version}
@@ -99,7 +102,7 @@ Requires:    %{name} = %{version}-%{release}
 Requires:      gcc
 %{?with_http_parser:Requires:  http-parser-devel >= 2.9.3}
 Requires:      libstdc++-devel
-%{?with_system_uv:Requires:    libuv-devel >= 1.38.1}
+%{?with_system_uv:Requires:    libuv-devel >= 1.42.0}
 Requires:      openssl-devel
 Requires:      zlib-devel >= 1.2.11
 
@@ -114,7 +117,7 @@ Summary:    Documentation for Node.js engine
 Summary(pl.UTF-8):     Dokumentacja silnika Node.js
 Group:         Documentation
 URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
-%{?noarchpackage}
+BuildArch:     noarch
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -146,6 +149,7 @@ Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
+%patch0 -p1
 %if "%{_lib}" == "lib64"
 %patch3 -p1
 %else
@@ -154,7 +158,7 @@ Sondy systemtap/dtrace dla Node.js.
 %patch4 -p1
 %patch5 -p1
 
-grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python3},'
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
 
 %{?with_system_brotli:%{__rm} -r deps/brotli}
 %{__rm} -r deps/cares
@@ -197,6 +201,7 @@ GYP_DEFINES="soname_version=%{sover}" \
 # CXXFLAGS must be exported, as it is needed for make, not gyp
 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
 LDFLAGS="%{rpmldflags}" \
+PATH="$(pwd)/out/tools/bin:$PATH" \
 %{__make} -C out \
        BUILDTYPE=Release \
        V=1
This page took 0.094848 seconds and 4 git commands to generate.