]> git.pld-linux.org Git - packages/nodejs.git/blob - nodejs.spec
ensure no deps being used
[packages/nodejs.git] / nodejs.spec
1 Summary:        Asynchronous JavaScript Engine
2 Name:           nodejs
3 Version:        0.10.15
4 Release:        1
5 License:        BSD and MIT and Apache v2.0 and GPL v3
6 Group:          Development/Languages
7 Source0:        http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
8 # Source0-md5:  59f295b0a30dc8dbdb46407c2d9b2923
9 Patch1:         %{name}-shared.patch
10 # force node to use /usr/lib/node as the systemwide module directory
11 Patch2:         %{name}-libpath.patch
12 # use /usr/lib64/node as an arch-specific module dir when appropriate
13 Patch3:         %{name}-lib64path.patch
14 Patch5:         uv-fpic.patch
15 URL:            http://www.nodejs.org/
16 BuildRequires:  c-ares-devel
17 BuildRequires:  gcc >= 5:4.0
18 BuildRequires:  http-parser-devel >= 2.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libuv-devel >= 0.10
21 BuildRequires:  openssl-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  python >= 1:2.5.2
24 BuildRequires:  python-jsmin
25 BuildRequires:  rpm >= 4.4.9-56
26 BuildRequires:  rpmbuild(macros) >= 1.219
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  v8-devel >= 3.15.11.10
29 BuildRequires:  zlib-devel
30 BuildConflicts: eio
31 Obsoletes:      nodejs-waf
32 ExclusiveArch:  %{ix86} %{x8664} arm
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         sover   %(echo %{version} | cut -d. -f2)
36
37 %description
38 Node.js is a platform built on Chrome's JavaScript runtime for easily
39 building fast, scalable network applications. Node.js uses an
40 event-driven, non-blocking I/O model that makes it lightweight and
41 efficient, perfect for data-intensive real-time applications that run
42 across distributed devices.
43
44 %package devel
45 Summary:        Development headers for nodejs
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       c-ares-devel
49 Requires:       gcc
50 Requires:       http-parser-devel
51 Requires:       libstdc++-devel
52 Requires:       libuv-devel
53 Requires:       openssl-devel
54 Requires:       v8-devel
55 Requires:       zlib-devel
56
57 %description devel
58 Development headers for nodejs.
59
60 %package doc
61 Summary:        Evented I/O for V8 JavaScript - documentation
62 Group:          Documentation
63
64 %description doc
65 Node.js is a server-side JavaScript environment that uses an
66 asynchronous event-driven model. Node's goal is to provide an easy way
67 to build scalable network programs.
68
69 This package contains the documentation for nodejs.
70
71 %prep
72 %setup -q -n node-v%{version}
73 %patch1 -p1
74 %if %{_lib} == "lib64"
75 %patch3 -p1
76 %else
77 %patch2 -p1
78 %endif
79 %patch5 -p1
80
81 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
82
83 rm -r deps
84
85 %build
86 # CC used only to detect if CC is clang, not used for compiling
87 CC="%{__cc}" \
88 CXX="%{__cxx}" \
89 GYP_DEFINES="soname_version=%{sover}" \
90 ./configure \
91         --shared-v8 \
92         --shared-zlib \
93         --shared-openssl \
94         --shared-cares \
95         --shared-libuv \
96         --shared-http-parser \
97         --without-npm \
98         --without-dtrace \
99         --prefix=%{_prefix}
100
101 # add LFS defines from libuv (RHBZ#892601)
102 # CXXFLAGS must be exported, as it is needed for make, not gyp
103 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
104 LDFLAGS="%{rpmldflags}" \
105 %{__make} -C out V=1 BUILDTYPE=Release
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 %{__make} justinstall \
110         DESTDIR=$RPM_BUILD_ROOT \
111         LIBDIR=%{_lib}
112
113 # no dtrace on linux
114 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/lib/dtrace/node.d
115
116 lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
117 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
118 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
119
120 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
121
122 install -d $RPM_BUILD_ROOT%{_includedir}/node
123 cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
124
125 # install for node-gyp
126 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
127 cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
128 ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
129
130 # for compat of fedora derivered scripts (shebangs)
131 ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
132
133 # globally installed node modules (noarch)
134 install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
135
136 # default searchpaths
137 install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
138
139 # create pkgconfig
140 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
141 cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
142 version=%{version}
143 prefix=%{_prefix}
144 libdir=${prefix}/%{_lib}
145 includedir=${prefix}/include/node
146
147 Name: nodejs
148 Description: Evented I/O for V8 JavaScript.
149 Version: ${version}
150 Cflags: -I${includedir}
151 EOF
152
153 # install documentation
154 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
155 cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
156 rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.markdown
157 rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc README.md AUTHORS ChangeLog LICENSE
168 %attr(755,root,root) %{_bindir}/node
169 %attr(755,root,root) %{_bindir}/nodejs
170 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
171 %ghost %{_libdir}/libnode.so.10
172 %if "%{_lib}" != "lib"
173 %dir %{_libdir}/node
174 %endif
175 %dir %{_prefix}/lib/node
176 %dir %{_prefix}/lib/node_modules
177 %{_mandir}/man1/node.1*
178 %{_mandir}/man1/nodejs.1
179
180 %files devel
181 %defattr(644,root,root,755)
182 %{_libdir}/libnode.so
183 %{_includedir}/node
184 %{_pkgconfigdir}/nodejs.pc
185 %{_usrsrc}/%{name}
186
187 %files doc
188 %defattr(644,root,root,755)
189 %doc %{_docdir}/%{name}-doc-%{version}
This page took 0.139948 seconds and 4 git commands to generate.